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General SOX Concepts
Summary

• The same object (e.g., a requirement, system element or function) can be used in multiple documents
and diagrams within a project. Modifying the object in one document affects ALL occurrences of
the object.

• The system design (Model Explorer view) contains all objects available in the project. Other
documents and diagrams contain only a subset of these objects. Creating (or importing) a new
object in a document automatically adds the object to the system design. Deleting an object from a
document does not delete the object in the system design unless explicitly done so.

• Exception: The set of SysML requirements available in the system design is exactly the same as the
set of requirements in the “Requirements” module.

• The main relationships between objects relevant over different documents (e.g., allocation of a
function to a system element) are kept consistent over all documents, too.

• If a change in a document or the system design could affect other documents, a Refactoring dialog
appears, which displays the consequences.

• Benefits for the user:

- All documents are always automatically consistent.

- All created or imported elements are automatically available in the SysML system design.

Details
In SOX, the same objects can be used in multiple modules and documents. For instance, a system
element "A" can be defined in the System Design module and can then be used in multiple safety
analyses, e.g., multiple FMEA documents FMEA1 and FMEA2. There are no copies of "A": All
documents (System Design, FMEA1, FMEA2) refer to the same object. This means that modifying the
object A within one of these documents automatically results in a modification of all other documents
that contain the same element.

fig. An example of elements across documents

The system design contains all objects to be reused within multiple modules. Those reusable objects
are represented by SOX-specific SysML stereotypes in the system design. (A stereotype represents a
custom variation of a standard SysML/UML element – for instance, the stereotype System Element

1



SOX User Guide

represents a specific SysML block that is interpreted in SOX as a system element.) The supported
reusable objects (represented by stereotypes) are: system element, function (including subtypes such
as safety functions, diagnoses and process characteristics), malfunction, requirement, and safety goal.

An exception are project tasks which can also be used in multiple documents but are independent from
the system design and are managed in the “project task” view.

Whenever a new instance of one of these objects is created (e.g. a new system element in an FMEA)
it is automatically added to the system design. All existing system design elements are listed in the
“Model Explorer” view (see below) and can be reused from there, e.g., by dragging and dropping them
into other documents.

fig. The "Model explore"r view

Alternatively, it is possible to open one or more “Object List” views (see below) to show lists of all
existing elements of a specific type.
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fig. The "Object lis"t view

The system design always contains all existing reusable objects (listed in the Model Explorer). But a
specific document (e.g., FMEA, FMEDA, FTA document) or diagram (e.g., SysML Block Definition
Diagram) contains only a subset of them. For instance, an FMEA document displays only those system
elements that are relevant in the context of this specific document. Different documents (e.g., FMEAs)
can contain different subsets of elements. As a consequence, creating a new object within an FMEA
document automatically adds this object to the system design, but creating a new object within the
system design does not automatically affect other documents/diagrams (as those contain only subsets).
Analogously, deleting an object in the system design deletes the object also in all other documents/
diagrams, but deleting an object within a document/diagram does not automatically result in deletion
from the system design. SOX provides a refactoring dialog (see below) which prompts information
about the consequences of object deletion whenever an object is referred to by other documents.

fig. The "Refactorin"g dialog

An exception are requirement documents (RM documents), as there should never be a requirement
that exists only in the system design but is not contained in a RM document. Hence, the relationship
between requirements in the system design and requirements in RM documents is 1:1, i.e., adding/
deleting a requirement on one side automatically results in addition/deletion on the other side. (By
default, Requirements created in a RM document are added in the system design into a package with
the same name as the RM document, but they can be freely moved within the system design without
effects on the RM documents.) This means that imported requirements (e.g., using ReqIF import)
become directly available in the system design, e.g., to link them with system design elements.
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fig. Requirements across SOX modules

The following table lists the types of objects that can be used over multiple documents/diagrams
(leftmost column) and their representation within a specific document (other columns):

fig. Objects that can be used over multiple documents

The main relationships between elements are stored in the system design as well and, hence, kept
consistent across all documents: Containment between system elements, assignment of functions to
system elements, assignment of malfunction to functions, assignment of safety goals to functions.
Again, adding such a relationship in one document automatically creates a corresponding relationship
in the system design (but not vice versa) and deleting such a relationship in the system design can
result in appearance of a “Refactoring” dialog that informs about the consequences.

The following table lists the relationships that are relevant in multiple types of documents/diagrams
and their meaning within a certain document/diagram type:

fig. Relationships that are relevant in multiple types of documents

Starting SOX
Logging in

This dialog appears when starting SOX:
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fig. The Login dialog

1. Enter your user ID.

2. Enter your password.

3. Choose whether you want to save the password, so you do not have to type it in on every startup.

4. Click on OK.

→ You are now logged in.

Setting up the Workspace and Repository
When starting SOX, a dialog opens, asking you to select a workspace.

Workspace:

A workspace is a folder on your hard drive that contains internal data about connections to a repository
and the projects that you have imported from this repository.

Repository:

A repository is a database that contains the actual files of the projects. If you connect to an existing
repository, you can then import its contained projects.

There are two types of repositories:

• Local repository: This is stored locally on your computer. This option is an easy way to test SOX
but it does not allow you to share or access data or catalogs from/with users on other computers
(except using import/export).

• Remote repository: This is stored on a central server, allowing parallel multi-user access and data
sharing. This requires installation of a SOX server, e.g., by your system administrator.
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Each workspace is associated with ONE repository. You can create multiple workspaces on your
computer corresponding to multiple repository connections. Whenever you want to connect to another
repository, you have to switch to another workspace. It is possible to have several workspaces for the
same repository, if there are a lot of projects stored in the repository and you only want to import
specific projects.

To switch between workspaces or to create a new workspace, restart SOX. The dialog "Workspace
Launcher" opens:

fig. "Workspace Launche"r dialog

As a default, there is a folder called “workspace” in the folder in which you installed SOX. You can
also choose another folder by clicking on Browse…

Important: A new workspace needs to be an empty folder! Do not change its content in the Windows
file explorer, only in SOX.

If you always want to use this folder in the future, click on the check box at the bottom of the dialog.
(If you choose this option, you can still select another workspace later: In the menu bar of SOX, go to
File > Switch Workspace. Here you can also see the workspaces that you used last)

Approve the selected folder by clicking OK.

Getting started with Projects

Creating a new SOX Project

1. Right-click inside the repository view. You usually find it on the left when starting SOX.

2. Choose New > SOX Project.

► The "New project" dialog opens.
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fig. "New Projec"t dialog

1. Click on Browse... to choose the target folder on your system or server where the SOX project
will be saved.

2. Choose a name for your SOX project.

3. Write a description of the project (optional).

4. Click on Finish.

→ A new SOX project with all module folders has been added to the project explorer (repository).

Creating a new Folder
Creating a new folder in the project:
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fig. Context menu for new folder

1. Right-click on a SOX project.

2. Choose New > New Folder.

► The dialog "Create new folder" opens.

3. Enter a name for the folder.

→ A folder was created in your project.

---

In the same way you can create a new sub-folder inside a module folder:

fig. Context menu when creating a sub-folder

1. Right-click on a module folder.

2. Choose New > New Folder.

► The dialog "Create new folder" opens.

3. Enter a name for the folder.

→ A sub-folder was created inside your module folder.

Importing a SOX Project

Note

There are two ways to import a project:

• Importing a .zip-file. The imported project will also be added to the repository database you
are connected to.

• Importing a project from the repository into your workspace. This makes the project available
to you locally from your workspace.
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Importing a project:

Right-click inside the repository view and choose Import.

► The "Import" wizard opens.

fig. "Impor"t wizard

1. Click on the arrow next to "SOX".

► A drop-down menu opens.

2. a) Choose Import SOX Project to import a .zip file.

b) Choose Import SOX Repository Project from the repository you are connected to.

3. Click on Next.

9
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fig. "Impor"t wizard page 2

1. Click on Browse... to choose a source file.

2. Click on Browse... to choose the target folder on your system or server where the changes on the
SOX project will be saved.

3. Choose a name for your SOX project.

4. Write a description of the project (optional).

5. Click on Finish.

→ A SOX project has been imported and added to your repository.

Exporting a SOX Project

1. Right-click inside the repository view.

2. Choose Export.

► The "Export" wizard opens.

10
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fig. "Expor"t wizard

1. Click the arrow next to "SOX".

► The drop-down menu opens.

2. Choose SOX Project Export to export a SOX project as a .zip file.

3. Click on Next.
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fig. "SOX Project Expor"t dialog

► The SOX Project Export dialog opens.

Note

You have the possibility to export a SOX project from a earlier date. So incorrect project data
can be reseted.

4. Click on Browse to choose a location for the .zip file.

5. Enter a name for the .zip file.

6. Click on Finish.

→ A SOX project will be exported and saved as a .zip file.

Deleting a SOX Project

Note

There are two ways to delete a project:
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• Deleting the project in the workspace you are currently working in. All your CONNECTIONS
to the files in the repository are erased. The project is no longer visible in your workspace but
it will still exist in the repository. You can later import the project again from the repository
into your workspace.

• Deleting the project from the repository (Warning: All the project files are erased, from your
workbench AND the repository database, for you and every other user of the repository!).

Deleting the whole project from the repository:

1. In the repository view, right-click on the name of the project.

2. Choose Delete.

► The "Refactoring" dialog opens.

fig. "Refactorin"g dialog

3. Make sure you really want to delete everything that has a checked check box.

4. Click on Finish.

→ All the project files are erased from your workbench and the repository.

Deleting only the connections to a project in your workspace:

1. In the repository view, right-click on the name of the project.

► The "Delete Resources" dialog opens.
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fig. "Delete Resource"s dialog

2. Let the box "Delete project contents on disk" unchecked.

3. Click on Preview > if you want to see more about what will be deleted.

4. Click on OK.

→ The project has been deleted from your workbench.

General SOX Functions
Importing SOX Objects

You can import the following SOX objects by using the EnCo Excel template:

Note
You can only import SOX objects, if parent objects exists, which can be used as container.

Object Container (Parent Object)
System Element System Element (the imported Object will be

created on a new level at the FMEA)

Function System Element, FMEDA > Unassigned
functions

Malfunction Function

Diagnosis Diagnosis Group, FMEDA > Diagnoses

Diagnosis Group FMEDA Document

Safety Function System Element

Product Characteristics System Element

Process Characteristics System Element

Interface Function System Element

Governement Function System Element

You can open the import wizard by using the according context menu entry of the corresponding Parent
Object.

The following procedure explains how to import System Elements, Functions and Malfunction to a
FMEA. The template which is used looks like this.

14
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fig. Template with SEs, FUs and MFs.

Precondition: A FMEA with "Spoile"r as root element and an Excel file based on the EnCo template
were created.

1. Right click in the repository view on the created FMEA file.

2. Choose Import > Add objects to FMEA.

► The Importing wizard opens.
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fig. Import wizard.

Click on the Browse button to select your desired excel file. With the Open template button you
can save the EnCo template on your system and edit it afterwards with Excel.

3. Click Next.

► Errors and warning will be shown if available.

4. Click Finish.

→ The objects from the chosen Excel file will be imported.

fig. FMEA with imported objects in SOX.

Document Checksum
To address error cases during export and import of projects in SOX (in SOX internal format), a
checksum is calculated from the exported/imported data: Before export, a checksum is calculated and
stored in the exported file. At the end of each import, the checksum is re-calculated and compared to
the checksum stored in the imported file. A match between the checksums shows that the imported
data exactly matches the original data before export.

In SOX, a generic algorithm has been implemented that traverses any SOX data object (e.g., a BOM
document) and all its contained objects (e.g., components) and calculates a checksum over them. The
checksum for a single data object is created by generation a checksum for each of its properties and
each of its references to other data objects. The checksum for a single property (e.g., component name)
is a checksum for a String composed of the property name and its value. The checksum for a reference
is a checksum for a String composed of the reference name the internal unique IDs of the referenced
elements. For instance, a component refers to its contained failure modes and to the module it is
contained in. Note that we consider containment references as well as references to elements contained
elsewhere.

Cecksum Calculations
Calculate a checksum for BOM content in Excel and in SOX and compare them:

To address error cases during import from an Excel file, a formula is added to the Excel template that
calculates a checksum (e.g., MD5, SHA) from the data in the Excel file. As the formula is contained
in the Excel file, the user has the possibility to check that all relevant data is covered by the formula.
In parallel, SOX calculates a checksum using the same checksum algorithm after importing the data.
SOX then compares the two checksums to ensure that the imported data exactly matches the data in
the Excel sheet.

Calculate checksum for FMEDA evaluation report in SOX and Excel and compare them:

To detect any errors in the FMEDA evaluation report (in Excel format), a checksum (see Appendix
A) is calculated from the relevant data in SOX and displayed to the user. In addition, a formula is

16



SOX User Guide

generated into the evaluation report that enables to re-calculate the checksum within Excel based on
the data in the Excel file. The user can ensure that the data in the Excel file is identical to the data in
SOX by comparing the two checksums.

Review catalog and calculate and store a checksum for the catalog to detect modifications:

To detect errors in standard failure rate catalogs or standard failure mode catalogs, each relevant
standard catalog was reviewed manually by an expert. Afterwards, a checksum was calculated to from
the catalog data that is stored as part of the catalog to detect any changes in the catalog. Each time SOX
starts, the checksum is re-calculated and compared to the checksum stored in the catalog. A match
indicates that the catalog is identical to the reviewed catalog.

Review failure mode catalog and calculate and store a checksum for the catalog to detect
modifications:

The measure has been applied to the standard failure rate catalogs delivered with SOX:

• Birolini

• IEC 62380

Causes for Checksum Mismatch

External modification of exported project files:

If the exported project file is modified externally, e.g., by incomplete file transfer or manual
modification, the checksum will be mismatch.

Errors in SOX import/export:

If any project content after importing a project differs to the original project content before the export,
the checksum will mismatch.

Changes in the internal SOX data model between different SOX versions:

Importing a project that was exported with an earlier version of SOX can lead to a checksum mismatch
if the internal SOX data model differs. For instance, if a property with a default value is added to the
data model in a new SOX version, all imported projects will be initialized with the default value during
project import, resulting in a different checksum compared to the same project in earlier versions. To
mitigate this case, SOX internally stores changes in the data model and which SOX document types
are affected by this change. In this way, SOX can indicate the user (for each document type) whether
a checksum mismatch was expected due to changes in the SOX data model.

Limitations

In case of changes in the data model between different SOX versions, SOX can only indicate the user
that a mismatch is expected due to data model changes. But there is no way to find out if the data model
change is the only cause of the mismatch. However, SOX can in addition indicate which document(s)
mismatch and, in case of BOM/FMEDA documents, which modules and components (if any).

The User Interface of SOX
Overview of the User Interface

1. User Interface

17
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fig. User interface overview

[1] Menu bar

[2] Toolbar

[3] Perspective picker

[4] Editor

[5] General views

[6] Model Explorer

[7] Repository

General Concepts of the User Interface
Views

The user interface of SOX consists of multiple "views", rectangular parts of the user interface. Views
are typically used to navigate a list or hierarchy of information or display properties for the active
editor. The views can be freely opened, closed and arranged.

The most important and special views are the repository view and the editor.

The repository view:

The repository view is where you can find all of your SOX projects and files. You usually find it on
the left when starting SOX. You always start here, whether you create a new project, import a project
or open an existing project. You get more information on that in the chapter "Getting started with
Projects".

The editor:

You will mostly work within the editor, using the other views as an aid. You get a specific editor for
every module.

---
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Rearranging views:

You can change a view´s location on the screen with drag & drop:

1. Click on a view´s tab and hold the mouse button.

2. Move the cursor to another location in the same stack of views, or even to a different stack of views.

► A gray vertical line indicates where it will be placed.

3. Release the mouse button.

→ The view´s tab has been placed at the new location.

---

You can even create a new stack (or area) for views:

When you drag a view around the screen, you can see that at certain places a double gray line appears.
This indicates that a new stack will be created, if you release the mouse button there.

---

Minimizing views:

In the upper right corner of a view click on .

→ The whole stack of views has been minimized and moved to the left or right of the screen.

19
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---

Maximizing views:

In the upper right corner of a view, click on .

→ All the other sets of views have been minimized and moved to the left or right of the screen.

---

Restoring views that have been minimized:

1. Find the minimized views to the left or right of the screen.

2.
Click on the "restore" button to the left or right of the screen: 

→ The stack of views has been restored.

Perspectives
Perspectives are predefined collections of views for the specific modules.

You find all the currently open perspectives to the very upper right:

"SOX Workbench" is the default perspective, you start from here. Here you find the repository view,
which lets you access all your files.

If you double-click on a file in the repository view in the workbench perspective, the corresponding
perspective will open.

Perspectives can also be customized to fit your own workflow. It is even possible to create new
perspectives.

1.
Click on the Open Perspective icon: 

► The "Open Perspective" dialog opens.

2. Choose the desired perspective.

3. Click the OK button to finish.

→ SOX is opened in the chosen perspective with the corresponding views.

To customize the perspective, click on  Window  in the menu bar.

For more information on each perspective, read the chapters about each module:

• System Designer

• Reliability

• FMEA

• FMEDA
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• Requirements

• FTA

• Hazard Analysis

Editor

fig. Editor overview

These are the three main parts of the editor:

The register [1] at the top shows the currently opened project.

The documents will be displayed and can be edited in the main part of the editor [2].

The register at the bottom [3] shows the currently opened documents.

Menu Bar

File
• Close

Close single/all windows in the explorer.

• Save

Save single/all changes in your current project.

• Print

Print FMEDA, BOM, Hazard, Requirements.

• Switch Workspace

SOX stores your projects in a folder called workspace. Choose a workspace folder to use for this
session.
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• Restart

Restart SOX.

• Import

Import FMEDA, BOM, Requirements, Excel.

• Document Properties

Change general properties of the selected document.

• Exit

Closes the application.

Edit
• Preferences

Opens the "Preferences" dialog to get options to change the preferences of your installation of SOX.

Administration
• User administration

Opens the security management view for administrators.

• Change passwords

Change the administrator password.

Window
• Hide Toolbar

The toolbar can be hidden and shown.

• Show view

Views can be added to the currently open perspective.

• Open Perspective

Different perspectives can be opened here.

• Save Perspective As

Perspectives can be customized by adding or removing views and added to the default perspectives.

• Reset Perspective

Reset the current perspective to its defaults.

• Close Perspective

Closes the current perspective.

• Close All Perspectives

Closes all open perspectives.
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Help
• Help Contents

Opens the help viewer.

• Search

Searches for terms from the help contents.

• License Manager

Shows informations about your license. Furthermore you can request a new license or copy the
current ID.

• About

Shows information about your SOX version.

Variant

Note

The menu "Variant" will be added to the menu bar, after you have opened a SOX project or
document.

You can add, edit or delete variants for the selected document. Variants are listed at the "Select variant"

icon at the toolbar  or in the PSS view.

Precondition: Your document needs to be open and selected.

Adding a variant:

1. Navigate to Variants in the menu bar.

2. Click on add variant.

► The Variant dialog opens.

3. Choose a name for this variant.

4. a) Click on Finish.

→ A variant with all objects of the selected document has been added.

b) Click on Next.

5. Select the objects that include the variant.

6. Click on Finish.

→ A variant with the selected objects has been added.

Toolbar

---
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All icons in the toolbar explained:

Icon Name Function

Enable write Make it possible to write
in the selected area.

Disable write Make it impossible to
write in the selected area.

Save all Save all changes of
the current project.

Save Save only the changes
of the current document.

Refresh Refreshes all entries. It often
solves calculation problems.

Undo Undo the last step.

Redo Redo the last step.

Move selected element up Move the selected element up.

Move selected element down Move the selected
element down.

Show trace decorators Show trace decorators

Show sequential decorators Show sequential decorators

Hide filtered parts Hide all filtered parts.

Variant select Select an applied variant.

Operation mode Select an applied
operation mode.

Create a new table from
the configurations catalog

Create a new table from
the configurations catalog.

Refresh the current diagram Refresh the current diagram.

Line style action Line style action

Select action Select action
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Icon Name Function

Arrange action Arrange action

Align action Align action

Align text Text align left/center/right

Show/Hide action Show/Hide action

Routing action Routing action

Distribute action Distribute action

Make same size Make same size of objects

Create a new table Create a new table

Create a new diagram Create a new diagram

General Views
These views are available in each default SOX perspective. They contain information and
functionalities that can be used in the whole project and are not specific to a certain SOX module.

History

fig. The "Histor"y view

The history view shows you details about a selected object´s history, e.g. when and by whom it was
created and edited.

Checking the history of an object:
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1. Select an object in the editor.

2. Click on the the button "Link with Editor and Selection":

→ You can now see the history of the object.

Properties

fig. The "Propertie"s view

In the properties view you find the following options to the left:

• General:

The properties view displays general information about a selected object. Also, this information
can be edited.

• Comments:

All comments of a selected object will be shown in this register.

Creating a new comment:

1. Right-click on an object.

2. Choose New > New Comment.
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fig. Context menu for new comment

→ A new comment has been added to an object and provided with the comment icon.

• Hyperlinks:

All hyperlinks of a selected object will be shown in this register.

Creating a new hyperlink:

1. Right-click on an object.

2. Choose New > New Hyperlink.

fig. Context menu for new hyperlink

► The "Add Hyperlink" dialog opens.

3. Enter a name for the hyperlink.

4. Enter the URL.

5. Click the OK button to finish.
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→ A new hyperlink has been added to the object and will be shown in the properties view.

• Traces:

The traces of an object will be shown in this register.

Clipboard

fig. The "Clipboar"d view

The clipboard is for storing objects, e.g. system elements, functions, malfunctions.

Place objects here with drag & drop so you can use them later:

1. Click on the object and hold the left mouse button.

► The cursor changes to a circle with a bar crossing through it.

2. Hold the mouse button and move the cursor to the clipboard view, over the field >>Drag<<.

► The cursor changes. A plus sign appears next to the cursor.

3. Release the mouse button.

► The object appears in the lower part of the clipboard.

→ The object is now constantly available in the clipboard.

You can drag it from the clipboard onto other objects.

---

Removing an object from the clipboard:

1. Select an object in the clipboard.

2.
Click on "Remove selection from clipboard": 

→ The selected object has been removed from the clipboard.

---

Removing all objects from the clipboard:

1. Select any object from the clipboard.

2.
Click on "Clear clipboard": 

→ All objects have been removed from the clipboard (they still exist everywhere else).
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Model Explorer

fig. The "Model Explore"r view

All existing system design elements (in the same project you are currently working in) are listed in
the "Model Explorer" view and can be reused from there, e.g., by dragging and dropping them into
other documents. Alternatively, it is possible to open one or more "Object list" views to show lists of
all existing elements of a specific type.

Sort elements alphabetically.

Customize the Model Explorer.

Toggle advanced Model Explorer.

Link with editor. This feature makes it easier
to select objects: If this is active, every object
you select in the editor will also be immediately
selected in the model explorer and the other way
round.

Show diagrams. This shows all diagrams in the
model and filters out everything else.

Object List
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fig. The "Object lis"t view

The "Object list" view shows a list of often needed objects. At first this view is empty.

Showing a list:

1.
Click on the browse button .

► The "Catalog selection" dialog opens.

fig. "Catalog selectio"n dialog

2. Select the desired object type.

3. Click OK.

→ The selected objects will be shown in the object list view.

Note that you can open as many of these object list views as you need! Just click on "New Catalog
View" and a new object list view will be added. The purpose of this view is to make it easier and faster
for you to get access to all the objects in your project.
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Catalogs
Norm Catalogs

fig. The "Catalog"s view

In this view you can find all the catalogs (norms) that are shipped with SOX. You can also copy those
catalogs and then edit them to fit your own demands. There are two folders in this view: "System"
and "Public".

System:

The system folder contains all the catalogs that are shipped with SOX. You cannot edit the catalogs
in the system folder!

Copying a catalog:

1. Right-click on a catalog.
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2. Choose Copy.

→ A copy of the catalog appears in the folder "Public".

Public:

Here you can find the copied catalogs. You can also create new catalogs by right-clicking inside the
public folder and choosing New. All users of the same repository can access the "Public" folder.

To edit a catalog, double-click on it, and the catalog editor will open:

fig. The catalog editor

Employee Catalog

In the employee catalog you can define team members. You can access the whole catalog of employees
across your projects. In the catalog you can assign team members to projects, add contact information
and, later on, you can assign those team members to tasks.

Opening the employee catalog:

Precondition: The "Catalog"s view is open.
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fig. Location of employee catalog

1. In the view "Catalogs", open System > Employee Catalogs > Employees.

2. Double-click on Employees.

→ The employee catalog is open.

fig. The employee catalog editor
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To the left of the employee catalog editor you find the hierarchical structure of companies, departments
and employees [2].

At the top there is a filter field [3]. Type in text and it filters the list.

You find a bar of buttons [1]:

"Home" takes you back to the beginning of the list ("Employees"), after navigating down the hierarchy.

"Back" moves you back in the hierarchy (you have to select an entry first).

"Go into" moves you deeper into the structure.

"Collapse all" closes all the expanded levels.

"Show deactivated employees": Normally all the employees that are deactivated (=deleted) are not
shown in the list. This lets you see them again. They are shown in gray.

When you click on an employees name, information about this employee appears to the right [5]. You
can see and enter contact information for this employee, the full name and where the employee works.

You can also deactivate the employee if he / she no longer works for the project [6].

If you have an account with the rights to manage SOX user accounts, you can also edit SOX user
information [4] (optional).

--

Adding a new company:

Right-click on Employees and choose New > Company.

--

Adding a new department:

Right-click on a company and choose New > Department.

--

Adding a new employee:

Right-click on a company or a department and choose New > Employee.

--

You can edit the structure with drag and drop, e.g. you can move an employee to a different department
or another company.

--

Deleting / deactivating employees:

You can either click the checkbox "Deactivated" [6] or right-click on an employee and click Delete.

PSS
The Project System Structure (PSS) view gives an overview of all related objects which have been
created within your project. Furthermore objects can be created and managed for each module.
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fig. The "PS"S view

One of the most important functions in the PSS is the drag & drop function. This allows you to assign
existing objects to other objects. For example, a system element can thus be linked with a requirement.

Traces
The view "Traces" shows all objects in a project that are related to the object that you selected.

You can see the names of the related objects, the direction of the relationship and the relation type.

Check the filters in the upper right corner for "Incoming references" and "Outgoing references".
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fig. "Trace"s view

For an overview of all the traces in a project, open the trace matrix.

Suspect Marker

Suspect markers ( ) indicate that a related object has been changed. Use this as a tool to make sure
that changes to an object do not have unintended consequences elsewhere. After a change has been
made to an object, the icons of all the related objects in the project receive a suspect marker.

After you made sure that the related objects do not need to be adjusted, you can delete the markers
for the object.

Suspected links have to be enabled for each project. You do this when creating a new project, or you
can do it later in the document properties by making a check mark at "Enable suspected links".

When the suspected links have been enabled in a project, the suspect marker filter gets enabled at top
of the Suspect Marker view.

Deleting suspect markers:

1. Select the object with the marker (you can also select multiple objects by keeping the Ctrl key
pressed).

2. Select the suspected links in the suspect marker view.

3. Choose Delete.

→ The suspect marker has been deleted.

Select the object with the marker (you can also select multiple objects by keeping the Ctrl key pressed).
Now select the suspected links in the suspect marker view and choose Delete.
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Working with Variants
You can add variants to your documents. This way you can analyze different versions of your system
without having to create entirely new documents for each version. You decide which objects (for
example which functions) are relevant to a certain variant.

Adding Variants
Adding a variant:

1. In the menu bar at the top, click on Variants > Add variant.

► The "Variant" wizard opens.

2. Enter a name.

3. Click on Next >.

4. Select the elements that you want to be part of the variant.

5. Click on Finish.

→ A new variant has been added.

Selecting Variants
To select a variant, look in the menu bar: Click on the triangle next to "V select".

Then click on the name of a variant. All the objects that are not part of the variant will now be displayed
in gray.

To deselect a variant, click again on the triangle, then on "Deselect variant".

Editing Variants
You can add objects to the variant (or remove the objects from them) by right-clicking on the object
and choosing Edit.... Then go to the tab "Variants".

You can also get an overview over your variants and edit them in the variant matrix:

In the repository view in the perspective "SOX Workbench", right-click on a document (e.g. your
FMEA document), then choose Open with > Variant matrix. Here you see the objects in your file,
plus a column for each variant that you created.

The objects displayed are: elements, functions, malfunctions, action groups.

In the columns, checkboxes mark which object is part of the variant. This gives you a good overview
over your variants. You can edit the variants here by clicking the checkboxes. In the right upper corner
you have a button that lets you create a new variant.

Deleting Variants
Delete a variant by going to the menu bar, clicking Variants > Delete variant, then choose the
respective variant.

You can also delete variants in the variant matrix: Right-click on the name of the variant and click
on Delete.
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Working with Versions
SOX allows you to save projects in different versions. This means SOX freezes the project to its current
state and provide it with a timestamp. They are mainly intended for comparison purpsoes.

Each project starts at a branch called "Main". Branching means you diverge from the "Main" line of
development and continue without messing with that main line. A green decorator behind the project

name shows on which branch the project currently is , and which timestamp

the version or project has  (Use the register "Team" at the SOX
preferences dialog for activating or deactivating these decorators).

If you are opening the project directory, you can see the branching directory which contains all created
versions. Furthermore you can switch between versions with a double click on the according one, or
using the "Select branch\version" dialog which can be opened by making a right-click on the project
or branch directory and choose Team > Switch to head or version.

fig. Repository View with opened Branching Directory.
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Creating a Version
Precondition: A SOX project was created and the repository view is active.

1. Make a right-click on the branch directory or the project.

2. Choose Team > Create version.

fig. Context Menu of Branch Directory.

► The Create a new Version dialog opens.
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fig. Create a new Version dialog.

3. Select a branch

4. Choose Time for diverging the version at the current state.

5. Enter a Name for the version.

6. Activate the checkbox for opening the project in this version.

7. Click OK.

→ The version will be created and added to the branch directory.

Deleting a Version
Versions can be delete by making a right-click on the according version and choose delete.
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fig. Deleting a Version.

User Administration
The User Administration editor provides access to all operations for managing SOX user accounts and
permissons. You can find the User Administration editor at:

1. Menubar, Administration > User Administration
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fig. Menubar Administration

This opens an editor that presents users, groups, and roles in a convenient layout with the most
commonly used properties editable right in the editor. Intuitive drag-and-drop gestures associate users,
groups, and roles as you would expect.

User Administration Editor

fig. User Administration View

[1] User Groups

[2] Users

[3] Roles

User Groups

In this section you can create and manage user groups. User groups are a collection of users and can

be usefull e.g. for displaying different departments. Click on the "new group" icon  for creating

a group. To delete a group, select the desired one and click on the "delete" icon .

Groups can be assigned with roles by selecting the deisred group and clicking the New or Add... button
at the Roles section for creating or adding roles.
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fig. Group Details

[1] The given group ID is also the displayed name of the group.

[2] In the users section you can (un-)assign users to the selected group.

[3] In the roles section you can (un-)assign roles to the selected group.

Users

A SOX user is a member of your projects with individual access to SOX. SOX users can be provided

with different roles and permissions. Click on the "new user" icon  for creating a user. To delete

a user, select the desired one and click on the "delete" icon . Users can be assigned with roles
by selecting the desired user and clicking the New or Add... button at the roles section for creating
or adding roles.
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fig. User detials.

[1] Section for providing the selected user with basic information. The given user ID is also the
displayed name in SOX.

[2] Button for resetting the password.

[3] In the groups section you can (un-)assign groups to the selected user.

[4] In the roles section you can (un-)assign roles to the selected user.

Note

New created SOX users are not provided with a password by default. Only the User ID is required
for their first login. We recommend to alert the user to create a password after logging in for the
first time.

Roles

In this section you can create and manage roles. Click on the "New Role" icon  for creating a new

role. To delete a role, select the desired one and click on the "delete" icon .
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fig. Roles detials

[1] Name of the selected role.

[2] Section for defining persmissions for resources (folder, projects, documents, etc.)

Acess:

• WRITE

The user/group can open and edit the defined resource

• READ

The user/group only can see and open the defined resource

Kind

• EXACT

Exact the defined resource is affected.

• TREE

The complete defined directory of the defined resource is affected.

• ANT/REGEX

Regular expressions for the resources.
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Path Filter

• Resource of the SOX repository.

[3] In the groups section you can (un-)assign groups to the selected role.

[4] In the users section you can (un-)assign users to the selected role.

The following screenshot shows an example for providing an user (TestUser) with READ-ing rights
for Project11 and WRITE-ing rights for Demo-Project-EMS.

Note

It's importand to have reading and writing rights for the root directory. This is necessary for
importing reasons.

fig. Example Reading and Writng Rights

In the example screen you can see reading and writing rights for $projects[1], which is the root folder
for other projects. The kind EXACT is choosen, so only the project folder is affected. That makes
sure that the folder $projects can be edited and other projects imported to this directory, and rights not
passed to the sub directory and folders.

Resetting User Password
The Reset Password... button lets the Administrator reset a user's password e.g. it has been forgotten.
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fig. Reset Password dialog.

On successful reset, an info dialog shows the new randomly-generated password to the Administrator
with a button to copy it to the clipboard to easily share it with the user, who then should change it
at the next opportunity.

fig. Password change dialog.

State Machines and Workflows
A workflow is a set of statuses and transitions that and object moves through during its lifecylcle
and typically represents processes within your organization. There are individual workflows for the
modules Requirements, Test, Hazard, Reliability and FMEDA. This workflows are binded on to
the listed modules and can only used for the according ones. The workflows will be saved in your
repository and affects all projects. The following table shows which objects of the modules can be
assigned with states:

SOX Modul Object State
FMEDA/BOM Modules, Components
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Requirements Modules, Requirements

Test Test Case

Test Run

Hazard Ratings

Customizing Workflows
Workflows can be customized to your desire. You can define or edit transitions, states or actions.

fig. Open Workflows

For opening the workflows

1. Click on the menu point Administration.

2. Choose Edit state machines.

3. Select your desired workflow.
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► The selected workflow will be opened.

Note

Edits at workflows are not saved automatically. Be sure to click on Save  or (Ctrl + S) if you
are leaving the workflow editor. A (*) symbol in front of the workflow name displays changes at
the workflow which aren't already saved.

fig. Workflow Editor

The workflow editor is simmilar to all workflows and is divided into the following parts:

Transistions [1]

fig. Transition Matrix

In the transistion matrix you can edit the transitions and consequently set actions between two statuses.
After you have created a new state and action you can click in the empty cell between two states and
choose the desired action.
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States [2]

fig. State Matrix

In the state matrix you can organize your states for the current workflow. You can create, delete and
provide them with custom icons, colours, description and set them as initial state.

Create a new state:

1.
Click on the plus icon (  )at the state matrix.

► New rows will be added to the state and transition matrix and a new state object will be added
to the transition graph.

2. Enter a unique ID at the ID column (Recommendation: name + State + Id).

3. Enter a name at the name column.

4. Make a double-click into the cell at the icon column.

► The Icon selection dialog opens.
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fig. Icon selection dialog.

In this dialog you can find all default SOX states icons. With the plus symbol ( ) you can add
icons (.png) from your system. The icon size (16x16) should not be exceeded. With the x symbol

( ) you can remove a selected icon from the SOX database.

5. Select your desired icon and click OK.

6. Make a double-click into the cell at the color column.

This color will be set as background color for the according object at the defined state.

7. Activate the checkbox at the initial column for setting the according state as starting state when
creating a new object. Initial states can't be deleted.

8. Optionally, enter a description for the according state.

→ A state with the defined properties was created and added to the states matrix, transition matrix
and transition graph.
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Actions [3]

fig. Actions Matrix

In the action matrix you can define new actions, which are necessary for trigger a transition between
to states.

Create a new action:

1.
Click on the plus icon (  )at the action matrix.

► A new row will be added to the action matrix.

2. Enter a unique ID at the ID column (Recommendation: name + Action + Id).

3. Enter a name at the name column.

4. Make a double-click into the cell at the roles column for giving a SOX user the permissions for
executing the according action.

5. Optionally, you can activate the checkbox at the auto on change column. If the auto on change
function is active, every change and edit at a object leads to the transition which is assigned to
this action.

→ A new action was created and added to the action matrix, transition graph and can be selected at
the transition matrix.
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Transisition Graph [4]

fig. Transistion Graph

The transition graph displays the worklfow as a diagram. You can move the statuses for designing the
structure of the diagram to your desire.

Importing/Exporting Workflows

With the buttons in the right upper corner, you can export ( ) or import ( ) workflows in SOX.
The workflows will be saved as .sxcat which is a SOX catalogs format and XML as base language.

The Trace Matrix
The trace matrix shows the relations between all the objects in your project.

You open the trace matrix by clicking on the icon in the menu bar:

fig. Icon Trace Matrix

Then the trace matrix opens. Here is an example:
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fig. The Trace Matrix

Click on the plus signs in the rows and columns to expand the columns.

You can also use the Collapse... and Expand... buttons below the table to show or hide rows.

You can find these abbreviations in the table:

fig. The abbreviations in the Trace Matrix

54



SOX User Guide

Notice that in the table the colors of a cell fade to white either to the left or to the right. This indicates
the direction of the relationship:

fig. A Relation in the Trace Matrix

To find more easily what you are looking for, there are filtering options:
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fig. Filter for the Trace Matrix

Above the table there are text filters for the rows and for the columns.

When you click the "Filter" tab at the bottom you can filter the rows and columns for content, type
and traces:

Click on the check boxes and go back to the trace matrix.

The matrix is now filtered.

Icons in SOX
Icons for SOX Modules

Icon Description

Workbench

System Design module

Requirements module

Hazard module

FMEA module

FMEDA module
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Icon Description

FTA module

SOX project

Icons for Views
Icons Description

Clipboard

Repository

Model Explorer

Catalogs

Dynamic Help

Object list

Task Assignments

Project Tasks

Traces

Failure net

Function net

Failure net explorer

PSS

Project safety goals

Structure content

FIT Details

Properties view

Temperature Profiles

Mission Profiles

Failure rate catalogs

Failure mode catalogs

Overview

Diagnoses view

Relationship matrix
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Icons Description

Form sheet

Control Plan

Risk Matrix

Malfunction Analysis

Pareto Analysis

Diagnoses

Miniature view

Variant Matrix

Icons in Views

View Icon Description

various views Minimize view

various views Maximize view

various views restore view

various views Link with editor

various views Add object

various views Text filter

various views Suspect marker

Clipboard Clear clipboard

Clipboard Remove selection from clipboard

Traces view Show outgoing references

Traces view Show incoming references

Model Explorer Toggle Advanced Model Explorer

Model Explorer Customize Model Explorer

Model Explorer Sort elements

PSS Hide prevention actions

PSS Hide detection actions

PSS Hide service actions
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View Icon Description

PSS Hide operation actions

PSS Hide construction actions

PSS Hide tasks

PSS Hide safety goals

PSS Hide requirements

PSS Hide malfunction

PSS Hide functions

Properties view Pin to current selection

Object list view Sort by safety level

Task Assignments view Switch to horizontal layout

Task Assignments view Switch to vertical layout

Editor FMEA & FMEDA Functions on/off

Editor FMEA & FMEDA Malfunctions on/off

Editor FMEA & FMEDA Safety goals on/off

Editor FMEA & FMEDA Requirements on/off

Editor FMEA & FMEDA Tasks on/off

Modules view Hide components

Functions view Hide diagnoses

Project tasks view Switch to horizontal layout

Project tasks view Switch to vertical layout

Icons for Catalogs
Icon Description

Failure mode catalog

Failure rate catalog

Function catalog

Machine catalog

Malfunction catalog

Rating catalog
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Icon Description

System element catalog

Icons in the Reliability Module
Icon Description

Component module

Component

imported component

changed component

deleted component

Failure mode

Icons in the FMEA Module
Icon Description

Comment

System element

Function

Malfunction

Connected function

Action group

Construction action

Operation action

Service action

Prevention action

Detection action

Safety goal

Process characteristic

Product characteristic

Security function

Interface function

Government function
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Icon Description

Edit significance rating

Edit classification

Form sheet

Control plan

Requirement

Task (active/rejected/proposed)

Task (inactive/proposed)

Edit Safety Goal Assignments

Icons in the RM Module

Icon Description

Safety Goal

Requirement

Requirement Attribute

Requirement Type

Type Definition

Element linked with Requirement

Safety goal linked with Requirement

Open Status Impact Dialog

Icons in the HA Module

Icon Description

Comment

Variants

Function

Malfunction

Safety goal

Hazard

Combined situation
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Icon Description

Effect

Relationship matrix

Motivation

Icons in the FMEDA Module
Icon Description

Comment

Operation modes

Variants

Function

Malfunction

Safety goal

Failure mode catalogs

Component module

Component

imported component

changed component

deleted component

Failure mode

Icons in the FTA Module
Icon Description

OR

AND

VOTING

Base event

House event

Intermediate event

Page break

Failure model
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Other Icons
Icon Description

Copy

Delete

Import

Export

Collapse

Expand

Open preferences

Comment

Operation modes

Variant

Task (active/rejected/proposed)

Task (inactive/proposed)

Preferences

Decompose ASIL level
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FMEA

Failure Mode and Effects Analysis.

The FMEA module of SOX supports you in the risk analysis according to VDA 6 and AIAG.

Here you can create nets of elements, function nets and failure nets, define actions and rate objects.

You can work with different variants and operation statuses.

You can link information with other SOX modules.

The FMEA analysis tools include the risk matrix, malfunction analysis and Pareto analysis.

You can create form sheets and control plans.

In this help guide, you will learn about the customizable user interface and the many ways to complete
a task.

An easy step-by-step guide will help beginners of SOX to quickly get familiar with the software.

Step-by-Step Guide
In this chapter you will learn the basics of the module, while creating a simple FMEA, from start to
finish.

We recommend going through this guide and actually performing all the steps. Performing a simple
FMEA from start to finish with SOX will give you a real understanding of the software.

This chapter requires knowledge on the basic SOX principles and standard views described in the
chapter Workbench.

Creating a new FMEA File
Precondition:   A SOX project was created.

1. You start in the repository view in the workbench perspective. Here, right-click on the FMEA folder
in your project.
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fig. New FMEA file from repository

2. Choose New > New FMEA File.

► The "New File" dialog opens.

fig. "New fil"e dialog

3. In the now opened dialog, click on Browse... next to "Target folder".

4. Choose the desired folder.

5. Enter a name for your file.

6. You need to define a system element that acts as the root of your FMEA.

a) Define a new root element by entering a name for it.

b) If you already have an element in your project that you want to use as a root element: Choose
an existing root element by clicking on Browse... next to "Root Element" and clicking on your
element of choice in the list.

7. Choose the type of FMEA that you want to create ("PRODUCT"; "PROCESS" or "DESIGN").

8. Choose the ratings catalog. (Later, in the view Catalogs, you can also define your own catalogs.)

9. Write a description of the file (optional).

10.Click on Finish.

11.In the alert that opens, click on Yes to open the editor in the FMEA perspective. (If you previously
marked the check box to "Remember..." and clicked No, you have to open the perspective in the
menu bar: Windows > Perspectives > FMEA.)

→ A new FMEA file has been created and opened.
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Creating System Elements
Note

There are multiple views in which you can create new objects. The result will always be the same,
regardless if you do it in the FMEA editor or another view.

1. Right-click on the root element.

fig. New system element

2. Choose New > New system element.

► The "Add new system element" dialog opens.
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fig. "Add new system elemen"t dialog

3. In the first line, "Add", make sure "System element" is selected.

4. Enter a name for the new system element.

5. Decide whether you want the sequence number of the system element to be determined
automatically by SOX with a consecutive number. You can enter your own sequence number
(optional).

6. Type a description into the "Description" box (optional).

7. If you are working with variants in your project, you can assign the new system element to a variant.
Click on Variants and choose one (optional). (See also the chapter Working with Variants.)

8. If you want to add another system element, click on Save & New.
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9. When you are done adding elements, click on OK.

→ The new system elements have been added.

Now add lower level system elements: Just repeat the process, starting with a right-click on the parent
system element.

Adding Functions to a System Element
Note

There are multiple views in which you can select a system element and add functions to it: The
FMEA editor, the structure content view and the PSS view. The result will always be the same.

1. Right-click on the system element.

fig. New function

2. Choose New > Function.

► The "Add new function" dialog opens.
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fig. "Add new functio"n dialog

3. In the first line, "Add", make sure "Function" is selected.

4. Enter a name for the new function.

5. Decide whether or not you want the sequence number of the function to be determined automatically
by SOX. You can enter your own sequence number (optional).

6. Type a description into the "Description" box (optional).

7. Choose the function type (function, diagnosis, safety function, product characteristics, process
characteristics). The standard type is "function". Choosing "diagnosis" adds another tab to the
dialog, giving you the option to add more attributes regarding diagnosis.

8. If you want to add another function, click on Save & New.
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9. When you are done adding functions to this system element, click on OK.

→ The functions have been added.

Further explanation of the "Add Function" dialog:

Under the tab "Functions" you can see if there are other functions already added to this system element.
Under the tab "Variants" you can assign the function to an existing variant (if you already have variants;
see also the chapter Working with Variants). Under "Catalog" you can see all functions of your project.

Adding Malfunctions to a Function
Note

There are multiple views in which you can create new objects or edit them. The result will always
be the same, regardless if you do it in the FMEA editor or another view.

1. Right-click on a function.

fig. New malfunction

2. Choose New > New malfunction.

► The "Add new malfunction" dialog opens.
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fig. "Add new malfunctio"n dialog

3. Enter a name for the new malfunction.

4. Decide whether you want the sequence number of the malfunction to be determined automatically
by SOX. You can enter your own sequence number (optional).

5. Type a description of the new malfunction into the "Description" box (optional).

6. If you want to add another malfunction, click on Save & New.

7. When you are done adding malfunctions to this function, click on OK.

→ The new malfunctions have been added.
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Connecting Functions/Malfunctions
Creating a function net and creating a failure net both work the same. You connect a function with
another function (or a malfunction with another malfunction respectively) with drag & drop:

1. With the mouse cursor over a function, press the left mouse button and hold it.

► The function is highlighted with a yellow background.

2. Move the cursor over the function that you want to connect it with.

► Next to the cursor a rectangle and a plus sign appear.

3. Move the cursor to the left and to the right: You will notice that the function´s background becomes
yellow either to the left or to the right side. To connect a function with a lower level system element,
the background has to light up on the right (facing the function it connects to).

fig. Connecting functions

4. Release the mouse button.

► The icons next to the two functions´ names change: They now also have two smaller dots,

pointing to the other function.

→ The two functions are now connected.

Do the same with the malfunctions.

Now that you have connected the (mal)functions, you can see them (and work with them!) in other
views:

The Function net explorer and Failure net explorer:

The Function net explorer and Failure net explorer show hierarchical structures (top-down) of the
system elements and functions / malfunctions.

The Function net / Failure net views:

These two views show how a function or malfunction is connected to others. Just double-click on a
function / malfunction in the editor and the respective view shows how it is connected to the others.

For more information on these views, read the respective chapters:

Function net view
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Failure net view

Function net explorer

Failure net explorer

Editing the FMEA Structure

Moving Objects

In the FMEA editor you have the possibility to restructure the objects. For this you can change the
position of system elements, functions and malfunctions with drag and drop.

You can also move several objects at once. For this you need to hold the Ctrl key, click on the elements
you want to select and then drag them to the desired target position.

Copying Objects

In order to copy objects, you have the following possibilities:

• In the editor you can copy an object with drag and Ctrl + drop. You need to drag the selected object
to the desired position and then press Ctrl when you want to drop the object. In that way a copy
will be saved at the target location.

• Right-click and choose the options Copy or Paste.

• Select the object you want to copy. Press the key combinations Ctrl + C in order to copy an object
and Ctrl + V to paste it again at the desired location.

Within the PSS you can make copies in the same way.

• With Drag and Ctrl + drop you can also copy objects from the PSS to the editor.

• It is also possible to copy several objects at once. Select the desired objects while holding pressed
the Ctrl key and then copy them.

Deleting Objects

In any view, you have the following options to delete an object:

• open the context menu with a right-click on the object and then click on Delete.

• select the object by clicking on it, then press the Del key.

You can select multiple objects at once by pressing the Ctrl key while selecting further objects.

When deleting there will always appear the "Refactoring" dialog, which informs you of the changes
regarding the objects´connections in the SOX project. Using the check boxes, make sure that only the
desired objects will be removed, then click on Finish.

Deleting Connections between Functions/Malfunctions

After you created a function net or failure net (see Connecting Functions and Malfunctions) you can
delete connections between (mal)functions in the function net view and the failure net view.

Here you can delete connections in two ways:
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• open the context menu with a right-click on the line between two (mal)functions and then click on
Delete.

• select the line by clicking on it, then press the Del key.

Adding Safety Goals to a Function
Precondition:   The "Project safety goal"s view needs to be open and contain safety goals. If the view
is not already open, click on Window in the menu bar, then Show view > Project safety goals. Usually
the safety goals are defined in the Requirements module, but you can also add new safety goals here
by right-clicking in the "Project safety goal"s view.

Use drag & drop to add a safety goal to a function:

1. In the Project safety goals view, click on your safety goal and hold the mouse button.

2. Move the cursor to the desired function.

► Next to the cursor, a rectangle and a plus sign appear.

fig. Adding safety goal

3. Release the mouse button.

→ The safety goal is added to the function.

Adding Action Groups
Note

There are multiple views in which you can create new objects or edit them. The result will always
be the same, regardless if you do it in the FMEA editor or another view.

First you add an action group to a malfunction. Action groups consist of construction actions, operation
actions, service actions, and each of those have prevention actions and detection actions. After that
you rate the actions and add tasks to them.

Adding a new action group:

1. Right-click on a malfunction.
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fig. Context menu on malfunction

2. Choose New > New Action Group.

► The dialog "New action group" appears.

fig. "New action grou"p dialog

3. Enter a name for the new action group.

4. Enter an abbreviation. It is restricted to one character. The abbreviation is meant for the table in the
project tasks view. There it will be the name of a column, allowing easy authentication.

5. With the check box, decide if you want to assign the new action group to all malfunctions on the
same level.

6. Click OK.
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► A triangle appears next to the malfunction. 

→ A new action group has been added and been assigned to the malfunction.

If you did not assign the new action group to all malfunctions of the same structure layer, you still
have the option to do this afterwards:

Right-click on an action group, then choose New > Assign to all malfunctions of the same layer.

SOX offers you the possibility to use revision states multiple times once they have been established.
In that way, you can assign one action group to several malfunctions.

Adding an existing action group:

1. Right-click on a malfunction.

2. Choose New > Action Groups and then your desired action group.

→ The action group has been added to the malfunction.

Rating Malfunctions and Actions
The following ratings are possible:

•  significance rating (or severity rating) for malfunctions (S)

•
 prevention rating (or occurrence rating) for actions (O)

•
 detection rating for actions (D)

Rating Malfunctions

Note

The ratings that are available depend on the ratings catalog that you chose.

Editing the significance (or severity) rating of a malfunction:

1. In the editor or any other view, right-click on a malfunction.
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fig. Context menu on malfunction

2. Choose Edit significance rating.

► The dialog "Properties for Malfunction" opens.
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fig. Dialog significance rating

3. Choose a rating.

4. Click on Finish.

→ The malfunction now has a rating.

Classifying Malfunctions and Functions

You can add a classification to a cause of failure. If you do so, you can then see the classification in
the form sheet.

Adding a classification:

1. Right-click on a function or malfunction.
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fig. Context menu on function/malfunction

2. Choose Edit classification.

► The classification dialog opens.
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fig. Dialog classification

3. Choose from one of the following:

NC: Not classified

S: Safety compliant

CC: Critical characteristic

PC: Potential critical characteristic

SC: Significant characteristic

PSC: Potential significant characteristic

4. Click OK.

→ A classification has been added.

Rating Actions
To rate the actions in your new group:

1. Click on the triangle next to the malfunction.

You see the assigned action group(s).

2. Click on the triangle next to the action group.

► The list of actions expands.
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3. You will see three types of actions: "construction actions", "operation actions" and "service actions".
Each of the three are divided into "prevention action" and "detection action". Choose one and make
a right-click on it to open the context menu.

fig. Context menu on action types

4. Choose Edit prevention rating.

► The dialog for the occurrence rating opens.

5. Choose a rating.

6. Click OK.

7. Right-click on Detection action.

8. Choose Edit detection rating.

► The dialog for the detection rating opens.

9. Choose a rating.

10.Click OK.

11.Make sure you repeated all this for construction actions, operation action and service action.

→ Your actions now have a rating.

Adding Tasks
You can assign tasks to all objects (system elements, functions, requirements). These are shown in the
window "project tasks". This is especially important for the actions.

Note

There are multiple views in which you can create new objects or edit them. The result will always
be the same, regardless if you do it in the FMEA editor or another view.

Adding a new task:

1. Right-click on an object.

2. Choose New > Assign new Task.

► The dialog "Assign new task to: ..." appears:
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fig. "Assign task to: ..". dialog

3. Enter a name for the new task.

4. Enter a description (optional).

5. Set the status.

6. Set the priority.

7. Set the correct dates.

8. Assign a responsible person.

a) Choose an existing one from the drop-down menu.

b) Or create a new one by clicking on the plus sign.

9. Click on Finish.

→ The task has been added.

The icon of a malfunction changes when a task has been added: 

All tasks are shown in the view "Project tasks".

Creating a Form Sheet
You can create a form sheet for system elements. If you have a process FMEA, read about control plans.
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Creating a form sheet:

1. Right-click on a system element.

fig. Context menu on system element

2. Choose Open form sheet.

► The "Form sheets" dialog opens.

3. a) Click "Select existing" to choose from existing form sheets.

b) Click "New" and enter a name for a new form sheet.

→ The form sheet editor opens.

You can go back to to the normal FMEA editor using the tab at the bottom of the editor. You can close
the form sheet by clicking the x button in the form sheet tab at the bottom of the view.

You can get a more detailed description of the form sheet editor here.

Opening the FMEA Analysis
SOX supports the analysis of FMEA including a risk matrix, evaluation of malfunctions, and a pareto
analysis. To start the analysis perform the following steps:

1. Go to the repository view in the workbench perspective.

2. Right-click on your FMEA file.
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fig. Context menu on FMEA file

3. Choose Open with > FMEA analysis.

→ The editor has changed to the FMEA analysis.

Note that you will see these tabs at the bottom of the editor:

Use these tabs to navigate between the risk matrix, the malfunction analysis and the Pareto analysis,
and to go back to the FMEA editor.

Working with the Risk Matrix
Here is an example of a risk matrix:

fig. Risk matrix

The x-axis [4] shows the severity and the y-axis [1] shows the occurrence probability rating.

Directly below the risk matrix, there is a table summarizing the key figures of the malfunctions. If this
table is not visible, make the view bigger by clicking and dragging the lower line further down.
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The first six columns of the table are: malfunction, function, system element, actions, classification,
significance rating.

Then you can see the occurrence rating, detection rating and RPN for the assigned construction actions
[5], for the operation actions [6] and for the service actions [7].

Below the table, there is a counter [2] showing the number of malfunctions that are shown in the table.

Filtering options for the table:

• Directly above the table, there is a filter [3] where you can enter text to filter for certain objects.

• You can click on a square in the risk matrix. (De-select the square by clicking on one of the white
squares.) You can select multiple squares at once by holding Ctrl while clicking.

• You can click on the filter button in the right upper corner of the view. This opens the "Choose
action groups" dialog.

Note that in the preferences menu you have options to adjust the size and to hide columns. You can also
change the style of the risk matrix from the VDA style (red, yellow and green) to the RG style (red and
green). You can change the detection value split for the RG style. You can decide which squares of the
risk matrix have which color. You do this by selecting a square, and then clicking on one of the buttons
labeled with a color name. You can select multiple squares at once by holding Ctrl while clicking.

A right-click in the table below the matrix opens a context menu:

• Go To

Opens the FMEA editor and shows the selected object.

• Configure table

Opens a dialog with check boxes that can show or hide certain columns.

• Reset to default

Resets your choice about which columns you wanted to show or hide.

• Show text filter

Here you can show or hide the "Enter filter text" field above the table.

• Export table

This exports the table to Excel.

• Export selection

Opens the selected part of the table in Excel.

For a better filtering possibility for your malfunctions, go to the Malfunction analysis by clicking on
the tab Malfunction analysis at the bottom of the view.
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Evaluating Malfunctions
The malfunction analysis (or malfunction evaluation) gives you the possibility to conduct a detailed
search for elements with the help of different filters.

To use the filters, collapse the filter options by clicking on the plus signs.

The filtered data will be displayed in the table below.

Enter your data and then click on the button "Filter" to get the results.

In the first filter block, you can filter for malfunctions. You can also filter for classification or S rating.
For this you need to enter a range you want to filter at the respective places. You can use the signs <
(smaller), <= (smaller or equal), > (bigger), >= (bigger or equal) or = (equal).

It is also possible to filter the malfunctions according to the respective actions. This is what the filter
in the middle is there for.

There you can also decide, whether you want to filter for construction and/or operation and/or service.
The following criteria can be used here: A rating, S rating and RPN. You can again choose one of the
comparing signs and enter a corresponding value.

In the last filter block, you can filter for malfunction tasks. You have the following possibilities:

Name, state with or without comparing signs, priority with or without comparing signs, responsible,
created (period of time), last changes (period of time), deadline (period of time) and completed (period
of time).

Performing a Pareto Analysis
The last element in the lower tab of the FMEA Analysis is the Pareto analysis.

With the help of a Pareto diagram, from a multitude of problem causes you can extract those problem
causes which have the strongest impact. You can see the importance of a cause directly in the diagram.

In your diagram you can see the RPN, the risk share and the revision state A (B).

If you move your mouse over the diagram, the values will be shown directly. If you click in the diagram,
the respective element will also be highlighted in blue in the table.

Below the diagram, there is a table with the malfunctions. You can filter this table by entering a certain
word into the filter field above it.

Note that you have the option to filter the results by clicking on the filter button in the right upper
corner of the view. This opens the "Choose action groups" dialog.

A right-click in the table opens a context menu:

Here you have the following options:

• Go To
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Opens the FMEA editor and shows the selected malfunction.

• Configure table

Opens a dialog with check boxes that can show or hide certain columns.

• Reset to default

Resets your choice about which columns you wanted to show or hide.

• Show text filter

Here you can show or hide the "Enter filter text" field above the table.

• Export table

This exports the table to Excel.

• Export selection

Opens the selected part of the table in Excel.

Note that there are options regrading the pareto analysis in the preferences menu: You can adjust the
x- and y-axis and change the labeling of the axis and the diagrams title. You can also show grid lines.

User Interface
Below you see all the standard views in the FMEA perspective. Remember that you can always open
views by going to the menu bar and clicking Window > Show View. You can also rearrange the views
with drag & drop.

fig. FMEA perspective

[1] FMEA editor

[2] Structure Content View / Clipboard / PSS / Failure net explorer / Function net explorer
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[3] Project safety goals

[4] Failure net / Function net

[5] Model Explorer / Catalogs / Object list

FMEA Editor
The FMEA editor shows all process- and system elements of an FMEA document. You can also see
the associated functions, malfunctions, product features, process features, diagnosis and the project
safety goals. It is possible to create and edit all objects right here in the editor.

Note that you can edit some general settings for the FMEA editor in the preferences menu:

You can choose the width of the boxes representing the elements. You can enable animations. You can
show comments as a tool tip: If you activate this, every comment will be shown as an overlay tool tip
when the mouse cursor is above an object in the editor.

Here you see the elements and how they are connected.

If you double-click on an element, all the structure layers to its left disappear. Show them again by
clicking on the names of the elements that are shown in the left upper corner of the editor:

E.g.:

You can show or hide the elements to an element´s right by clicking on the + or - sign:

The other objects that are associated with the elements (functions, malfunctions etc.) are shown
beneath each element.

You can collapse and expand the list of objects under an element by clicking on the triangle in front
of the name:

In the right upper corner of the view you find these filtering options:

•  Show/Hide functions

•
 Show/Hide malfunctions
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•
 Show/Hide safety goals

•
 Show/Hide requirements

•
 Show/Hide tasks

The Context Menu
Clicking with the right mouse button anywhere in the editor and also in views (e.g. the function net
and failure net views) will open the context menu. In it you will find a lot of different options, ranging
from the adjustment of the editor (e.g. zoom) to working with elements (e.g. adding new functions).

First we will look at the options you get when right-clicking on an empty space. Then we will look at
the options you get when right-clicking on certain objects.

Options when making a right-click on a free space
When making a right-click on a free space in the FMEA document, you will get to choose from several
options, which are also available when selecting an object:

fig. Context menu on free space

•
 Expand all

Expands all children of all system elements.

•
 Collapse all

Collapses all children of all system elements.

• Show structure layer

Here you can select which structure layer will be displayed.

fig. Show structure layer
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fig. Example of structure layers

• Zoom

Here you can zoom in or out in the respective view, depending on the chosen factor.

• Filter

Here you can decide which kinds of elements are shown in the FMEA editor. This can make it easier
for you to get a clear overview. You can also access these filters as buttons in the upper right corner
of the FMEA editor.

fig. Filter

• Show/Hide functions

•  Show/Hide malfunctions

•
Show/Hide requirements

•
Show/Hide tasks
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• Open preferences

Select this option to open the preferences menu.

Options when making a right-click on a system element
Right-click on a system element in order to access the following options:

fig. Context menu on system element

• New

•
 System element

Here you can create a new system/process element. Alternatively, you can also create a new
system element by using the key combination Ctrl + Shift + G.

More information can be found in the chapter Creating System Elements.

•
 Process element

Here you can create a process element. This is done in the same way as you create a system
element.

•  New function

Here you can add functions to a system element. Alternatively, you can also use the key
combination Ctrl + Shift + F to create a new function.

More information can be found in the chapter Adding Functions to a System Element.
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•
 Product characteristics

Adds a product characteristic to the selected system/process element.

•
 Process characteristics

Adds a process characteristic to the selected system/process element.

•
 New Security Function

Adds a security function to the selected system/process element.

•
 New Interface Function

Adds an interface function to the selected system/process element.

•
 New Government Function

Adds a government function to the selected system/process element.

•
 Requirements and trace

Assigns a new requirement to the selected element. More information on this topic can be found
in the chapter Creating new Requirements.

•
 Assign new task

Assigns a new task to the selected element. Alternatively, you can also use the key combination
Ctrl + Shift + T in order to assign a new task.

More information on this topic can be found in the chapter Assigning a new Task.

•  New Comment

Adds a new comment to the selected element. More information on this can be found in the
chapter Comments.

Alternatively, you can also select the object, then use the key combination Ctrl + Shift + C to
insert a new comment.

Or you select the object, go to the properties view, then Comments. Then click on the plus sign
in the upper right corner of the view.

• Edit system element

Select this option in order to edit the system elements you have created.

• Edit

With this option you can edit the selected system/process element. Clicking on this option opens
the characteristics dialog of the system/process element.

Alternatively, you can also edit your system element by using the Return key.

•
Save a system element as a new FMEA
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Choose the location in the project where you want to save the document.

•
 Copy

Choose this option in order to copy the selected object or system/process element.

Alternatively, you can also copy the selected system element by pressing the key combination Ctrl
+ C.

• Delete

Choose this option in order to delete the selected object or system/process element.

It should be taken into consideration that the children of the object will also be deleted.

Alternatively, you can also delete the selected system element with the Del key.

• Form sheet editor

Choose this option in order to open the form sheet editor. Here you can add or edit further
information on the FMEA project .

More information on the form sheet editor can be found in the respective section.

• Control plan

This is only visible for process elements. Choose this option to create a control plan.

•
 Operation modes

By choosing this function, the operation or service of the selected element is included or excluded,
depending on the respective selection.

• Convert

With this option, you can convert a system element into a process element or a process element
into a system element.

•
Expand all

•
Collapse all

• Show structure layer

Reduces the view to the selected structure level.

• Zoom

Lets you zoom in or out in the respective view, depending on the chosen factor.

• Filter

Hide or show different system/process elements.

• Properties

Opens the properties dialog.

•
Preferences
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Choose this option to open the preferences dialog.

Options when making a right-click on a function

fig. Context menu on function

• New

• New malfunction

Creates a new malfunction for the selected function. Read more on this in the chapter Adding
Malfunctions to a Function.

Alternatively, you can also use the key combination Ctrl + Shift + M to create a new malfunction.

•
 New Requirement and Trace

Assigns a new requirement to the selected element. More information on this topic can be found
in the chapter Creating new Requirements.

•
 Assign new Task

Assigns a new task to the selected element.

Alternatively, you can also use the key combination Ctrl + Shift + T to assign a new task.

More information on this topic can be found in the chapter Assigning a new Task.

• Comment

Adds a new comment to the selected element. More information on this can be found in the
chapter Comments.
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Alternatively, you can also use the key combination Ctrl + Shift + C to insert a new comment.

•
 Edit classification

Edits the safety classification of the selected function.

If you have chosen a safety classification, an abbreviation of the selected classification will be shown
in front of the edited function.

• Edit function

Opens the dialog for editing the selected function.

Alternatively, you can also edit your function by using the Return key.

•
 Copy

Choose this option in order to copy the selected object or system/process elements.

Alternatively, you can also copy your selected function by using the key combination Ctrl + C.

• Delete

Choose this option to delete the selected function or functions.

Alternatively, you can also use the Del key to delete your function.

•
 Expand all

•
 Collapse all

• Display structure level

Reduces the view to the selected structure level.

• Zoom

Lets you zoom in or out in the respective view, depending on the chosen factor.

•
 Operating mode

By choosing this function, the operation or service of the selected element is included or excluded,
depending on the respective selection.

• Convert

 Convert into a process characteristic

Converts the selected function into a process characteristic.

 Convert into a product characteristic

Converts the selected function into a product characteristic.

 Convert into a safety function.
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Converts the selected function into a safety function.

• Properties

Opens the properties dialog of the function.

• Open Preferences

Choose this option to open the preferences dialog.

Options when making a right-click on a malfunction

fig. Context menu on malfunction

• New

•
 Assign new Task

Assigns a new task to the selected element.

Alternatively, you can also use the key combination Ctrl + Shift + T to assign a new task.

More information on this topic can be found in the chapter Assigning a new Task.

•
 New Action Group

Choose this option in order to create a new group of actions (or measures). Read more on this
in the section Adding Actions.

•
 Action Groups

Choose this option in order to integrate your selected malfunction into a group of actions.
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•  New comment

Adds a new comment to the selected element. More details on this can be found in the chapter
Comments.

You can also insert a new comment by using the key combination Ctrl + Shift + C.

• Add from Model

If you added an object in the System Design module, you can quickly add this object to another
object in the FMEA module here. See: Adding from Model

•
 Edit Safety Goal Assignments

Assign or remove safety goals from the selected element.

• Edit

Opens the "Edit" dialog.

Alternatively, you can also edit your malfunction by using the Return key.

•
 Edit significance rating (severity rating)

If you have added a rating catalog to your FMEA, you can edit your S rating here.

•
 Edit classification

Edits the safety classification of the selected function.

If you have selected one of these safety classifications, an abbreviation of the selected classification
will be shown in front of the edited malfunction in your editor.

•
 Copy

Choose this option in order to copy the selected object or system elements.

Alternatively, you can also use the key combination Ctrl + C to copy your selected function.

•  Remove significance rating

Only visible if the malfunction already has a significance rating.

• Delete

Choose this option in order to delete the selected function or functions.

You can also delete your function by pressing the Del key.

•
 Operation mode

By choosing this function, the operation or service of the selected element is included or excluded,
depending on the respective selection.

•
 Expand all
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•
 Collapse all

• Display structure level

Reduces the view to the selected structure level.

• Zoom

Lets you zoom in or out in the respective view, depending on the factor chosen.

• Filter

Lets you show or hide different system elements.

• Properties

Opens the properties dialog of the function.

•
 Open Preferences

Opens the preferences dialog.

Structure Content View
In the structure content view you can get an overview of the contents (child-objects) of the selected
system- or process element.

Furthermore, you can create and edit new actions, system- / process elements, functions and
malfunctions here.

You can also add tasks (tasks are converted into FMEA measures here) and safety goals. In the header
of this view you will find the following functions:

•
 Hide / show prevention actions

•
 Hide / show detection actions

•
 Hide / show service actions

•
 Hide / Show operation actions

•
 Hide / Show construction action

•
 Hide / show tasks

•
 Hide / show safety goals

•  Hide / show malfunctions

•
 Hide / show functions

•
 Collapse all

98



FMEA

Hides all layers except for the root element.

You can also use the key combination Ctrl + Shift + Numpad_Divide.

•
 Link with editor

If this option is activated, the structure view will be linked with the FMEA editor. If you then select
an element in the structure view, this element will automatically be selected in the FMEA editor as
well. The same happens if you select an element in the FMEA view.

FMEA Ratings Catalogs
You can create several ratings catalogs or you can edit the existing, active ratings catalogs. The editing
dialog for the rating catalogs can be opened from the Catalog view with a right click on the public
folder:

fig. Catalogs view.

Note

The standardized catalogs in the system folder can't be edited.

Edit FMEA ratings catalogs

Select the ratings catalog you want to edit in the list. Afterwards, you can edit the name of the ratings
catalog or modify the descriptions of the individual entries. In order to modify the properties of an
entry, please click on the desired field in the table. You can then directly enter your changes in the
table. Standard ratings catalogs included in the software package cannot be edited. However, they can
be copied and then edited afterwards.

Create, edit, delete ratings catalogs

In order to create a new rating catalog please click on  New.  Then a new rating catalog with the title
"New rating catalog" is established. This can then be edited according to your needs. In order to delete
a ratings catalog, select the respective catalog in the drop-down list and then click on Delete. Please
bear in mind that there has to be always at least one rating catalog.

Import & export ratings catalogs
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Ratings catalogs can be saved as a file and then restored.

To export a ratings catalog, right-click on it, then choose Export .

Click on Export in order to export a ratings catalog.

PSS View - Project System Structure
The Project System Structure view gives you an overview of all documents that belong to your
project. This overview is not limited to FMEA documents, but also includes FMEDA, HA and other
documents.

In this view, you also have the possibility to drag elements to the FMEA or to other SOX modules,
for example the FMEDA.

In the upper right corner you can find the following symbols for the structuring of the PSS:

•
 Hide / show prevention actions

•
 Hide / show detection actions

•
 Hide / show service actions

•
 Hide / show operation actions

•
 Hide / show construction actions

•
 Hide / show tasks

•
 Hide / show safety goals

•  Hide / show malfunctions

•
 Hide / show functions

•
 Collapse all (Ctrl + Shift + Numpad_Divide)

•
 Expand all (Ctrl + Shift + Numpad_Multiply)

•
 Link to editor

•
 View menu

•
 Minimize
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•
 Maximize

The PSS:

fig. The PSS view

• Safety goals

For a more detailed description, please go to the section Performing a Pareto Analysis.

• Project hazards

Here you see the hazards that are in your projects.

• Project team

Here you will find a list of all team members.

Add a new team member:

When making a right-click on Project team and then on New member, the following dialog will
open:
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fig. "Add Team Membe"r dialog

Name, Surname and Company are mandatory fields.

Optionally, you can add the following information: Department, Telephone (business), Telephone
(private), Mobile, Fax, Email.

• BOM

• FMEA

• FMEDA

• FTA

• HA

Note

You have to manually save a document first and you possibly also have to update the Project
System Structure in order to get a complete and correct list of all objects of the respective modules.

There are options in the preferences menu for the PSS view regarding FMEA: You can filter what is
shown and you can decide how the view expands when opening it and when adding parts
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Project Safety Goals View
This view provides you with an overview of your project and safety goals summarized in a table. The
following attributes are included: name, safety level, current, safe state, coverage EOT, FTT, FTZI,
FIT, save reduction, warning concept.

By making a right-click on a safety goal, you will get to the following options:

fig. Context menu on safety goal

• New

•
 New hazard

This will open the dialog "Add new hazard".

•
 Assign new task

Choose this option to assign a new task  or use the key combination Ctrl + Shift + T.

•
 New safety goal

This will lead you to the dialog "New safety goal":
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fig. "New safety goa"l dialog

Please insert the name of the safety goal and the safe state.

Optionally, you can also add the following information:

EOT, FTT, FTZI, FIT, safe reduction, warning concept, safety coverage, norm, safety level.

Clicking on OK will confirm the safety goal and close the dialog, clicking on Save & proceed will
save the safety goal and directly reopen the dialog "New safety goal".

•
 New sub safety goal

To assign a new secondary safety goal to a selected safety goal, make a right-click on the desired
safety goal and then click on New sub safety goal.

•
 Comment

Opens the "Add comment" dialog..

• Edit

This opens the "Edit safety goal" dialog.

•
 Copy

Choose this option to copy your safety goal or use the key combination Ctrl + C.

•  Delete

This automatically opens the dialog "Refactoring".

Here you get information about the consequences and can delete all elements which are linked to
your selected safety goal.

Function Net View
This view shows how a function is connected to others. Just double-click on a function / malfunction
in the editor and the function net view shows how it is connected to the others.

In the header of this view you can choose between the following options:

 Hide / show system- / process elements

This option gives you the possibility to hide or show the system / process elements which belong to
a certain function.

 Hide / show malfunctions

This option gives you the possibility to hide or show the malfunctions which belong to a certain
function.

Additionally, you can minimize or maximize the view with the respective buttons.

Note that in the preferences menu under "FMEA" you have filtering options for the function net view
and the malfunction net view.
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Creating Function Nets
There are two possibilities to create a function net. Either in the view "Function net" or directly in the
FMEA editor. Function nets can be created by using the drag & drop function.

Creating a function net in the function net view:

In order to create a new function net, double-click on a function in the FMEA editor first. The
respective function will then be displayed in the Function net view.

Afterwards, you can create the function net by dragging further functions from the structure content
view or the FMEA editor onto already existing functions in the function net.

Here it is important where you drop the functions: If you drop them in the front part of a function,
they will be placed in front of the function, if you drop them in the rear part of a function, they will
be placed behind the function.

The functions are then all linked:

fig. Function net view

Creating a function net in the FMEA editor:

Drag a function from within the FMEA editor or from the PSS or structure content view and drop it
onto another function, in order to link them in the function net.

The icons of the functions can change. This shows you whether functions are already included in a
function net or not. The icon shows you how the functions are linked with each other:

 Function has no links

 Function has one or more successors.

 Function has one or more predecessors

 Function has one or more successors and predecessors

Deleting a link:

Right-click on the link line in the function net and choose the option Delete.

Function Net Explorer
If you have created a function net, this and all other previously created function nets will be displayed
in the function net explorer.
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The Function net explorer shows hierarchical structures (top-down) of the system elements and
functions.

fig. Function net explorer

Failure Net View
This view shows how a malfunction is connected to others. Just double-click on a function /
malfunction in the editor and the failure net view shows how it is connected to the others.

fig. Failure net view

The icons at the top of the view let you hide certain objects.

Note that in the preferences menu under "FMEA" you have filtering options for the function net view
and the malfunction net view.

Creating Failure Nets
You have two options to create a failure net. One in the failure net view and one directly in the FMEA
editor. You can create failure nets with drag & drop.

Creating a failure net in the failure net view:

106



FMEA

To create a new failure net, double-click on a malfunction in the FMEA editor. The selected
malfunction will then be displayed in the failure net view.

Then you can create the failure net by dragging further malfunctions from the structure content view
or the FMEA editor onto already existing malfunctions in the failure net.

Here it is important where you drop the malfunctions: If you drop them in the front part of a
malfunction, they will be placed in front of this malfunction, if you drop them in the rear part of a
malfunction, they will be placed behind this malfunction.

Creating a failure net in the FMEA editor:

Drag a malfunction from within the FMEA editor or from the PSS or structure content view and drop
it onto a malfunction in order to link it in the failure net.

Note that the icons of the malfunctions can change. This shows you if malfunctions are already part
of other failure nets. The icon shows how the malfunctions are interlinked:

 Malfunction has no link

 Malfunction has one or more successors

 Malfunction has one or more predecessors

 Malfunction has one or more predecessors and successors.

In order to create further failure nets, please go to the FMEA view. Double-click on a malfunction
here. As a result, a new failure net will be shown in the failure net view. In the same way you can
also return to previously created failure nets. In case the malfunction is already part of a failure net,
this failure net will be opened.

Deleting a link:

Right-click on the link line in the failure net and choose the option Delete.

You can automatically create the function net related to your failure net:

Go to the preferences dialog (right-click an empty space in the editor, then click Open preferences)
and then under FMEA > Malfunction net you need to activate the option "Connect functions if
malfunctions connected".

Failure Net Explorer

If you have created a failure net, this and all previously created failure nets will be displayed in the
Failure net explorer .

The Function net explorer and Failure net explorer show hierarchical structures (top-down) of the
system elements and functions / malfunctions.

107



FMEA

fig. failure net explorer

The Form Sheet editor
The form sheet editor gives you an overview of everything in your FMEA document.

You can edit the objects in the form sheet. You will see these changes immediately in the FMEA editor.

If you have not created a form sheet yet, read this chapter first: Creating a Form sheet.

Filtering and adjusting the Display of the Form sheet Editor
You can change the appearance of the form sheet. In the right upper corner you have to following
options:

•
 Show comments

Shows or hides the comments

•
 ASIL/SIL on/off

Shows or hides ASIL/SIL

•
 Elements on/off

Shows or hides the elements

•
 Functions on/off

Shows or hides the functions

•
 Background for tasks on/off

Turns the color of the background for the tasks´ status on or off
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Note that there are options in the preferences menu regarding the form sheet editor: showing and hiding
responsibilities and comments and adjusting the layout to fit the window width. You can also adjust
the layout according to the catalogs. You can choose how many levels of effects are shown and how
many levels of the causes are shown.

Editing in the Form sheet Editor

Note

When editing values in the form sheet editor keep in mind that they will be changed throughout
the FMEA. Some values are derived or inherited from other values. Changing them will changed
the values in other places in the FMEA, e.g.: In AIAG the S rating of an action is inherited from
the top level malfunction, so changing the S rating of an action will change the S rating of the
top level malfunction.

To change the name of an element in the form sheet, double-click on it. The "Edit..." dialog opens.
Change the name of the element and confirm your change by clicking on OK.

A drop-down menu opens when you double-click on ratings, dates, task statuses. Click on one entry
in the drop-down list to assign this choice to the object.

Responsible persons are linked with the employee catalog in the catalogs view. So if you want to set
responsible persons to prevention and detection actions you have to create a employee catalog.

Just like in the FMEA editor, you can create new objects, e.g. add a new malfunction to a function.
Make a right-click on an object and choose New. Like in the FMEA editor, the "Add" dialog will open.

Further Information on the Form sheet Editor

The color of the tasks depends on a task´s status:

• green:

"finished", "proposed/taken"

• yellow:

"active", "reviewing", "rejected",

• red:

"proposed", "inactive"

Printing form sheets:

You can export a form sheet as a PDF or Excel file. See Printing Form sheets and Control Plans to
PDF and Excel.

The Preferences Menu
You can open the preferences menu either from the menu bar (Edit > Preferences), or by making a
right-click in the editor.

Then the dialog with all the settings for SOX opens:
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fig. Preferences dialog

When you click on FMEA [1] you can see the general editor settings.

[2] You can choose the width of the boxes representing the elements in the FMEA editor. Possible
values are 100 to 999.

[3] You can make a check mark to allow animations.

[4] You can make a check mark to show comments as a tool tip. If you activate this, every comment
will be shown as an overlay tool tip when the mouse cursor is above an object in the editor.

Click on the triangle in front of FMEA, or double-click in FMEA, then the list expands.

You see that you have options for the form sheet and control plan: showing and hiding responsibilities
and comments and adjusting the layout to fit the window width.

For the form sheet you can adjust the layout according to the catalogs, you can choose how many
levels of effects are shown and how many levels of the causes are shown.

For the "Structure details" view you can choose whether to use the Root S rating and you can filter
the objects for a better overview.

For the "PSS" view you can filter what is shown and you can decide how the view expands when
opening it and when adding parts.

You have filtering options for the function net view and the malfunction net view.

Regarding action groups you have options to decide whether the system will open dialogs to ask things
in certain situations regarding action groups.
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For the risk matrix you have options to adjust the size and to hide columns. You can also change the
style of the risk matrix from the VDA style (red, yellow and green) to the RG style (red and green).
You can change the detection value split for the RG style. You can decide which squares of the risk
matrix have which color. You do this by selecting a square, and then clicking on one of the buttons
labeled with a color name. You can select multiple squares at once by holding Ctrl while clicking.

Regarding the pareto analysis you can adjust the x- and y-axis and change the labeling of the axis and
the diagrams title. You can also show grid lines.

Additional Functionality
Links to other SOX Modules

You can link the FMEA with other SOX modules with drag & drop.

Linking the FMEA with the FMEDA

You can insert a hardware failure or a system failure from the failure net view of the FMEA into
the columns "Hardware Failure" or "System Failure" of the FMEDA by simply dragging the desired
element from the failure net to the respective column.

fig. Link hardware failure

A dialog will ask if you want to add the effect to the FMEDA or replace it:
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fig. Dialog "Replace effec"t

Then the "Selection" wizard opens. With the buttons Browse... select the required effects and
functions.

fig. "Selectio"n wizard

When you are done, click Finish.

The hardware effect with the respective HE function, the corresponding system effect with the related
SE function and the related safety goals will now be listed in the FMEDA.

Linking FMEA with RM
You can create requirements for each element from the FMEA by right-clicking on them, or you can
drag & drop already existing requirements from an RM document (from your project) into the FMEA.

Note that the cursor changes when it is above an element that you can link the requirement to: Next
to the cursor a rectangle with an arrow inside appears.
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fig. Linking FMEA and RM

If you have dragged a requirement to an element in the FMEA, the respective element symbol will be
marked with a small R. This indicates the link to a requirement in the RM module:

In the "Traces" view you can get an overview of your links related to the selected element.

Import-Export of FMEA Files
SOX offers you the possibility to either import existing FMEA files or to export documents created
with SOX. Note that SOX gives you options to fit the import to your needs!

You will find these options in the FMEA editor under the tab File:
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Importing FMEA Files
Import an already existing MSR FMEA document, either through the menu bar or in the repository
view.

Go the repository view in the workbench perspective, then make a right-click and choose the option
Import. This will open the "Import" wizard:

fig. "Impor"t wizard

Choose "FMEA MSR Import", then click on Next >.
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Now you can select an FMEA document in XML format. Afterwards, the FMEA documents created
within this file will be displayed. By selecting one of these documents, you can then import the file.

This dialog also offers the following check boxes:

Malfunction nets

Malfunction nets will be imported.

Check input

The input of the selected document will be checked.

RPNs

The Risk Priority Number of the document will be adopted.

Add tasks to

The tasks of the imported document will be adopted. You can then decide which layer the tasks shall
be assigned to.

Exporting FMEA Files
You can export the currently selected document as an MSR FMEA document. In the menu bar, go to
File > Export MSR FMEA.

This opens the following dialog:

fig. MSR export dialog

Here you can define the output location for the file you want to export. Furthermore, you can decide
whether and from which layer actions will be exported.

Saving a System-Process Element as a New FMEA
Saving one of your system- / process elements as a new FMEA:
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1. Right-click on the system- / process element.

2. Choose Save as new FMEA.

3. Select the target folder and the file name.

4. Click on Finish.

→ A new, independent FMEA document has been created, which displays your system element as
a root element.

Linking two FMEA Documents
Via the project system structure view (PSS) you can link different documents with each other. You
have these possibilities:

• You can drag a system- / process element from another FMEA document onto one of your current
system- / process elements in order to interlink them.

• You can drag any function from the PSS and drop it onto any desired system- / process element in
order to assign this function to the system- / process element.

All related malfunctions are automatically dragged along as well.

• In the same way you can also drag diagnoses, malfunctions, safety goals, product characteristics
and process characteristics into your existing document.

Using Control Plans
A control plan is a detailed document linking manufacturing process steps to key inspection and control
activities. A control plan lists all product and process inspection points required to deliver a defect-
free outcome, and is essential for maintaining process control over the long run.

A control plan is usually developed based on an existing process or system structure.

Creating a Control Plan

Note

To be able to generate a control plan, the document type of the structure has to be PROCESS.

To change the document type, right-click somewhere in the FMEA editor. Then select Document
Properties (or in the menu bar: File > Document properties). The properties dialog will appear.
Choose the document type PROCESS. You can also change the document type by right-clicking on
the FMEA project name (under the FMEA file of the project while in the SOX Workbench/PSS view)
and then selecting Properties.
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fig. Document properties dialog

To create a control plan at least one process element must be defined in the FMEA editor. To create
a control plan, go to the FMEA editor and right-click on the desired process element. Then choose
Control Plan. You can also select multiple process elements by keeping the Ctrl key pressed down
while clicking on the process elements.
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fig. Context menu on process element

A dialog will appear, in which you can choose between already existing control plans or create a new
one:
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fig. Control plan dialog

Select an existing control plan or create a new control plan by entering a name. Then click on Finish.

→ The control plan opens.

Filtering and adjusting the Display of the Control Plan Editor

You can change the appearance of the control plan. In the right upper corner you have to following
options:

•
 Show/Hide comments

Shows or hides the comments

•
 Elements on/off

Shows or hides the elements

•  Functions on/off

Shows or hides the functions

•
 Background for tasks on/off

Turns the color of the background for the tasks´ status on or off

•
 Show/Hide responsibilities
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Shows or hides the responsible persons regarding control method and reaction plan

Note that there are options in the preferences menu regarding the Control Plan editor: showing and
hiding responsibilities and comments and adjusting the layout to fit the window width.

Editing a Control Plan
In a control plan table you can edit all fields that are already labeled by double-clicking on them.

In the left upper corner of the table you find check boxes for "prototype", "prelaunch" and "production".

Adding-Removing Process Elements

Adding new process elements to a control plan:

You can add a new element to the control plan in two ways:

- directly in the control plan

- in the FMEA editor by right-clicking on a process (parent) element and selecting New > System/
Process element.

If the control plan is created from the root element, all the changes will automatically be visible in
the control plan.

Removing process elements from a control plan:

You can remove a process element from the control plan by right-clicking on it and selecting Delete
elements.

You can also delete an element by clicking on it and then pressing the del key (delete).

Changing the Name of a Control Plan

You can change the name of the control plan by finding the control plan file in the PSS view and
double-clicking on it.

The control plan file can be found in the PSS view in your project under the name of the FMEA file
and then under Control Plans.

Editing Process Number-Process Description-Machines

Editing the Part/Process Number:

To edit the part/process number directly in the control plan, double-click on the field "Number" in
the control plan. The number will then be highlighted and you can edit it by typing a number. Click
somewhere else on the screen to save the changes.

The process number is automatically generated when you create the project. A corresponding number
is then assigned to the system/process elements and their functions. If you change a part/process
number, the number of all child-elements / functions will be changed and adjusted to the parent's
number.

Adding /Editing a Machine directly in the control plan:

To add a new machine to your process element, right-click on the process element. Then go to New
> Machine.

120



FMEA

Note that machines must be defined in a catalog for assigning machines to the process element.

If the machines catalog is empty click on New. A dialog will appear where you can enter the name
of the machine.

In the "Catalog" field, you can rename any machine by double-clicking on it. You can also delete a
machine by selecting it and then clicking on Delete. To save the changes click on OK.

If you click on Restore Defaults any unsaved changes will be lost.

You can enter more than one machine for each process.

Adding-Editing Characteristics

Adding Characteristics in the Control Plan:

You can add product characteristics by right-clicking on the process element and then on New >
Product Characteristic. A dialog will appear where you can enter the name of the characteristic and
edit it.

To insert a process characteristic, you first have to create a sub-process element (child-element). Then
right-click on the sub-element and choose New > Process characteristic. Product characteristics are
for the element itself, while process characteristics belong to the sub-element.

Editing Characteristics in the Control Plan:

To edit an already existing characteristic you can either click on it and press Return or you can right-
click on it and then click on Edit Process/Product Characteristics.

If you only want to rename the characteristic, you can double-click on it.

Editing Classification

To edit the field "Classification", you can just double-click on it. A drop-down list will appear where
you can choose the classification of the element.

You can also right-click on it and then select Edit classification.

Adding-Editing Specifications

Adding/Editing Specifications directly in the Control Plan:

In order to edit the field "Specification", the system/process element has to have a product or process
characteristic.

To edit a specification, right-click on the field "Specification" and select Edit specification. A pop-
up dialog will appear where you can edit the specification. You can only add a specification if your
process element has a product/process characteristic.
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fig. "Properties for functio"n dialog

Adding/Editing Inspection Equipment directly in the Control Plan:

In order to add an inspection equipment in the control plan, right-click on the field "Specification"
and select Edit inspection equipment.

You can then edit the inspection equipment by double-clicking on it or right-clicking on it and then
selecting Edit inspection equipment.

Adding/Editing Responsibilities:

You can edit the field "Responsible" by double-clicking on it. A drop-down list will appear with your
team members. Then you can select the person, the process is assigned to, by clicking on their name.
You can only edit the field "Responsible" if the field "Specification" is labeled.

Responsible persons are linked with the employee catalog in the catalogs view. So if you want to set
responsible persons to prevention and detection actions you have to create a employee catalog.

Adding Inspection equipments:

Note that inspection equipments are stored in a inspection equipment catalog in the catalog view. So
if you want to assign an inspection equipment you have to create a inspection equipment catalog.

Right-click on the process characteristics and choose New > Inspection equipment. A dialog appears
where you can assign the inspection equipment.

For editing responsible, samples, size & frequency use the inspection equipment dialog.
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fig. Inspection equipment dialog.

Creating and Editing Control Methods and Reaction Plans
Prevention and detection actions can be assigned to process/product characteristics. They will then
become visible in the control plan as control methods (detection actions) and reaction plans (prevention
actions).

Note
In order to assign an element characteristic to a control method and/or a reaction plan, you have
to assign an action group first. Action groups can only be assigned to malfunctions.

Entering Control Methods and Reaction Plans using the PSS

You can also enter new tasks using the PSS view. Go to your project and unfold the root element. Then
unfold the element which you want to assign a task to. Find the process/product characteristic and the
corresponding malfunction and right-click on it. Then select New > New Action Group.

A dialog will then appear where you can define a new action group (already defined action groups
will be visible under New Action Group). Now you can unfold the malfunction and there you can
unfold the action group, too. Right-click on Construction actions and then select New Prevention/
Detection action.

A dialog will appear. There you can define the name of the task, and optionally enter a description,
a status (depending on the status of the task, the field in the control plan will be in a different color),
priority, date the task was created/finished and/or deadlines and an assignee. Click on Finish at the
bottom of the dialog when ready. The task will now become visible in the control plan.

Editing Control Methods and Reaction Plans

To edit an already existing control method or reaction plan, right-click on the task in the control plan.
Then click on Edit.

You can also click on the task and then press Return.

Or you can go to the PSS view and there unfold all the relevant functions until you find the
Construction actions. There you can right-click on the action, and then on Edit.
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Printing Form sheets and Control Plans to PDF and
Excel

You can print form sheets and control plans to PDF format and Microsoft Excel.

Printing a PDF file:

Prerequisites: A form sheet or a control plan needs to be open.

1. Go to the menu bar and click on File.

2. Choose Print.

► The "Print settings" dialog opens.

fig. "Print setting"s dialog

3. Choose the output format (PDF or Excel).

4. Choose whether you want the printed file to immediately open after generating the output file.

5. Click on Browse....

► The Windows file manager opens.

6. Choose a folder and enter a name, then click on Save.

7. Choose a variant if you have one.

8. Set the orientation of the content on the sheet and its size.

9. Set the margins.
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10.You can enter text to appear as a header or a footer (optional).

11.Click on Print.

→ A new file has been created and saved to the chosen location. If you chose Open, the file will
open automatically.

Printing a file for Microsoft Excel:

This works the same as printing a PDF file except you cannot enter a header/footer or choose a margin.

Inheritance of ASIL Level
If the ASIL level changes anywhere in the SOX project, this level gets passed on along the failure net.
This happens across the different modules of SOX. Here is an example: You change a severity rating
in the Hazard Analysis module. The HA module now calculates a new ASIL level for the associated
safety goal. You have used the same safety goal in the FMEA module, so the new ASIL level also
changes in the FMEA module and it gets passed along the failure net.

Creating new Requirements
To create a new requirement, right-click on a function or system/characteristic and choose New > New
Requirement and Trace.

Requirements consist of a certain number and kind of characteristics and attributes.

These attributes can be summarized as a type of requirement. Every requirement needs to be assigned
to a type of requirement.

To create and edit requirements, the following dialog will open:

fig. Dialog "New requiremen"t

Here you can edit the characteristics of a new requirement. These include:

• Parent node:

Desired parent node of the new requirement. In this field, you can choose between all previously
created requirement parent nodes of the selected project. If there is no selection available, you have
to create a module first.
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• Type:

Desired type of the new requirement. In this field, you can choose between all previously created
types of requirements.

• Name:

Name of the new requirement. (This field will be inactive in case the chosen type does not have an
attribute with the name ReqIF.Name.)

• Text:

In case the type of the new requirement allows it, you can enter a text about the requirement here.

• Variants:

Here you can assign the new requirement to a variant.

Complete the process by clicking on Finish.

Operation Mode
In the toolbar you can choose an operation mode (construction, operation, service).

You can include or exclude elements with one operation mode at a time.

That means, in case a malfunction no longer has an effect in operation due to defined diagnoses and
Diagnostic Coverage (DC), this malfunction can be excluded for operation. The malfunction is thus
marked as inactive.

To do that, you go to the context menu (right-click on a malfunction) and click on the option Operation
modes where you can then choose between the following possibilities:
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fig. Context menu on malfunction

If you have for example excluded a malfunction for operation, this malfunction will be marked with
"(Ox)" before it´s name. When switching to the operation mode, this malfunction will be grayed out
(i.e. deactivated).

Adding from Model
If you added an object (system element, function etc.) in the System Design module, you can quickly
and easily add this object to another object in the FMEA module.

You can do this in the FMEA editor and in all the views:

1. Right-click on the object that you want to add the new object to.

2. Choose Add from Model.

3. Choose the respective object or choose Add all.

→ The object from the System Design has been added to the FMEA.

Text Find Function
You can use the text find function by using the shortcut Ctrl + F. This function is possible for the
FMEA Editor, Failure net and Function net.

fig. Find dialog.

Activate a checkbox for using different search algorithm.
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Introduction

Hazard and Risk analysis. The HARA module of SOX supports you in listing your security needs and
assembling safety reviews.

SOX provides you with the following norms for determining the safety level according to the level
definitions from each respective norms.

• ISO 26262 Automotive Safety Integrity Level (ASIL)

• ISO 26262 Motorcycle Safety Integrity Level (MSIL)

• IEC 61508 Safety Integrity Level (ASIL)

• IEC 13849 Performance Level (PL)

• ISO 25119 Agricultural Performance Level (AgPL)

You can work with different variants and operation statuses.

Step-by-Step-Guide
This guide leads you step-by-step through the creation of a Hazard and Risk Analysis.

Creating a new HARA file
Precondition: A SOX project was created and the workbench perspective is active.

1. Go to the Repository view and right-click on the HARA folder in your project.

fig. New HARA File context menu.

2. Choose New > New HARA File

► The "New HA file" dialog opens.

fig. New HA file dialog.

3. Click on Browse... and choose HARA as target folder.

4. Enter a filename for the HARA file.

5. If you have already created system elements, you can assign them by clicking the Add... button.

► The Add system elements dialog opens.

fig. Add system elements dialog.

This dialog shows all your created system elements of your project [1]. Select the desired elements
and click OK (multiple selection is possible). With the plus icon [2] you can create new system
elements.
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Note

System elements, functions and malfunctions are necessary for a hazard and risk analysis.
In the chapter System Designer Exemplary Method for Designing the System Structure you
can find more information about designing a system (creating system elements, functions and
malfunctions in the System Designer) and using them for the HARA.

6. Choose the safety level specification according to the Norm.

Note

Please contact us if you need customized profiles for norm catalogs. If not, choose a (Standard)
profile or leave the field empty.

7. The Description, Objective and Foundation fields are optional and can be used for detailed
descriptions of your hazard document.

8. Click Finish.

→ A HARA file will be created and added to the HARA folder.

Creating System Elements
You can create system elements in the Repository and Model Explorer view by adding system elements
to your project. There is also the possibility to create system elements directly at the HARA editor or
using the Add system element dialog which can be opened at the "HARA document properties" or at
the context menu of "Rated system elements" in the Overview view.

The following procedure is an example for creating a system element at the HARA editor.

Precondition: A HARA file was created and is active.

fig. HARA editor tool bar add empty rating.

1. Add an empty rating by clicking the plus icon at the HARA editor tool bar.

► A new row (rating) appears.

2. Make a double-click into the Element cell and type in a name for the system element.

(The drop down menu shows already assigned system elements.)

→ The system element will be added as object to your project and assigned to the HARA document.

Creating Functions
You can create functions in the context menu of system elements. The context menu is available in
every view in which a system element exists. For example: Editor, Overview, PSS, Repository,.... You
can also create functions directly in the HARA editor by clicking into the according function cell.

The following procedure is an example for creating a function in the Overview view of the Hazard
Analysis perspective.

Precondition: System elements were created and the Hazard Analysis perspective is active.

1. Go to the "Overview" view and make a right-click on the system element that should be provided
with a function.
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fig. New Function context menu.

2. Choose New > Function.

Note
A FMEA can be useful for a detailed analysis about possible functions and malfunctions. Select
a system element, click on Create FMEA, choose FMEA as your Target folder and name the
file. Now you can start the FMEA with the selected system element as root element.

► The Add dialog opens.

3. Name the function.

4. Click OK.

→ A function will be created and added to the chosen system element.

Creating Malfunctions
You can create malfunctions in the context menu of functions. The context menu is available in every
view in which a functions exists. For example: Editor, Overview, PSS, Repository,.... You can also
create malfunctions directly in the HARA editor by clicking into the according malfunction cell.

Precondition: Functions were created and the Hazard Analysis perspective is active.

1. Go to the "Overview" view and make a right-click on the function which should be provided with
a malfunction.

fig. New Malfunction context menu.

2. Choose New > Malfunction.

Note
A FMEA can be useful for a detailed analysis about possible functions and malfunctions. Select
a system element, click on Create FMEA, choose FMEA as your Target folder and name the
file. Now you can start the FMEA with the selected system element as root element.

► The Add dialog opens.

3. Name the malfunction.

4. Click OK.

→ A malfunction will be created and added to the chosen system element.

Adding Situation Parameters and Effects
Note
SOX provides catalogs which contain standard values for the situation parameters. But you also
can define individually catalogs and values. Read the chapter Customized Choice Lists for more
information.

Precondition: System elements, functions and malfunctions were created.
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fig. HARA editor Add ratings button

1. Click the Add ratings button in the editor tool bar

► A new row (rating) appears.

2. Make a double-click into the element cell and select a system element.

3. Make a double-click into the function cell and select a function.

4. Make a double-click into the malfunction cell and select a malfunction.

5. Edit the values of situations by editing the according cell with a double-click into it.

Note

Manually entered values of the situation parameters will be labeled with a pen and stored in a
catalog which is local to the current project. The local project catalogs can be accessed from
the Catalogs View.

fig. Manually entered value.

Note that content of local project catalogs is only available to the project itself. If you want to
re-use the catalog content it needs to be moved to a public catalog.

fig. Context menu Move to.

Or you can use the "Add permutations" function.

6. Click on Add permutations .

► The permutation matrix definition dialog opens.

fig. Permutation matrix definition dialog

7. Select at least one malfunction (system elements and functions that are assigned to malfunctions)
which should be provided with situation parameters.

Click the Restore last selections button if you want selection settings from earlier permutations.

8. Click on the Add\Remove catalogs button to select the default SOX choice lists.

► The choice lists dialog opens.

Note

You can also edit the values with clicking the Edit catalogs button. You can make new entries
or edit already existing values. If you are editing values of catalogs which are stored in the
public folder (Global), the changes will be applied in all other projects and documents where
the value is used. The available catalog is displayed in bold letters.

Project catalog: This catalogs are stored together with the project. They are not available to
other projects. If you want to make their content available for other projects you need to move
the content to a public catalog.
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9. After choosing the desired choice list, you can now select the items which are to be considered
for the permutation.

10.Click Next.

► The select permutations dialog opens in which all possible permutations according to your
selection are listed.

11.Select your desired permutations

12.Click Finish.

→ All selected permutations will be created and added to the HARA document.

Evaluation of the Safety-/Performance Level
• For ISO26262 (ASIL or MSIL)

Evaluations for S (severity), E (exposure) and C (controllability).

• For IEC61508 (SIL)

Evaluations for S (severity), A (presence), G (avoidance), W (probability of endurance).

• For IECI3849 (PL)

Evaluations for S (severity), F (presence), P (avoidance).

• For ISO25119 (AgPL)

Evaluations for S (severity), E (exposure), C (controllability)

Make a double-click to into the cell to edit the according value. For reason, effect and hazard
parameters there is the possibility to create customized choice lists.

The following procedure shows how to use customized choice lists for reason parameters.

Precondition: A HARA document was created and a rating was added.

1. Double-click into the reason cell.

2. Choose Select choice list...

► The choice list selection dialog opens.

3. Select your desired choice list.

4. Click OK.

► The values of the choice list are now available at the drop down menu of the reason cell.

5. Double-click again into the reason cell.

6. Select the desired value.

→ The value for the reason cell and the according E-Value will be added to the rating.

Creating Safety Goals
In the "PSS" view or in the "Overview", make a right-click on Safety Goal and choose New > New
safety goal.
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Or make a right-click anywhere in the "Project safety goals" view.

The "New safety goal" dialog opens:

fig. Dialog "New safety goa"l

Enter at least a name and a safe state. Then click on OK.

The User Interface
Below you see all the standard views in the HA perspective. Remember that you can always (re-)open
views by going to the menu bar and clicking Window > Show View. You can also arrange the views
with drag & drop.

fig. The User interface of the HARA module

[1] HARA editor

[2] Overview / PSS

[3] Project safety goals

[4] Relationship matrix / Properties / Task Assignments / Project tasks / Traces / History

[5] Model Explorer / Catalogs / Object list

The HARA Editor
The HA editor shows a table with malfunctions that are assigned to functions and certain situations.

Then these malfunctions get effects and the effects get hazards. These hazards are then evaluated
according to the norm you have chosen when creating the HARA document:

You add safety goals and then their safe states are shown.

You can rate the priority of each line in the "Priority" column: i star (low), 2 stars (medium), 3 stars
(high priority).

You get a drop-down menu that lets you choose an entry for the cell, by clicking on a cell in the table
and then clicking on the triangle that appears.

if you right-click in the editor, a context menu opens:

fig. Context menu in the HA editor

You can add tasks and comments, and copy the selected element.

With Add rating, a new rating with the selected system element will be added.

With Change State you can change the state of the selected rating according to the state machine rules.

With Delete rating you can delete the selected rating.

With Set "No effect" you can provide the rating with no effect ► The rating will be greyed.

133



HARA User Guide

With Transfer ratings to other malfunctions you can transfer the ratings to other already created
malfunction with no ratings.

The Situation Matrix
The situation matrix represents the connection between malfunctions and operational situations and
can be opened with the "Open situation matrix" icon at the HARA editor tool bar.

fig. Icon "Open situation matri"x.

You can de-select a malfunction from a situation:

fig. Situation matrix.

Click into the check box. The "delete related ratings" alert opens:

fig. Alert "delete related rating"s

The Overview View
The view "Overview" is similar to the "PSS" view, but concentrates on the HA documents.

Here (and in the "PSS" view) you can create new functions, malfunctions. You can also create new
system elements, functions, malfunctions, hazards and safety goals.

Additional Functionality
Customized Choice Lists

Customized choice lists are catalogs for working modular. This means the catalog are stored on the
server (global) and can be used by all users. So if you change this catalogs, this effects on all projects
and documents in which the catalog is be used. But you also can use the catalogs only on your local
system.

fig. Choice list selection dialog.

In this dialog you can select SOX and your created choice lists [2]. Your selection will be displayed
at the according drop down menu of the displayed parameter [1]. With the Add new catalog button
[3] you can create a new choice list.

fig. Catalog editor with choice list.

In this editor you can edit the choice list. The type [2] is necessary to assign the catalogs to the according
parameter.

Table 1. Choicelist Types assigned to Category

Choicelist Type HARA Situation Category
<sox2.ha.place> Place
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<sox2.ha.endangered.persons> Endangered persons

<sox2.ha.driving.dynamics> Driving dynamics

<sox2.ha.characteristics> Characteristics

For adding new values select the language and click the plus icon  on the right.

If you need your values in different languages, you can add your language with a right-click [1] and
New > Language.

fig. Add language dialog.

Type in the country abbreviation and click OK. The chosen language will be added to the catalog.
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Introduction

Calculate required probabilities in the SOX module FTA and track the progress of your analysis with
the possibility to consign a status and to assign tasks. The SOX module FTA provides the possibility,
besides the option to display variants, to take over hardware and system effects of the FMEA or failure
modes from the FMEDA and to link them simply by drag & drop. Sources and effects of risks are
therefore systematically identified and eliminated with appropriate countermeasures (e.g. diagnoses).

Step-by-Step-Guide
Creating a New File

Precondition: A SOX project was created and the Repository view is active.

1. In the Repository view, right-click on the FTA folder.

2. Choose New > New FTA File .

► The "New FTA file" dialog opens.

fig. Dialog "New FTA Fil"e

1. Click on Browse... to choose the target folder where the FTA file should be saved.

2. Choose a filename for the FTA file.

3. Choose the Mission Time (in hours) for this FTA.

4. Assign a Safety Goal for the FTA file. (Can be assigned later)

5. Assigned hazards can be selected with a check mark. (Can be assigned later)

→ An FTA file was created and added to the repository.

Now you can drag & drop the objects from the sidebar to form a fault tree, derive an FTA from an
FMEA or use single failures and components from the FMEA out of the PSS view.

Importing an FTA
The XML structure (gates, events and their relations) of an IsoGraph FTA can be imported for a further
analysis with SOX.

Precondition: A SOX project was created and the Repository view is active.

1. In the Repository view, right-click on the FTA folder.

2. Choose Import.

►The Import wizard opens.

fig. "Impor"t wizard

3. Choose FTA Isograph Import (Structure XML).

4. Click Next >.
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► The wizard switches to its next page.

fig. "Impor"t wizard page 2

5. Click on Browse... and choose FTA as the Target folder.

6. Click on Browse... and choose an FTA XML file.

7. Choose a filename for the FTA.

8. Click on Finish.

→ An FTA structure was imported.

Creating a Gate
Precondition: An FTA document is selected and the FTA editor is active.

1. To the right of the editor, in the column "Palette", click on the desired gate.

► The type of gate is selected.

2. Click in the editor.

►The gate dialog opens.

fig. Gate dialog

3. Choose a name for the gate. This will be the name of the malfunction.

4. Write a description (optional).

5. Click on Color... to adjust a background color.

6. Click on OK.

→ A gate with the malfunction was created.

Creating an Event
Precondition: An FTA document is selected, the FTA editor is active and gates were created.

1. To the right of the editor, click on the desired Event.

2. Click on a gate in the editor.

► The event dialog opens.

fig. Event dialog

3. Choose a name for the event.

4. Write a description (optional).

5. If necessary change the status of the event.

6. Type in the component life time in hours. This will influence the probability calculations!

7. Click on Color... to adjust a Background color.
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8. Choose Local Failure model to crate a new failure rate value or choose Document to use a
manually created failure model.

9. If necessary choose a common cause failure (CCF).

10.Click on OK.

→ An event was created.

Creating a Page Break
Note
Page breaks are useful to get a better overview over your FTAs. The page breaks will not influence
the probability calculation of the whole system.

1. In the editor, right-click on the desired gate/malfunction (not event) where the page break should be.

► The context menu opens.

2. Choose Create page break.

► The page break will be shown as triangle.

3. Double-click on the triangle to open the page break.

4. Double-click on the triangle under the malfunction to get a level above.

Editing an FTA
The FTA can be edited on document, module and object level.

1. In the Repository view, right-click on an FTA document.

fig. Context menu for document properties

2. Choose Document properties.

► The Properties for dialog with th entries "FTA Document" and "FTA module" opens.

Document

fig. Dialog "Properties for FTA Documen"t

In this dialog the Mission Time in hours can be changed. The default value is 1.0E9 from the FIT
calculation. If safety goals have been created, they can be assigned here or in the Safety Goals view.

Module
Note
The changes will be active for every FTA document.

fig. Dialog "Properties for FTA Modul"e
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In this dialog the general FTA module properties can be changed.

Object
Right-click on a gate/event and choose Properties.

► The gate dialog opens.

►The event dialog opens.

If only the type of the object should be changed, right-click on a gate/event and choose Change gate/
event type.

fig. Context menu for changing gate/event type

Exporting as a Picture
Precondition: The desired FTA is open.

1. Right-click in the FTA editor.

► The context menu opens.

fig. Context menu for exporting diagrams

2. Choose Export Diagram...

► The "Export Diagram" dialog opens.

fig. Dialog "Export diagra"m

Note: You can also export only one object, if you select the desired one and do a right-click on it.

3. Change the export preferences to your desire with the following image formatting possibilities:

• BMP (Windows Bitmap)

• GIF (Graphics Interchange Format)

• JPG (Joint Photographic Experts Group)

• PNG (Portable Network Graphic)

• RLE (Run-Length encoding)

• SVG (Scalable Vector Graphic) - the SVG-File will only be converted properly to PDF if
Inkscape (File -> Save as...) is used - printing the file to PDF (with any tool) did not perform
very well.

Use a higher Scale-factor (Pixel), for a more detailed resolution.

4. Click on OK.

5. Choose a file path.
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→ The FTA is exported with the chosen preferences.

Print
Precondition: The desired FTA has to be opened.

1. Right-click somewhere in the FTA editor.

► The context menu opens.

fig. Context menu for printing

2. Choose Print...

► The "Print preview and preferences" dialog opens.

fig. Dialog "Print preview and preference"s
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3. Change the printing preferences to your desire.

4. Click on OK.

→ The FTA will be printed with the chosen preferences.

The User Interface
This is the default FTA perspective:

fig. The user interface

[1] PSS view, Project safety goals view

[2] Miniature View of the opened FTA document

[3] FTA Analysis View

[4] FTA Editor

[5] Sidebar

PSS/Project Safety Goals View
The Project System Structure view (PSS) gives you an overview of all documents that belong to the
project.

fig. "PS"S view

The Project safety goals view shows all created safety goals of the project. They can be edited here.

fig. "Project safety goal"s view

Miniature View
The miniature view shows the active FTA or active page breaks. The miniature view is synchronized
with the editor, so you can use the view to navigate in the FTA.

fig. "Miniatur"e view

FTA Analysis View
• Minimal cut sets

fig. Minimal cut sets

If the "Filter page" function is active, only the gates and events will be shown which are part of
the active page break.

The Minimal cut sets table shows:

- the gate ID (event ID)
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- the calculated probability

- the calculated importance

of an opened FTA document.

The table can be exported and saved to your system.

fig. Context menu for exporting the table

• Gates

fig. Gates

If the "Filter page" function is activated by a check mark, only the gates and events will be shown
which are part of the active page break.

If the "Show gates without children" function is activated by a check mark, only the gates without
a base-, house- or intermediate event will be shown.

The Gates table shows the ID, name, gate type and status of an open FTA document.

• Events

fig. Events

If the "Filter page" function is active, only the gates and events will be shown which are part of
the active page break.

The Events table shows the ID, name, event type, failure model, CCF (Common Cause Failure)
model, status, Fussel Veseley, Birnbaum, criticality.

FTA Editor

Sidebar
• Palette
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Select individual objects

Select several objects

• Objects

OR The output occurs only if at least
one of the inputs occurs.

AND The output occurs only if all of
the inputs occur together.
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VOTING The voting gate used to show
M of N combinations of inputs
causing the output to occur.

Base Event The Base Event represents the
inherent of primary failure
mode of a component; a
component failure that cannot
be further defined in detail.
(Primary failure)
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House Event The House event represents an
event or action that is expected
to occur as part of normal
system operation.

Intermediate Event The Intermediate Event
represents a failure that is
induced by an external event
or failure. It also represents
a failure mode that could be
developed in more detail if
desired. (Secondary failure)

Additional Functionality
Evaluation

Precondition: The FTA has to be completed until the base events.

1. Right-click on the desired gate.

2. Choose Calculate probabilities.

→ The probability of failure for every gate and event will be calculated.

You can see the probability of failure of the undesired event and the input failure event probabilities
in the minimal cut sets view .

The following reliability equations are used to calculate the probability of failure for the base events
(component failure):
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R = Probability of success (Reliability)

Q = Probability of failure

λ = Component failure rate

T = Time interval (mission/component life time or exposure time [h])

Deriving an FTA from FMEA
Precondition: A new FTA document was created and the PSS view is active.

fig. Drag & drop malfunction from FMEA

1. Drag the top undesired event (In this example it is the malfunction "Passenger car not ventilated")
from the PSS view.

2. Drop it into the FTA editor.

► The "Add fault tree" dialog opens.

fig. Dialog "Add fault tre"e

3. Click on Add fault tree to derive the structure from the FMEA.

→ The fault tree has been created and is shown in the FTA editor.

fig. Fault tree derived from FMEA

Using Calculated FIT Values from the FMEDA
Precondition: An FTA has been created and the PSS view is active.

fig. Drag & drop component from FMEDA

1. Drag the desired component (Base Event) from the FMEDA part of the PSS view.

2. Drop it on a gate in the FTA editor.

► The calculated FIT value will be adapted.
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Note

In this case you have to make sure that the TF (Total FIT) Failure model on document level is
active.

Creating Failure Models manually
The TF (Total FIT) failure model is the default generated model for every FTA document. Use this
model to adopt the calculated FIT values from the FMEDA/BOM for the FTA. Further more it is
possible to manually create failure models for each FTA document which can be used via drag & drop
or assigned in the properties dialog.

Precondition: The PSS view is active.

1. Open the desired FTA document in the PSS view.

fig. Failure models in the PSS view

2. Right click on Failure models > New Failure model.

►The "Add failure model" dialog opens.

fig. Dialog "Add failure mode"l

3. Choose the failure model type and its values.

4. Click on OK.

→ A new failure model has been added to the FTA document.
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Introduction

Create test cases based on your requirements in SOX and pass them to their specific testing tools. Use
guided test runs with workflow and user rights assistance.

Please approach us for specific data outputs. We will adjust the output in XML so you can pass SOX
test cases along to your test tools and read back the status, so as to generate maximum assistance in
the preparation of your project-related traceability.

Step-by-Step-Guide
Creating a Test Specification

A SOX test specification contains a test plan, analysis and test group section.

fig. Structure of test specification.

Precondition: A SOX project was created and the Repository view is active.

1. Open the SOX project in the repository view.

2. Right-click on the Test folder

3. Choose New > Test Specification
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fig. New Test Specification.

► The dialog "Create new Test Specification" opens.

4. Click on Browse to specify the file location.

5. Enter a filename.

6. Choose the Template language (a template for the test plan which helps you to provide your test
plan with all necessary information).

7. Click on Finish.

→ A new test specification with test plan, analysis and test groups was added to the repository.

Creating Test Groups
Test groups can be organized at the Hierarchy view of the Test perspective. Test groups are necessary
for test suits and test cases because they are used as containers and root elements.

The following procedure explains how to create test groups at the hierarchy view.
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Precondition: A test specification was created and the Hierarchy view is active.

1. Right-click in the hierarchy view.

2. Choose New > New Test Group.

► The "Add Test Group" dialog opens.

3. Enter a name for the modul.

4. Click on the Browse button to choose a responsible employee for this test group.

Note

The employee must be defined at the employee catalog. Read the employee catalog chapter
for more information.

5. Click on Finish.

→ A test group was created and added to the hierarchy view and the test specification.

Creating Test Cases
Test cases can be stored in test groups or test suites. Test suites are used for sup groups in test groups.

To execute test cases, you have to create test runs and link them with test cases.

The following procedure explains how to create test cases in the hierarchy view or in the editor.

Precondition: A test group was created.

1. Right-click on a test group.
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fig. New test case in the hierarchy view.

2. Choose New > Test Case.

► The "Add Test Case" dialog opens.
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fig. Add Test Case dialog.

3. With the browse button you can change the test group/suite in which the test case will be stored.
By default it will be the test group which was selected.

4. Enter a name for the test case.

5. Enter a text e.g. which will describe the procedure for this test case.

6. Enter a precondition.

7. Enter a expected result

8. Enter a post condition.

Note
The content of the fields (5)(6)(7)(8) are optional and can be edited later. They can be edited
with XHMTL formatting. With a click into the field you'll get a tool bar with all possible
formatting. If there appears no tool bar, change the size of the dialog.

fig. XHTML tool bar.
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9. Click Finish.

→ A test case with all entries was added to the selected test group/suite.

Creating Test Steps
Precondition: A test case was created.

1. Right-click on a test case.

fig. New Test Step.

2. Choose New > Test Step.

► The "Add Test Step" dialog opens.

153



TM User Guide

fig. Add Test Step dialog.

3. With the browse button you can change the test case in which the test case will be stored. By default
it will be the test case which was selected.

4. Enter a text e.g. which will describe the procedure for this test step.

5. Enter a precondition.

6. Enter an expected result.

7. Enter a post condition.

Note
The content of the fields (4)(5)(6)(7) are optional and can be edited later. They can be edited
with XHMTL formatting. With a click into the field you'll get a tool bar with all possible
formatting. If there appears no tool bar, change the size of the dialog.
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fig. XHTML tool bar.

→ A test case with all entries was added to the selected test case.

Creating Test Runs
Test runs are necessary for executing a defined set of test cases. They also contain information about
results and status of the test run.

Precondition: The Test perspective is active.

1. Right-click into the Test Runs view.

fig. Context menu new TestRun

2. Choose New > TestRun

► "New TestRun" dialog opens.
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fig. New TestRun dialog.

3. Enter a name for the test run.

4. Optional enter a description for the test run.

5. Click on the Schedule icon  to set an appointment for the execution of the test run.

6. Select a Priority for this test run.

7. Click on the Browse button to choose a responsible employee for this test group.

Note

The employee must be defined at the employee catalog. Read the employee catalog chapter
for more information.

8. If you are using the Save & proceed function, the already created test runs will be displayed in
this field.

9. Click OK.
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→ A test run was created and added to the Test Runs view.

Adding Test Cases to Test Runs
Test runs are necessary for executing a defined set of test cases. Test cases can be added to any number
of different test runs. You also can assign whole test groups and test suites.

Drag your desired test- case/suite or group and drop it on a test run.

Note

If you want to remove a test- case/suite or group, use the context menu entry Delete at the Test
Runs view. The object will be only removed from the test run, not from the project.

Executing Test Runs
For executing test runs, approve that your test run and the test cases have the following status:

The test case must be Active The Test Run must be Approved

Note

This is the default SOX work flow which is defined in the state machine. Please contact us for
implementing a customized state machine and work flow. Read the chapter State Machine for
more information.

Precondition: Test cases are added to the test run. The status of the test run is approved and the
containing test cases are active. The Test Runs view is active.

1. Right-click on the test run which should be executed.

fig. Starting the test run.

2. Choose Start TestRun.
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► The "Test Run execution" dialog opens.

fig. Test Run execution dialog.

[1] Counter for test run duration. [2] Status of executed test cases. (Passed/Passed
with Errors/Error/Blocked)

[3] Test case and test step content. [4] Start/Pause Test Case.

[5] Keep comment. If active the last entered
comment stays in the comment box.

[6] Archive/Interrupt Test Run

[7] Buttons for rating the test steps. [8] Previously entered comments can be selected
here and used for the current executed test step.

[9] Rate complete Test Case, if active the
complete test case will be rated with your
selected rating.

[10] Structure of test case and test steps which
are included to this test run.

3. Click on Start Test Case.

► The counter [1] for this test run starts.

4. Rate the current test step.

Note

If you want to rate the current test step with Passed with errors, Error or Blocked, you have
enter a comment at the comment box.
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fig. Test Run execution dialog comment box.

5. After you have rated all test steps and test case, click on Archive to finish the test execution.

→ The test run was executed.

The User Interface

fig. User interface of Test perspective.

[1] Hierarchy View
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[2] Test Modul Editor

[3] Test Run View

Test Modul Editor
The test modul editor contains the three register:

• Test Plan

fig. Test plan register.

The test plan contains by default a template which helps you to provide your test plan with all
necessary information. The content can be edited in XHMTL formatting.

• Analysis

fig. Analysis register.

The Analysis register contains a pie chart and block diagram which gives you information about the
entity count and test results. It's only an overview and not editable.

• Test Groups
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fig. Test group register.

The test group register shows all contained test- suits/cases and steps. It also gives you information
about last test results, linked requirements and test run information.

Meaning of colors:

Brown Test suites

Beige Test cases

Green Passed

Green/Red Passed with errors

Yellow Blocked

Red Error

Grey Not executed

Hierarchy View
The Hierarchy view displays the test groups and their related test- suites/cases and steps. Furthermore
Test- groups/suites/cases and steps can be created and organized here.
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fig. Hierarchy view.

•
 New test group

Triggers the New test module dialog.

•
 New Test suite

Triggers the New test suite dialog.

•
 New Test case

Triggers the New test case dialog.

•
 New Test step

Triggers the New test step dialog.
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Test Runs View
The test runs view displays all test runs and their information. In this view you can also create and
organize test runs.

fig. Test run view.

The description part on the right shows the content of a selected test case.

Additional Functionality
Linking Requirements

Precondition: Requirements and test cases were created.

1. Open the test specification and the according test group register which contains the test cases for
linking.

2. Open the PSS view and the requirements structure until the requirement which should be linked

► You should have a similar interface like fig. Linking requirements with test cases.

fig. Linking requirements with test cases.
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3. Drag the desired requirement and drop it on to the to be linked test case

► The requirement will be displayed in the editor at the requirements column.

→ A requirement was linked with and test case.
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Reliability

Import or create Bills of Materials (BOMs) in the SOX Reliability module. FIT values are calculated in
the SOX RE module in compliance with project-specific profiles and can be used for various analyses.

Step-by-Step-Guide
Creating a New File

Precondition: A SOX project has been created and the Repository view is active.

fig. "Repositor"y view

1. Open the SOX project in the repository view.

2. Right-click on the BOM folder.

3. Choose New > New BOM file.

► The dialog "Create a new BOM file" opens.
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fig. "Create a new BOM fil"e dialog

4. Click on Browse... and choose BOM as the target folder.

5. Enter a filename for the BOM file.

6. Choose the method for failure mode catalog handling. Choose here between Birolini and IEC62380.

7. Choose a failure rate catalog. FIT rates can be calculated according to different norms (i.e.
IEC62380, SN29500).

8. Optionally, enter a description that helps to understand the content.

9. Click Finish.

→ A BOM file was created and added to the repository.

Creating a New Module
Precondition: A reliability file was created and the BOM Modules view is active.
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fig. "BOM Module"s view

1. Right-click in the BOM Modules view on the element Overall system. This virtual assembly group
provides all assembly groups of the BOM.

2. Choose New > New Module...

► The dialog "New assembly group" opens.

3. Enter a name for the module.

4. Click OK.

→ A new module was created and added to the "Overall system".

Creating a New Component
Precondition: A module has been created.

fig. Context menu for new component

1. In the BOM Modules view, right-click on a module.

2. Choose New > New Component

► The dialog "New component" opens.
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fig. "New Componen"t dialog

1. Enter a name for the component.

2. Optionally, enter a description that helps to understand the content.

3. Enter a product code.

4. Select a module that contains the new component.

5. a) Choose a failure rate catalog and component type if the new component was defined in a catalog.

b) If you want to manually set the FIT value for the new component, leave these two sections empty.

6. If there are several components of the same type, assign a factor (i.e. the quantity of the component;
has direct impact on the value "Total FIT").

7. The FIT value of a component is defined in the failure rate catalogs and will be set automatically.

8. Click on Failure mode types... to choose a failure mode type from the failure mode catalogs.

9. Click OK and Next to confirm and create a further component.

→ A component was created and added to the selected module.

Note
The FIT for components of the IEC62380 catalog can only be calculated if there is a mission and
temperature profile determined and selected in the FIT Details view.

Creating New Failure Modes
Precondition: A component was created.
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1. Right-click on a component in the BOM editor.

2. Choose New > Append New Failure Mode.

► The dialog "New Failure Mode" opens.

fig. "New Failure Mod"e dialog

The distribution (in percent) for the failure mode is used for calculating the probability for this failure
mode to occur for this type of element. The sum of all possible failure modes for an element's type
must be equal to 1.

If the sum of failure mode distribution is not 1, SOX issues a warning.

Print
The BOM can be printed as an FMEDA report. Click on File > Print to get to the "FMEDA Report"
wizard.
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The User Interface

fig. Reliability User Interface

[1] FIT Details view, Temperature profiles view, Mission profiles view

[2] Failure rate Catalogs, Failure mode Catalogs, PSS, Clipboard

[3] BOM Modules, Properties, History

[4] Model Explorer, Catalogs, Object list

[5] BOM Editor
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FIT Details

fig. "FIT Detail"s view (sn29500)

( ) = Physical symbol

[ ] = Physical unit

At first you need to select a component that is connected to a catalog and component type. If you click
on this component this view appears to the right of the BOM editor. Some fields are grayed out so
you cannot enter values. This depends on the catalog and component type you use. In the example
above we used the catalog "sn29500" and the component type "K (General purpose relay...)". For
this type there is only the "Stress Operation Time", "Operational Time" and "Waitstate Temperature"
available.

- Catalog: Component catalog. Either "sn29500" or "IEC62380".

- Component type: The type of your component that you have chosen in the "New Component" dialog.

- Failure mode type: Your selected failure mode if you have chosen one from the catalog. If you have
created your own failure mode in the "New Failure mode" dialog, this line will not be shown here,
only the types from a catalog.

The values of the attributes are from the corresponding norm "sn29500" or "IEC62380". To change
the values, you have to edit the failure mode catalog.
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fig. "FIT Detail"s view (IEC62380)

- Catalog: Comes from your selection in the "New Component" dialog.

- Component Type: Comes from your selection in the "New Component" dialog.

- Failure Mode Type: If there is a Failure mode type connected to your component, this type will be
shown here. If there is no failure mode or you have created your own, this field is empty.

- Mission profile: In this section you have to select an existing mission profile. Dealing with mission
profiles will be shown in the chapter Mission profiles.

- Temperature Profile: You need a temperature profile for the FIT calculation. If you have more than
one profile, choose a specific profile from the list after clicking the arrow. Temperature profiles will
be discussed in the next chapter.
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Temperature Profiles

fig. "Temperature profile"s view

In this section we will discuss the functions and values of the temperature profiles view. In the picture
above you can see the standard view without any content. In the first step you have to add a profile:

Precondition: The Temperature profiles view is opened.

fig. "Temperature profile"s view

1.
In the profiles section, click on the plus icon: 

► The "New profile" dialog opens.
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fig. "New Profil"e dialog

2. Click OK.

► The new temperature profile was added to the "Profiles" section.

fig. "Temperature profil"es view with custom profile

3. Select a temperature profile with a left-click.

4.
Click on the plus icon in the temp value section.

► Cells for factor and temperature appear.
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fig. Temp value section

5. Enter values for factor (i.e. the weighting of the temperature) and temperature. Further values can

be entered by clicking on the plus button: 

→ A temperature profile with its values was created and can be assigned to components.

(t_ac)_i Environmental temperature

τ_i Factor for calculation with the according
temperature (t_ac)_i . (Weighting of the
temperature)

Σ tau Sum of all τ_i

T_ac_mean Average environmental temperature

Mission Profiles
Another important feature for the calculation of Total FIT is the Mission profiles view.

This view is only relevant for IEC62380.

Mission profiles are used to define working phases. Any number of working phases may be included
within a mission profile.

Later, the mission profiles can be assigned in the FIT Details view.

175



Reliability

fig. "Mission Profile"s view

Here in the Missions profiles view you can add and edit profiles. To add a new mission profile, click

the green plus symbol  on the upper right corner.

A mission profile has to be broken down into several homogeneous working phases, on the basis of a
typical year of use. The following phases have to be taken into account:

- On/off working phases with various average outside temperatures

- Permanent-working phases with various average outside temperature swings

- Storage/dormant phases mode with various average outside temperature swings. For a reliability
calculation, the time quantity is the number of calendar hours of the installed population of this
equipment, including working as well as storage/dormant hours.
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fig. "Add mission profile"s dialog

Enter here the name for your mission profile and click OK to add it. If you want to create more profiles
immediately, click Save & proceed.

fig. Adding a Working Phase
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If you have created a mission profile, select it and add a working phase with a click on the green plus

 symbol.

fig. "Add working Phas"e dialog

Now you have to add information to the working phase in this dialog. The following list describes the
values which have to be entered:

- Name: The name of this working phase.

- phase type: ON_OFF, Permanent or dormant

- t_ae: average outside environmental temperature surrounding the equipment, during the i^th phase
of the mission profile.

- n: annual number of thermal cycles seen by the components of the PCB, corresponding to the i^th
phase of the mission profile with an average swing Δ T.

- ΔT : average swing of the thermal variation seen by the components of the PCB, corresponding to
the i^th phase of the mission profile.
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fig. Mission Profiles

If you are done, use this mission profile in the FIT details for IEC62380 catalogs.

Failure Rate Catalogs
SOX provides the IEC62380 and the SN29500 failure rate catalogs which contain categories and
component Types. They are implemented with installing SOX. The catalogs are stored in the System
folder in the Catalogs view.

Note

Failure rate- and failure mode catalogs in the System folder can not be edited!
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fig. "Catalog"s view

The Failure Rate Catalogs view displays all failure rate catalogs from the System and Public folder.
Use this view to assign failure rates to components via drag & drop. Different catalogs can be selected
with the triangle  symbol.

fig. "Failure Rate Catalog"s view

Note

In this view the catalogs can not be edited. Use the public folder in the Catalogs view for creating,
importing and editing catalogs.

Creating a New Failure Rate Catalog

Precondition: The Catalogs view is active.

1. Right-click on the Public folder.

2. Choose New > Failure rate catalog (IEC62380 or SN29500)

► The dialog "New IEC62380/SN29500 Catalog" opens.
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fig. "New IEC62380 Catalo"g dialog

3. Use the Browse button to specify the file location.

4. The Catalog ID will be set automatically.

5. Enter a name for the catalog.

6. Optionally, enter a description.

7. Click Finish.

→ A new catalog was created and opened in the editor.

fig. Catalog editor (IEC62380)
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A failure rate catalog is subdivided into categories and failure mode types.

Creating Categories

Precondition: A catalog was created and the catalog editor is active.

1. Right-click on the catalog in the editor.

fig. Context menu for new category

2. Choose New > Category.

► The dialog "Create new Category" opens.

3. Enter a name for the category.

4. Click OK to finish or Save & proceed to create further categories.

→ A category was created.

To create sub-categories you have to select a parent category at first and than repeat the procedure
create categories.

Creating Component Types

Precondition: A component category was created.

1. Right-click on the category folder which shall contain the component type.
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fig. Context menu for new component type

2. Choose New > Component Type.

► The dilalog "Create new Component Type" opens.

fig. Dialog "Create new Component Typ"e

3. Enter a name for the component type.

4. Click OK to finish or Save & proceed to create further component types.

→ A new component type was created and added to the selected category.

Now the component type can be edited in the Details part of the Catalog editor.
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fig. Catalog editor with Details according to the IEC62380 scheme

[1] Catalog explorer

[2] Details of a component type (IEC62380 in this example)

Importing a Failure Rate Catalog

Note

Catalogs can only be imported in the public folder.

1. Right-click in the Catalogs view on the public folder.

2. Choose Import > Catalog.

► The "Import" dialog opens.

fig. Dialog "Catalog impor"t

3. Click on Browse... to choose the desired source file.

4. Click on Browse... to choose the target folder

5. Enter a name for the catalog.

6. Optionally, enter a description.

7.
The UID will be set automatically. If the UID already exists, click on the button  to generate
a new one.
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fig. Alert "Delete UI"D

8. Click on Finish.

→ A catalog was imported and added to the Public folder in the catalogs view.

Exporting a Failure Rate Catalog
Catalogs can be exported from the System and Public folder.

1. Right-click in the Catalogs view on the desired catalog.

2. Choose Export > Catalog.

► The dialog "Catalog Export" opens.

fig. Dialog "Catalog Expor"t

3. Click on Browse to specify the file location.

4. Click on Finish.

→ A catalog was exported and saved to the choose location.

Assign Failure Rates to Components
Failure rates can be assigned in the creating a component procedure or with drag & drop out from the
Failure Rate Catalogs view into the editor:
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Precondition: A component was created. The Failure Rate Catalogs view and the BOM editor are
active.

1. Click on the arrow button to select a failure rate catalog.

fig. Failure rate catalog selection

► The selected catalog will be displayed.

2. Select the desired failure rate.

fig. Failure rate selection

3. Drag & drop it into the convenient column in the BOM editor.

►The alert "Component type assignment" opens.
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fig. Component type assignment alert

4. Click Yes to adopt the parameters.

→ A failure rate with its parameters has been assigned to a component.

Failure Mode Catalogs
SOX provides the IEC62380 and the Birolini failure mode catalogs which contain failure mode types
and failure modes. They are implemented with installing SOX. The catalogs are stored in the System
folder in the Catalogs view.

fig. "Catalog"s view

The Failure mode catalogs view displays all failure mode catalogs from the System and Public folder.
Use this view to assign failure modes to components via drag & drop. Different catalogs can be selected
with the triangle  symbol.

fig. "Failure mode catalog"s view

Note

In this view the catalogs can not be edited. Use the public folder in the Catalogs view for creating,
importing and editing catalogs.
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Note

Failure rate- and failure mode catalogs in the System folder can not be edited!

Creating a New Failure Rate Catalog

Precondition: The Catalogs view is active.

1. Right-click on the Public folder.

2. Choose New > Failure mode catalog.

► The dialog "New failure mode catalog" opens.

fig. Dialog "New failure mode catalo"g

3. Click Browse to specify the file location.

4. The Catalog ID will be set automatically.

5. Enter a name for the catalog.

6. Optionally, enter a description.

7. Click Finish.

→ A new catalog has been created and opened as an editor.

Creating New Failure Mode Types.

Precondition: A catalog was created and the catalog editor is active.

1. Right-click on the catalog in the editor.
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fig. Context menu for new failure mode type

2. Choose New > Failure mode type

► The dialog "Create new Failure Mode Type" opens.

fig. Dialog "Create new Failure Mode Typ"e

3. Enter a name for the failure mode type.

4. Click OK to finish or Save & proceed for creating further failure mode types.

→ A failure mode type has been created.

Creating Failure Modes

Precondition: A failure mode type was created.
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1. Right-click on the failure mode type which shall contain the component type.

fig. Context menu for new failure mode

2. Choose New > Failure Mode.

► The dialog "Create new Failure Mode" opens.

fig. Create new Failure Mode dialog

3. Enter a name for the failure mode.

4. Click OK to finish or Save & proceed to create further failure modes.

→ A new failure mode was created and added to the selected failure mode type.

Now the failure mode can be edited in the Details part of the Catalog editor.
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fig. Failure mode catalog editor

[1] Catalog explorer

[2] Details of a failure mode type.

Note

The split value of all failure modes has to be 100%.

Assign Failure Modes to Components

Failure modes can be assigned in the creating a component procedure or with drag & drop out from
the Failure mode Catalogs view into the editor:

Precondition: A component was created. The Failure Mode Catalogs view and the BOM editor are
active.

1. Click on the arrow  button to select a failure mode catalog.

fig. Failure mode catalog selection

►The selected catalog will be displayed.

2. Select the desired failure mode.
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fig. Failure mode selection

3. Drag & drop it into the convenient column in the BOM editor.

→ A failure mode with its parameters was assigned to a component.

BOM Modules
Modules can be defined here so that FIT rates can be calculated modularly (modular FIT calculation
for different functional groups).

fig. BOM Modules view

The BOM Modules view shows you the overall system with the different component groups of your
BOM and Total FIT/ FIT.

- FIT (Failure in time): This number is calculated from FIT details, temperature profile and mission
profiles.

- Total FIT: FIT * Factor = Total FIT

The number in brackets behind modules shows you the number of components in the module. If there
are components which are not yet connected to a group, the counter behind "unassigned" will increase.

You can create submodules in the same way as creating BOM modules: Right-click on an existing
assembly group and follow the same steps as shown to create a submodule.
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Note

Notice: It's not possible to create more levels of subgroups below an assembly group than one.
If you import an Excel project with more than one level of submodules there will be an error
message and the import aborts. If this happens please adapt your BOM Excel data so that there
are no more than one subgroup.

fig. Show / Hide components

To connect components with an assembly group, right-click on the component, go to Assembly group
and choose the group you need. Another way is to double-click the section in the Assembly group
column of your component. Choose your group from the list as shown in the picture below.

fig. Context menu for switching assembly group
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BOM Editor
The BOM editor gives an overview on all your components, failure modes, FIT values and much more.

fig. BOM editor

[1] This area shows the actual BOM module. With a click on the triangle  the BOM module can
be changed by selecting the desired one.

[2] Tool bar with the following functions:

Decide with this filter which elements should
be shown. (All, Not Imported, New, Changed,
Deleted)

Toggle Status Colors: Every component status has
it's own color (e.g. Review = yellow). Press this
button to turn the colors on or off .

Show state of import: Turn on or off the import
status with this button.

Modules: Activate this first if you want to filter for
certain modules. Then click on the corresponding
module in the BOM Modules view below. Now
the BOM editor only shows elements of the
selected module.

New component: Create a new component with
this button.

New Failure Mode: Create a new failure mode
with this button. This button will be disabled if
you haven't selected a component.

Expand-/Collapse all

Switch views Modules/Components: Use this
button to change the table either to the Modules
view where you see just the BOM modules or
to the components view where you can see your
components with failure modes.
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[3] In this area the BOM is displayed and can be edited.

Status: You can change the status of each component with a double-click on the component in the
status column. Then a little list pops up with "Open" (set as standard), "Review" and "Closed". If you
want to hide the failure modes of an component, just click the "-" symbol. Click "+" to show them.

Name: This column represents the name of the component. You can change the name with a double-
click on the component in the name column.

Description: If you have set a description in the "New Component" dialog, this description will appear
in this column. You can add or change the description with a double-click on the field.

Factor: The number of times this component exists in the system. Important for Total FIT:

FIT * Factor = Total FIT

Product Code: Enter your product code for this component.

Assembly group: If there is an existing assembly group, you can connect your component to this
group by double-clicking on the component in the assembly group column. A list will pop up from
which you have to choose the group if there is more than one.

Basis FIT:  The value of "Basis FIT" comes from the Siemens catalog and is fixed. This is set
automatically, so you can't change this value if you have chosen a catalog and component type.

FIT %: This is only relevant for modules defined as a component type. FIT % describes the proportion
of the component in percent, relative to the Total FIT.

FIT: Is the failure in time value without the factor. The value comes from the chosen catalog. It changes
with the manipulation of "FIT Details", "Temperature profiles" and "Mission profiles".

Total FIT: The value of total FIT is calculated from FIT * Factor.

Catalog: The catalog column shows you the catalog of your component. This catalog is set in the
"New Component" dialog and can be sn29500, IEC62380 or custom. You can set the FIT value for
yourself if you haven't chosen a catalog. This isn't possible if you have chosen a catalog.

Catalog component type: You can find the component type in this column which you have set in the
"New Component" dialog.

Additional Functionality
Importing Data from Excel

About the SOX BOM template:

With the SOX BOM template you can exchange data between SOX and Microsoft Excel. You
can download the SOX BOM template at the EnCo template section at the Welcome Screen or at
the download center.  [http://www.enco-software.com/download-site/]It is avlailable for the norms
IEC62380 an SN29500.

Decsription of the structure of the BOM template:

The BOM template for Excel has a certain structure that SOX will recognize. Do not change the
structure. However, you can add or change information right in Excel. For example, you can add
components in the sheet “BOM”. Later when you import the Excel file into SOX2, these changes will
be applied in SOX. When you import it into your BOM document, just choose the “EnCo Internal”
file format in the import dialog.
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The Excel file:

The first sheet in the Excel file („BOM Master File Data“) contains the master file data or metadata
about the BOM file. The second sheet (“BOM”) contains the actual bill of materials:

fig. BOM template for Excel, sheet no. 2

The third sheet lists the modules. The forth contains all the component types in the norm. The sheet
"Failure Modes" lists the failure modes with ID, name and split (%). The sixth contains the temperature
profiles. For the norm IEC62380 there also is a sheet for mission profiles.

Importing data from Excel:

Precondition: A BOM document was created and opened. The content to be imported is available as
an Excel file compliant to the Excel template provided by EnCo Software.

1. Open the menu bar point File.

2. Choose Import > BOM Import.

►The BOM import wizard opens.
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fig. BOM import wizard

3. Choose the EnCo Internal format.

4. Click on Browse... to choose the desired file.

5. Click on Finish.

► The dialog "Select options" opens.
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fig. BOM import wizard

6. Select the content that should be imported.

7. Click Next >.

► The dialog "Mapping of imported elements" opens.
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fig. BOM import wizard

8. Click on Finish.

→ A BOM was imported and added to the repository.

Creating Project Data
Precondition: A BOM document, the BOM Modules view and the FIT Details view are open.

1. Select a module or the overall system in the BOM Modules view.

fig. Selection in the BOM Modules view
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2. Select a failure rate catalog in the FIT Details view.

fig. Failure rate catalog selection in the FIT Details view

3. Assign a temperature profile. (Create a temperature profile).

fig. FIT Details SN29500

4. Assign a mission profile (if IEC62380). (Create a mission profile)
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fig. FIT Details IEC62380

→ The FIT value will be calculated in consideration of the chosen failure rate and the temperature/
mission profile.
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The SOX System Designer module offers extensive solutions for modeling your systems with OMG
SysML 1.4 and UML 2.0 standards. Define your system with different diagram types and link
requirements from the SOX Requirements Module to system design elements.

In SOX, objects that can be reused over multiple documents (requirements, functions, malfunctions,
diagnoses, safety goals) and relationships between them are automatically in the system design
as stereotyped SysML elements. A stereotype is a specific "marker" that can be applied
to SysML elements to mark a specific meaning of the element. SOX uses the following
stereotypes: SystemElement, Function (including subtypes such as SafetyFunction, Diagnosis or
ProcessCharacteristics), Malfunction, Requirement, and SafetyGoal.

Diagrams
With SOX you can use and create all SysML 1.4 diagrams and the basic UML diagrams. In addition,
SOX provides two additional diagram types, SOX Functions diagram and SOX Requirements diagram,
to be used to create SOX-specific stereotypes in a convenient manner.

As in other SysML/UML modeling tools, a diagram presents only a specific view on the overall system.
One element can appear in multiple diagrams and you can delete an element from diagram without
deleting it from the overall model. The overall system is available in the "Model Explorer" view. To
add an already existing element to a diagram, just drag it from the "Model Explorer" view or "Object
List" view into the diagram. Please note that elements created in other SOX modules are automatically
added to the system design and do not need to be re-created there.

Create Diagrams
Diagrams can be created from the Model Explorer view. Creating a diagram can be performed by
right clicking on one of the shown model classes on the picture . The selected element will be the
owner of the diagram.

1. Right-click SysML 1.4 model.

2. Choose New Diagram.
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3. Choose your desired diagram type.

► A name dialog window opens.

4. Choose a name for the diagram.

5. Click OK.

► The diagram editor opens.

Note

The diagrams will be saved and can be found in the Model Explorer view.
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fig. Model Explorer view with active filter "Show diagram"s.

Created diagrams can also be opened in the "Open diagrams\documents" dialog which can be

found by clicking on the open diagrams\documents icon  at the toolbar.

fig. Open diagrams\documents dialog.

The Diagram Editor
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[1] In this area the diagram can be created and edited.

[2] Tool-Palette that contains:

Select single objects or more by holding down the
mouse button.

Left-click to zoom in.

Left-click to zoom out.

Select the objects completely including into the
rectangle area.

Standard marquee selection.

Nodes only.

Labels only.

Connections only.

Select the objects intersecting and including the
marquee rectangle

Intersection selection

Nodes only (intersection)

Labels only (intersection)

Connections only (intersection)

[3] In this explorer all objects are listed that can be used for the diagram.

Exemplary Method for Designing the System Structure with
SysML 1.4

Precondition: A SOX Project was created and opened.
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1. Right-click on SysML 1.4 model in the Model Explorer view.

2. Choose New Diagram > SysML 1.4 Block Definition.

► A name dialog window opens.

3. Choose a name for the diagram.

4. Click OK.

► The Diagram Editor opens.

1. Left-click on SystemElement.

2. Left-click in the editor.

► A system element was created.

Note: The name of the objects can be edited directly after they have been created, in the properties
view or using the short cut function F2.

3. Define the system structure
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Note: Use the "PartAssociaton" connectors to define the system structure hierarchy.

1. Select a connector with a left-click. (PartAssociation)

2. Select a parent SystemElement with a left-click.

3. Select the child SystemElement with a left-click.

Note: The diagram can be modeled for your desire. Click here for more information.

207



System Designer

Deleting In Diagrams
Do a right-click on an element in the diagram editor to:

• Delete Selected Element will delete the element from the entire model and also from all diagrams
where it was present.

• Delete From Diagram will hide the element just in this diagram.

SOX Functions
Create a SOX Function diagram to specify a Functions net, their hierarchy, associated malfunctions,
and allocations of functions to system elements. Malfunctions are assigned to functions via a
Composition relationship from the function to the malfunction. Functions are assigned to system
elements via an Allocate relationship.
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Connections between malfunctions defined in failure nets (cause-effect-relationships) are added to the
system design as well. They are represented in SysML by dependencies with a SOX-specific stereotype
Effects applied. Hence, the failure net connections can be represented by, e.g., a Function diagram

The SOX Functions diagram has been extended with the following Stereotypes:

• Function (stereotyped SysML Block)

• Malfunction (stereotyped SysML Block)

• Diagnoses (stereotyped SysML Block)

• Safetyfunction (typo)

• ProcessCharacteristics (stereotyped SysML Block)

• ProductCharacteristics (stereotyped SysML Block)

• InterfaceFunction (stereotyped SysML Block)

• GovernmentFunction (stereotyped SysML Block)

• SecurityFunciton (typo)

• SystemElement (stereotyped SysML Block)

SOX Requirements
The SOX Requirements diagram has been extended with the following stereotypes:

• SafetyGoal (stereotyped SysML Requirement)

• SystemElement (stereotyped SysML Block)

Note: You have to create a Requirement document in the RM Module, before creating a SOX
Requirement diagram. This is necessary to select a parent module and type of a requirement in the
diagram editor.

Requirements can be created or imported (ReqIF format) in the RM (Requirements) module. All
added/imported requirements are automatically available in the system design and can be dragged
there into diagrams to link them with system design elements (Satisfy relationship in SysML). Linking
requirement with system design elements in other modules (e.g., FMEA editor) can be performed by
just dragging a requirement on the desired element. This causes automated creation of a corresponding
Satisfy relationship in the system design.
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Apply Stereotypes
Warning
Manually applying/removing SOX Stereotypes changes the meaning of an element in SOX which
can have unintended consequences, e.g., if the element is already used in other documents.

1. Create an element in the diagram editor.

2. Select the element.

3. Open the Properties view.

4. Choose Profile.

5.
Click on the Apply stereotype symbol .

► The Stereotype window opens.

6. Select the desired stereotypes.

7.
Use the arrows     to move the chosen stereotypes.
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8. Click OK to finish the process.

→ The chosen stereotypes have been applied to the object.

With the Remove stereotype icon  you can delete stereotypes from the selected object.

Import System Design (UML/SysML)
You can import systems designed with UML/SysML 1.4 (Supported input format: Enterprise Architect
XMI 2.1.).

Note

Individual Profiles can not be imported.

Precondition: A SOX project was created/imported and the target project selected.

1. Right-click in the Repository view and choose Import...

► The "Import" wizard opens.

fig. "Impor"t wizard.
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2. Choose Import System Design (UML/SysML).

3. Click Next.

► The "System Design (UML/SysML) Import" opens.

4. Select the desired source file.

5. The target location has to be a SysML 1.4 model or a sub folder of this package.

6. Click Next.

► The "Import Model" dialog opens.

7. The drill down menu shows all model elements that will be imported.

8. Click Next.

► The "Diagnosis" dialog opens.

Note
Individual SysML profiles can not be imported. You can review in the "Diagnosis" dialog all
objects that can not be imported. If you want to create diagrams with this objects you have
to create them later.

9. Click Next.

► The "Apply Stereotype" wizard opens.

Select the desired objects from the imported model and apply SOX stereotypes to them. The
following list shows a standard combination of UML objects and SOX stereotypes (other
combinations are also possible)

UML Object SOX Stereotype
Blocks System Element

Blocks, Activities Function

Classes Malfunction

10.Click Finish.

→ The system design will be imported and added to the SOX project (Design) and SysML 1.4 model.

Export Diagrams as Pictures
With SOX you can export diagrams as pictures in different formats: GIF, BMP, JPEG, JPG, SVG,
PNG, PDF.

Recommendation: SVG, the size for the elements of this vector image format can be scaled for your
desires without degradation.

Export a Single Diagram
1. Open the diagram in the editor.

2. Right-click in the editor on an empty area.

3. Choose File > Save As Image File.

►Save As Image File window opens.
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1. Select the output directory.

2. Choose a File Name.

3. Choose an output Image Format.

NOTE: The quality can be changed if you choose JPEG as Image Format.

4. Do a mark for overwriting an existing file without warning.

5. Do a mark for exporting the diagram as HTML so you can display the diagram in your browser.

6. Click OK to export the diagram.

→The diagram was exported and saved to your chosen file path.

Export all Diagrams
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1. Right-click in the Model Explorer on SysML 1.4 model

► The Export All diagrams window opens.

1. Select the output directory.

2. Choose an output Image Format.

NOTE: The quality can be changed if you choose JPEG as Image Format.

3. Click OK to export all diagrams.

Note: If "Prefix with qualified name" is marked, the diagram name will be provided with the prefix
e.g. SysML 1.4 model.

→ The diagrams were exported and saved to your chosen file path.

Derive a FMEA from System Design
It is possible to automatically initialize a new FMEA document with the structure from the system
design starting from a chosen root system element.

Precondition: The system design has been defined.
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1. Right-click in the Model Explorer on the desired root element.

2. Choose Create FMEA.

► The File import window opens.

3. Select a target folder where the FMEA should be saved. (FMEA Folder)

4. Choose a filename.

5. Click Finish.

→ The FMEA with all relations that were defined in the Model Explorer was created.

Semantics of SysML Relationships in SOX
The main relationships between elements are stored in the system design as well and, hence, kept
consistent across all documents: Hierarchy of system elements, hierarchy of functions, assignment
of functions to system elements, assignment of malfunction to functions, cause-effect relationships
between malfunctions, assignment of safety goals to functions, and assignment of requirements to
system design elements. Again, adding such a relationship in one document automatically creates a
corresponding relationship in the system design (but not vice versa) and deleting such a relationship
in the system design can result in appearance of a “Refactoring” dialogue that informs about the
consequences.

The following table lists the relationships that are relevant in multiple types of documents/diagrams
and their meaning within a certain document/diagram type:
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• Association

specifies peer-to-peer relationships between model elements, e.g. if a Class-x has an attribute of
type Class-y, it can be viewed in a class diagram as a Association between Class-x and Class-y.

• Aggregation

is used to model a whole/part relationship between model elements. The part element can exist
without the whole. Aggregation causes the generated code to contain the aggregate either by
reference or by value, depending on the details of the relationship. E.g. to model an aggregation,
the aggregate (Department) has an aggregation association to its constituent parts (Employee). A
hollow diamond is attached to the end of an association path on the side of the aggregate (the whole)
to indicate aggregation.

• Composition

is an aggregation with strong ownership, i.e. when the container is deleted, all of its composite
objects are deleted as well.

• Dependency

is a relationship in which one model element uses another. Dependency may exist between classes
if a message is sent from one class to the other or if one class mentions the other as a parameter to
an operation. Dependency may exist between packages if one package is dependent on another.

• Generalization

relationship causes a class to be generated as a subclass of another class.

• Realizes
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relationship specifies that, e.g. an implementation realizes a specification. The Realizes relationship
does not affect the code.

To create a relationship between two modeling elements, use the tool palette in the diagram editor,
e.g. to create an Association between two classes, select the Association tool in the tool palette,
click on the source element and then click on the destination element.

Diagram Modeling Tools

Select

For selecting all elements,shapes and connectors in the diagram editor, do a right-click on an empty

area and choose select. You can also use the select icon from the toolbar .

To select more items manually use ctrl + left-click.

Arrange

With this function you can arrange the diagram automatically.

Note: The structure will be arranged by considering the connectors/relations.

Shape Align

1. Select all desired elements.

Note: The last selected element will define the position for all elements.

2. Right-click on one selected element.
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3. Choose Format > Alignment.

→ The selected elements will be aligned with your chosen method.

Connectors/Relations

You can model the connectors/relations with the Line Style function.

1. Select all desired connectors.

2. Right-click on one selected element.
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3. Choose Format > Line Style.

→ The selected lines will be routed in your chosen style.

Shape Size

1. Select all desired elements.

Note: The last selected element will define the size for all elements.

2. Right-click on one selected element.
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3. Choose Format > Make Same Size.

→ The selected elements will have the same size after your selection.

Rulers and Grid
The Rulers and Grid function supports you to create diagrams organized and descriptive. It is a helping
tool and will not be displayed in the printed/exported diagrams.

[1] Display

• Show Grid
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Put a mark to show/hide the grid.

• Grid In Front

Put a mark to set the grid in front or behind the diagram objects.

• Show ruler

Put a mark to show/hide the ruler which can be scaled in different units and spacing.

[2] Snap

• Snap To Grid

Put a mark to snap the diagram objects to the grid automatically.

• Snap To Shapes

Put a mark to snap the diagram objects to the shapes.

[3] Measurement

• Ruler Units

You can choose between Inches, Pixels, Centimeters.

• Grid Spacing

Set the spacing of the grid lines.

[4] Grid Line

• Color

Choose a desired color for the grid lines.

• Style

You can choose between Dash, Dash Dot, Dash Dot Dot, Dot, Solid, Custom.

[5] Reset Default

Use this button to set the ruler and grid settings to its default.
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Properties view

This is the default place of the properties view.

For the different types of selection nodes, edges there are different register.

Empty Area

General informations of an opened diagram are shown and can be edited if no object is selected.
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Nodes

Informations of nodes are shown and can be edited if a node is selected. Also stereotypes can be
applied.

Edges

Informations of edges are shown and can be edited if a edge (connector, relation) is selected. You can
also specifies the kind of aggregation that applies to the properties.

Filter
You can find all filter with a right-click on a element in your diagram editor or in the toolbar.
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• Show/Hide Compartments

Use this function to select the compartments of an element that are should displayed in the editor.

• Show/Hide Content

Use this function to select the content of an element that are should displayed in the editor. This is
primary necessary in the internal block diagram (IBD). You can also use the drag & drop function
for ports and properties.

• Show/Hide Related Link

Use this function to select the connectors/relations between elements that are should displayed.

Model Explorer
All existing system design elements of a project are listed in the “Model Explorer” view and can
be reused from there, e.g., by dragging and dropping them into other documents. Alternatively, it is
possible to open one or more “Object list" views to show lists of all existing elements of a specific type.

Symbol definition:

Sort elements alphabetically.

Customize the Model Explorer.

Toggle advanced Model Explorer.

Link with editor. A handy feature to select objects:
If this is active, every object you select in the
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editor will also be immediately selected in the
model explorer and vice versa.

Show diagrams. This shows all diagrams in the
model and filters out everything else.

Create Elements Directly in the Model Explorer View.
1. Right-click on a parent element where the new element should be saved.

2. Choose your desired type from the topics New SysML Child, SysML 1.4, New Child, New
Relationship, New Diagram, New Table.

3. Edit the element in the respective properties view.

Note: Elements that are not valid for respective parent elements are not displayed or shown grayed.

Create Child Models
Tip: Child models can be useful for sub-systems e.g.

1. Right-click on a parent model.

2. Choose new child > model.

All objects from a parent model can be used in the child model. Already created objects can be imported
by drag & drop or with the copy function. Imported objects that are used in a diagram of the child
model will be marked with a hyper-link symbol.
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The SOX FMEDA supports the generation of FMEDAs in accordance with ISO 26262. With the
SOX module FMEDA you can calculate safety specific metrics per component group and follow the
progress of your analysis via Status and Tasks.

The SOX module FMEDA offers not only the ability to build variants, but import hardware and system
effects from the FMEA module and easily create a network using the Drag & Drop feature.

Causes and effects of risks are systematically identified and eliminated through the appropriate
measures (e.g. diagnosis). The SOX FMEDA module possesses a variety of analysis options and via
the Reliability module the generation of failure rates in accordance with e.g. SN 29500.

Step-by-Step-Guide
Creating an FMEDA File

Precondition: A SOX Project was created and SOX Workbench perspective is active.

fig. New FMEDA file.

1. Right-click in the Repository view on the FMEDA folder.

► The context menu opens.

2. Choose New > New FMEDA File.

► The dialog "New FMEDA" opens.
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fig. "New FMED"A dialog.

3. Click on Browse... to specify the file location.

4. Enter a name for the FMEDA.

5. Choose a BOM which forms the base of the FMEDA.

6. Choose your default calculation scheme. (ISO 26262, IEC 61508)

7. If IEC 61508 is chosen, select a system type of your calculation scheme and set the HFT level.

8. Enter the Operation Time (in hours) if the default calculation scheme is ISO 26262.

9. Click on Finish.

→ An FMEDA file was created and added to the repository.

Assigning Failure Modes to Components
Hardware function/failure and system function/failure can be assigned from the FMEA, but also with
the Functions view.

Precondition: Functions and malfunctions were created, the FMEDA document is opened and the
Functions view is active.

1. Drag the desired malfunction and drop it to the according column in the editor.

► The "Add or replace" alert opens.
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fig. Add or replace alert.

2. Click on Add or Replace.

3. ► The Hardware- and System functions dialog opens.

fig. Hardware- and System functions dialog.

→ The according hardware function/failure and system function/failure will be set automatically.
But they can also changed by clicking the according Browse... button.

Note

The functionality to add or replace hardware function/failure and system function/failure is
identical.
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Assigning Safety Goals
Precondition: The FMEDA Editor and the Project safety goals view is active. A Project safety goal
was created.

1. Left-click on the Assign button of the desired safety goal.

fig. Assigning safety goals.

→ SOX automatically extends the FMEDA table with additional columns for metric calculation per
safety goal.

Calculating FMEDA according to ISO 26262
The safety engineer edits an FMEDA, assigns calculation parameter values and diagnoses to a FMEDA
document with the calculation scheme ISO 26262. SOX then performs the calculations accordingly
and displays the results.

Precondition: An FMEDA document with calculation scheme ISO 26262 is open. Diagnoses were
created. Safety goals were assigned.

fig. Calculation parameters per failure mode and safety goal.

1. Double-click to set the diagnosis.

2. Double-click to set the safety relevance SR (SP).

3. Enter the relevance (optional).

4. Enter FMC (SP).

Do the same steps for MP.
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5. Set CCF.

6. SOX calculates the resulting metrics λ and displays them.

Creating an FMEDA Report
Precondition: An FMEDA document is open.

1. In the menu bar, click on File.

2. Choose Print.

► The "FMEDA Report" wizard opens.

fig. "FMEDA Repor"t wizard.

3. Set report type.

4. Select Excel report or PDF report (PDF only for module report).

5. Set sheets (sections) to be added to the report.

6. Set FMEA data to be added to the report.

7. Click Next.

► The output dialog opens.

8. Click on Browse to specify the file location.

9. The output file will open automatically if "Open" is marked.
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10.Click on Finish.

→ An FMEDA report was created.

The User Interface

fig. User Interface FMEDA perspective.

[1] FMEDA Editor

[2] PSS view, Functions view

[3] Diagnoses view, Project safety goals view, Clipboard, Task Assignment, Project Tasks, Traces

[4] Modules view, Properties view, History view

FMEDA Editor

Functions View
The Functions view gives you an overview of all functions and their malfunctions. Moreover, you
may create or delete functions and malfunctions. The functions are listed in a tree diagram and are
sorted by corresponding modules.

Furthermore the system design is displayed and the safety goal assignments can be edited.

Creating a new Function
Precondition: The functions view is active.

1. Select the desired module or "Unassigned".

2. Choose New > New Function.

► The "Add new Function" dialog opens.
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fig. "Add new Functio"n dialog.

3. Enter a name for the function.

4. Optionally, enter a description.

To create more functions, click on Save & New, then you can directly enter a new name for a new
function. With OK you save your function and finish the process. With Cancel the process will
be canceled.

→ A new function was added to the project.

Assigning Functions to Modules
To assign a function to a module, choose the desired function and drag & drop it on a module.

Create Malfunctions
Precondition: A function was created and the function view is active.

1. Right-click on a function.

2. Choose New > New malfunction.

► The "Add malfunction" dialog opens.
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fig. "Add malfunctio"n dialog.

3. Enter a name for the new malfunction.

4. Optionally, enter a description.

To create more malfunctions, click on Save & New, then you can directly enter a new name for
a new malfunction. With OK you save your malfunction and finish the process. With Cancel the
process will be canceled.

→ A malfunction was added to the project.
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Diagnoses View

fig. Diagnoses view.

The Diagnoses view displays all diagnoses and their functions. Furthermore in this view diagnoses
can be created, edited and deleted.

Creating Diagnosis Groups
Precondition: The diagnoses view is active.

1. Right-click somewhere in the diagnosis view.

2. Choose New > New Diagnosis Group

► The "New diagnosis group" dialog opens.
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fig. "New diagnosis grou"p dialog.

To create more diagnosis groups, click on Save & New, then you can directly enter a new name for a
new diagnosis group. With OK you save your diagnosis groups and finish the process. With Cancel
the process will be canceled.

→ A new diagnosis group was created and added to the diagnosis view.

Creating Diagnoses
Precondition: A diagnosis group was created.

1. Select an existing diagnosis group.

2. Right-click on it.

3. Choose New > New Diagnosis

► The Add diagnosis dialog opens.

fig. Add diagnosis dialog.

1. Enter a name for the diagnosis.

235



FMEDA

2. Optionally, enter a description.

3. Set enabled/disabled.

Note

• IEC: Only DC Single is required.

• ISO: FMC Single/Multiple is required.

4. Enter threshold (optional).

5. Enter failure response (optional).

6. Enter off time (optional).

To create more diagnoses, click on Save & New, then you can directly enter a new name for a new
diagnosis. With OK you save your diagnosis and finish the process. With Cancel the process will be
canceled.

→ A new diagnosis was added to the selected diagnoses group.

Editing Diagnoses and Diagnosis Groups
To edit diagnoses and diagnosis groups, select the desired one. Right-click on the diagnosis and choose
Edit. After that, the "Edit diagnoses" dialog opens.

Setting the Diagnosis State
To set a diagnosis state, select your diagnosis and right-click on the desired one. Choose Set diagnosis
state and you get the options "enable" and "disable".

If you disable your diagnosis state,you will set the FMC in the overview to 0% and consequently
modify the metric calculation.

Deleting Diagnoses and Diagnosis Groups
To delete a diagnosis or a diagnosis group, right-click on the desired one and choose Delete.

The Refactoring dialog opens. To finally delete the diagnosis or diagnosis group, click on Finish.

Project Safety Goals View

fig. Project safety goals view.

The Project safety goals view displays all Project safety goals. Furthermore in this view Project safety
goals can be created, edited, deleted and assigned.
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Creating Project Safety Goals
Precondition: The Project safety goals view is active.

1. Right-click in the Project safety goals view.

2. Choose New > New safety goal.

► The" New safety goal" dialog opens.

fig. New safety goal dialog.

3. Enter a name for the safety goal.

4. Enter a Safe State.

Optional:

• Enter a EOT, FTT, FTTI.

• Enter a Safe Reduction

• Enter a Warning Concept

• Enter a Safety-coverage.

5. Choose the norm according to the desired safety calculation ASIL, SIL, PL, MSIL.

237



FMEDA

6. Choose the Safety Level according to the chosen norm.

To create more safety goals, click on Save & New, then you can directly enter a new name for a new
diagnosis. With OK you save your diagnosis and finish the process. With Cancel the process will be
canceled.

→ A new Safety goal was created.

Assigning Project Safety Goals

Precondition: The FMEDA Editor and the Project safety goals view is active. A Project safety goal
was created.

1. Left-click on the Assign button of the desired safety goal.

fig. Assign safety goals.

→ SOX automatically extends the FMEDA table with additional columns for metric calculation per
safety goal.

Merging Project Safety Goals

Precondition: Safety goals were created and the Project safety gaols view is active. The safety goals
have no safety relevance and are in the same safety norm calculation.

1. Select the desired safety goals (hold CTRL + Left-click).

2. Right-click on one selected safety goal.

3. Choose Merge safety goals.

►The "Merge Safety Goals" dialog opens.
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fig. "Merge Safety Goal"s dialog.

4. Enter a name for the new safety goal.

5. Enter the remaining parameters for the new generated safety goal.

6. Click on Finish.

→ The safety goals were merged and the newly generated safety goal will be added to your project.

Assigning Safety Relevance

Precondition: The Project safety goal has to be assigned and the FMEDA document is opened.

1. Double-click in the SR (SP) [1]/SR (MP) [2] column of the desired Failure Mode row.

fig. FMEDA Editor.

→ The failure mode is now safety related which is displayed by a X symbol.
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Tip

• Several relevance can be assigned with multiple selection.

1. Hold CTRL and click on the desired rows.

2. Press F2.

• All relevance can be assigned

1. Double-click on the column title SR (SP)/SR (MP)

► All rows are marked.

2. Press F2.

Note

The relevance of each safety goal can be scaled in percent in the Relevance (SP)/(MP) column.
This has an effect on the safety calculation.

Edit Project Safety Goals

To edit Project safety goals, select the desired one. Right-click on it and choose Edit. After that, the
"Edit Project safety goals" dialog opens.

Deleting Project Safety Goals

To delete a Project safety goal, right-click on the desired one and choose Delete.

The Refactoring dialog opens. To finally delete the project safety goal, click on Finish.

Additional Functionality
Linking FMEA and FMEDA

The functions and malfunctions from the FMEA analysis can be used for the FMEDA document.

Precondition: A FMEA was created, a FMEDA document is opened and the PSS view is active.

1. Open the FMEA in the PSS view.
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fig. Opened FMEA in the PSS view.

2. Drag the malfunction desired as hardware/system failure.

3. Drop it to the according column in the FMEDA editor.

► The "Add or replace" alert opens.

fig. Add or replace alert.

Add/Replace

► The add Hardware- and System functions dialog opens.
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fig. Add Hardware- and System functions dialog.

[1] According hardware function of the chosen hardware failure

[2] Chosen hardware failure

[3] Selection of system failure

[4] System functions and system failure.

To remove the system functions and system failure, select the desired one [4] and press the button
Remove [5].
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fig. [3] Selection of system failure.

[1] Linked malfunctions from the failure net and level info (blue).

[2] Remaining malfunctions from the project.

Click on Finish.

→ A hardware function/failure and system function/failure will be added and the safety goal
assignment will be adopted and displayed in the column SE SG.

Replace

► The " Hardware- and System functions" dialog opens.
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fig. "Hardware- and System function"s dialog.

The according hardware function/failure and system function/failure will be set automatically. But
they can also be changed by clicking the according Browse... button.

Note

The functionality to add or replace hardware function/failure and system function/failure is
identical.

Synchronize with FMEA
This function is a semi-automatic support for synchronization of FMEDA system effects and hardware
failures with FMEA. After activate the Sync function, the following analyses will be executed by SOX.

• Empty hardware effect

fig. Empty hardware effect at a FMEDA.

• Empty system effect
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fig. Empty system effect at a FMEDA.

• Not safety-related system effect

fig. Not safety-related system effect at a FMEDA.

• Missing system effect

fig. Missing system effect.

In this case, the system failure (MF10) is provided with three hardware failures (MF1, MF58, MF2)
at the FMEA failure net and MF58 is missing at the FMEDA. This will be recognized by the
synchronize with FMEA function.

• Hardware effect not assigned to modul
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fig. Hardware effect is not assigned to modul at the FMEDA.

• Missing hardware effect

fig. Missing hardware effect.

Precondition: A FMEDA and FMEA were created.

1. Go to the Repository view and right-click on the desired FMEDA.
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fig. Context menu entry Sync with FMEA.

2. Choose Sync with FMEA.

►The FMEA Selection dialog opens.

3. Select your desired FMEA and click on Next.

► The Analysis Results dialog opens.
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fig. Analysis Results dialog.

[1] In this area you can drag columns. Same messages of the dragged column will be grouped. With
a right click on a dragged column you can ungroup the messages.

[2] In this area the results of the analyses are displayed.

[3]

• Toggle Group By Header

Shows or hides the area [1] for dragging columns to group.

• Collapse All

Collapse all expanded groups.

• Expand All

Expand all collapsed groups.

• Export

Export the analysis results as an Excel Workbook (.xls).

• Refresh

Refresh the analysis results. This can be necessary by editing the FMEDA while this dialog is
active.

4. Select your desired results, make a right-click and choose Quick Fix.

Note: The selection in dialog triggers selection in the editor or PSS.

► The Quick Fix dialog opens.
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fig. Quick Fix dialog.

5. Select the desired changes and click OK.

→ The selected changes will be added to the FMEDA.
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Introduction

The SOX Requirements module offers a complete solution for creating , tracking and analyzing
requirements. Import your product requirements specifications from Excel, Word, ReqIF or Rif and
create the functional specification document in SOX . For this, you can reuse data from former projects
from the server-based catalog, compare different concepts and make status alignments via the SOX
Traceability Matrix.

Step-by-Step-Guide
Creating an RM File

Precondition: A SOX project was created and the Repository view is active.

1. Right-click on the RM folder in the repository.

2. Choose New > New RM File.

fig. New RM file from the Repository.

► The dialog "New requirements file" opens.
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fig. "New requirements fil"e dialog.

3. Click on Browse to specify the file location.

4. Enter a filename.

5. Optionally, enter a description.

6. Click on Finish.

→ A new RM file with the RM module specification document and the according type definition was
added to the repository.

Creating new Requirement Types
A requirement type is needed to define the number and kind of the characteristics of a requirement.
I.e. a requirement type consists of a collection of attributes. Also the table head will be designed by
these types.

Precondition: The view "Type Definitio"n is open.

1. Right-click in the "Type Definition" view.

2. Choose New > New Requirement Type.

► The dialog "New requirement type" opens.
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fig. "New requirement typ"e dialog.

3. Enter a name for the requirement type.

4. Optionally, enter a description.

5. Set the safety relevance for the requirement type.

Insert Attributes

Create New Attributes

6. Click on Finish.

→ A requirement type was created and added to the view "Type Definition".

Inserting Attributes

Already existing attributes can be used for the requirement type.

1. Click on Insert.

► The dialog "Attribute selection" opens.
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fig. "Attribute selectio"n dialog.

2. Select the desired attribute.

3. Click on OK.

→ The selected attribute was added to the requirement type.

Creating new Attributes
1. Click on New.

Note

Name and Status attributes must be applied specifically if you want to import an Excel file. A
name attribute has to be named with ReqIF.Name. A status attribute has to be provided with
the SOX.Status type.

fig. Attribute settings.
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[1] Name for the attribute

[2] String, Boolean, Integer, Real, Date, Enumeration (can be customized), XHTML, SOX.Status

[3] Default value

[4] Optionally, enter a description

→ An attribute was created.

Creating Requirement Modules
A module represents a collection of requirements. However, as a requirement needs to be assigned to
a module, the creation of module is mandatory.

Precondition: The Hierarchy view is active.

1. Right-click in the hierarchy view.

2. Choose New > New Module.

► The dialog "New module" opens.

fig. "New Modul"e dialog.

3. Enter a name for the module.

4. Optionally, enter a description.

5. Click on Browse to choose a module type or create a new one by clicking on the plus symbol.

6. Click on Finish.

→ A module was created and added to the Hierarchy view.

Creating new Requirements
It is possible to create an arbitrary amount of requirements. Requirements consist of a defined amount
and kind of attributes. These attributes can be combined to an attribute type.
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Every requirement needs to have an attribute type which defines kind and amount of attributes.

Requirements themselves have to be assigned to a module.

Precondition: A Module was created and the Hierarchy view is active.

fig. Context menu for new requirement.

1. Right-click on the parent module.

2. Choose New > New Requirement.

► The dialog "New requirement" opens.

fig. "New requiremen"t dialog.

3. Click on Select to choose the parent module.

4. Click on Select to choose the requirement type.

5. Enter a name.

6. Enter a text. It will be displayed in the text column.

7. Click on Finish.

→ A requirement was created and added to the module. It also will be displayed in the RM editor.
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Assigning Safety Goals
Precondition: Requirements and Safety Goals were created. The RM Editor and the Project Safety
goal view is active.

1. Select the desired safety goal.

2. Drag & drop it into the desired requirement row and safety goals column.

► The safety goal level will be adopted and the assigned requirement will be marked.

→ A requirement was assigned to a safety goal.

The User Interface

fig. The User Interface

[1] Hierarchy, PSS

[2] RM Editor

[3] Type Definition

[4] Project safety goals, Clipboard

[5] Modules, Properties, Task Assignment, Link Modules, Traces, History

The Hierarchy View
The Hierarchy view displays the requirement modules and their related requirements. Furthermore
requirements and modules can be created and organized here.
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fig. "Hierarch"y view.

•
 New module

Triggers the new module dialog to create a new module.

•
 New requirement

Triggers the new requirement dialog to create a new requirement.

The RM Editor
The RM editor shows all requirements of a project in table form. Every module is a separate table.
The table head is given by the requirement types and can be customized in this way. The table rows
are numbered. There are also columns for assigning safety goals.
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fig. RM Editor.

•
 Import status

Show/Hide the import status.

•
 New requirement

Opens the dialog "New requirement", to create a new requirement.

•
 Delete requirement

Deletes the selected requirement.

Customizing the Tables
The table can be customized by the requirement types or using the table modeling functions. Do a
right-click on the table head to open the context menu.

•
 Hide column

Hides the selected column.

•
Show all columns

Shows all columns

• Group selected columns

Groups the selected columns. To select several columns at once, hold down the CTRL key and left-
click the columns.
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• Ungroup selected columns

Ungroups the selected columns. To select several columns at once, hold down the CTRL key and
left-click the columns.

•
 Auto resize column

Resizes the column to the minimal size

•
 Edit styles

Opens the dialog "Customize style".

fig. "Customize styl"e dialog.

• Rename column

Renames the column. (Not the attribute!)

•
 Clear all filters

Clears all filters.

•
 Choose columns

Opens the dialog "Column Chooser".
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fig. "Column Choose"r dialog.

[1] Available Columns (not active in the editor).

[2] Selected Columns (active in the editor). The order from top to down defines the order of the table
head form left to right.

Use the arrow symbols to move the columns.

Sorting and Filtering
Click on the desired table head to sort the according column alphabetically. An arrow shows the
direction.

fig. Sorted column from a-z (▲).

Use the filter cell to filter a column.

fig. Filter cell.

Dragging & Dropping Pictures into the Editor
Pictures and screen shots can be used in the RM Editor per drag & drop from your system into the
requirement editor. Possible image files are: svg, gif, jpeg, png.

The Type Definition View
The "Type Definition" view shows the requirement types and the according attributes. Furthermore,
requirement types and attributes can be created and deleted.
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fig. "Type Definitio"n view.

•
 New Requirement Type

Opens the dialog "New requirement" dialog to create a new requirement type.

The Modules View
The "Modules" view shows all requirement modules of the active project. Furthermore, modules and
requirements can be created, deleted and copied. Also tasks can be assigned and comments created.

fig. "Module"s view.

•
 New Module

Opens the dialog "New module" to create a new module.
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The Link Modules View

fig. "Link Module"s view.

Additional Functionality
Linking Requirements

Requirements can be linked with other SOX elements. For example, a requirement can be assigned
to a system element:

Precondition: A requirement and a system element have been created. The RM editor and the PSS
view are active.

1. Select the desired requirement.

2. Drag & drop it from the RM editor onto the desired element in the PSS view.

► The linked element will be marked with a requirement symbol and the requirement will be added
to the element in the PSS view.
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fig. Decorator for linked requirement .

→ A requirement was linked with an element.

Note

The safety level will be adopted, if the element is assigned with a safety goal.

The following elements can be linked with requirements:

• BOM modules

• System elements

• Functions/malfunctions

• Safety goals

Safety Classification

Adding a Safety Classification

Safety classifications can be added in the model explorer, in the RM Hierarchy view, PSS view and
in the diagram.

Precondition: A requirement was created.
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fig. Context menu for adding a safety level in the Hierarchy view.

1. Right-click on the respective requirement.

2. Choose Add safety level.

► The dialog "Add safety level" opens.

fig. "Add safety leve"l dialog.

3. Choose the safety level.
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4. Click on OK.

→ A safety level was added to the requirement.

Editing/Deleting a Safety Classification

1. Right-click on a safety classified requirement.

2. Choose Edit/Remove safety level.

→ The safety level was edited or removed.

ASIL Decomposition
SOX supports ASIL decomposition according to ISO26262. An ASIL decomposition can be
performed on safety goals and requirements with safety classification.

Safety Goals

The ASIL decomposition of safety goals can be performed in the views "Project Safety Goal", "PSS",
"Model Explorer (Diagrams)" and " Object list".

Precondition: The safety level of the safety goal must be defined in the ISO26262 (ASIL).

1. Right-click on a safety goal.
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fig. Context menu for decomposing a safety goal.

2. Choose Decompose > and your desired decomposing level.

The context menu shows all possible decompositions. If you are not at the lowest level you can
do further compositions.

→ The new created safety goals will be named with "A_", "B_" and provided with the new and parent
safety level.
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fig. Safety goal decomposition.

Safety Classified Requirements

The ASIL decomposition of requirements can be performed in the views "Hierarchy", "PSS", "Model
Explorer- (Diagrams)" and "Object list".

Precondition: The requirement must be safety classified.

1. Right-click on a requirement.

fig. Decomposing a requirement.

2. Choose Decompose > and your desired decomposition level.

The context menu shows all possible decompositions. If you are not at the lowest level you can
do further compositions.

→ The new requirements will be named with "A_", "B_" and provided with the new and parent safety
level.

267



Requirements

fig. Requirement decomposition.

SysML Example
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fig. Decomposition of a requirement in a diagram.

fig. Decomposition of a requirement in the model explorer.

Deleting a Decomposition

1. Right-click on a decomposed requirement or safety goal.

2. Choose Decompose > Delete decomposition.

► A dialog opens, asking if you confirm deleting the child elements.

3. Click on Yes.

► The "Refactoring" dialog opens.

4. Click on Finish.

→ The decomposition has been deleted.

Importing Files
You can import requirements from an Excel file or ReqIF formats. Furthermore ReqIF documents can
be merged.

Importing an Excel File

Precondition: A requirement document was created and is active. The Excel file has a requirement
identifiers column (Id's) for mapping the sheet with SOX.

1. In the menu bar, open File.

2. Choose Import > Import Excel.

► The Excel import wizard opens.
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fig. Excel File Selection.

3. Click on Browse... to choose the desired file.

4.
Click on the plus symbol ( )to create a new import configuration or select an existing one.

This configuration will be saved an can be used for further imports.

5. Click on Next.
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fig. General Settings.

6. Choose the sheet [1] of the Excel file that should be imported.

7. Choose the starting cell [2] which declares the beginning of the requirement table.

8. Choose the requirement identifiers column which declares the ID of each requirement.

fig. Excel sheet example.

9. Click on Next.

fig. Requirement Type Mapping.

10.If all attributes are defined in one requirement type, set a default requirement type. With the plus

symbol ( )you can create a new requirement type.

11.Create for each column the mapping between the Excel Type and the SOX type if there is no default
type.
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fig. Requirement Type Mapping Example.

12.Click on Next.

fig. Attribute Mapping.

13.Double-click into the "SOX Attribute" column and the according row to set the desired SOX
attribute. Also the enumeration of an attribute hast to be mapped.

14.Click on Next.
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fig. Hierarchy Mapping.

15.Optionally you can select an Excel column where the requirements hierarchy is mapped. The
hierarchy can be described by indent or contained dots (e.g. 1.2.1).

16.Click on Finish.

→ An Excel file was imported and will be added as a requirement module.

Importing a Requirement Document
Precondition: A SOX project was created and the Repository view is active.

1. Right-click in the Repository view on the RM folder.
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fig. Import RM from the Repository View.

2. Choose Import.

► The Import wizard opens.

fig. Import wizard.

3. Select Requirements Import. Possible versions are: (ReqIF 1.0.1, RIF 1.1a, RIF 1.2).

4. Click on Next.
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fig. Requirements Import.

5. Click on Browse to choose RM as the target folder.

6. Click on Browse to select the desired file.

7. Enter a filename.

8. Select the desired modules.

9. Click on Finish.

→ A requirement document was imported.

Merging Requirement Documents

Precondition: A requirement document was created and is opened.

1. Open the menu bar point File.

2. Choose Import > ReqIF format.

► The dialog "Requirements Import" opens.
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fig. "Requirements Impor"t dialog.

3. Click on Browse to choose the requirement document from SOX.

4. Click on Browse to choose the file that should be merged.

5. Select the desired modules.

6. Click on Finish.

→ The requirement file was merged into the chosen document.
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