
 
 
 
ENCO SOFTWARE GMBH I Lortzingstr. 9 I D-81241 MÜNCHEN 

 

FMEA User Guide 

Inhalt 
Introduction 3 

Step-by-Step-Guide 3 

Creating a new FMEA file 4 

Creating System Elements 5 

Process FMEA 6 

Adding Functions to a System Element 6 

Adding Malfunctions to a Function 9 

Connecting Functions/Malfunctions 10 

Editing the FMEA Structure 11 

Moving Objects 11 

Copying Objects 11 

Deleting Objects 11 

Deleting Connections between Functions/Malfunctions 11 

Adding Safety Goals to a Function 12 

Creating Action Groups 13 

Defining Prevention and Detection Actions 14 

Rating Malfunctions and Action Groups 16 

Rating severity (S) of malfunctions 16 

Classifying malfunctions and functions 17 

Rating occurrence (O) and detectability (D) of action groups 18 

Current state and target state 20 

Adding Tasks 20 

Creating a Form Sheet 22 

FMEA-MSR (Monitoring and System Reaction) 23 

The hybrid failure net 23 

Creating a hybrid net 23 

The User Interface 26 

Setting Preferences 26 

Preferences menu 26 

Document properties 27 

The FMEA Perspective 27 



 

EnCo Software GmbH FMEA User Guide 
(Release v3.3.0) 

March 5, 2021 

 

FMEA Editor 28 

Structure content view / Clipboard / Project System Structure (PSS) 28 

Project safety goals 29 

Function net / Failure net 29 

Model Explorer / Catalogs / Object List 29 

The Form Sheet Editor 29 

The new form sheets: DFMEA / PFMEA 29 

Additional Functionality 31 

Using Control Plans 31 

Creating a Control Plan 31 

Editing a Control Plan 32 

Creating and editing Control Method and Reaction Plan 36 

 

 



 

EnCo Software GmbH FMEA User Guide 
(Release v3.3.0) 

March 5, 2021 

 

Introduction 

The Failure Mode and Effects Analysis (FMEA) is a qualitative and systematic risk analysis method. 

Starting with a system structure (structure tree) you assign functions and malfunctions to system 

elements, create a function and failure net, assess the risk, and assign and track tasks.  

The FMEA module of SOX supports analysis according to the new AIAG & VDA FMEA Guide (2019). 

Features: 

• Work with different variants and operation statuses. 

• Exchange information with other SOX modules. 

• FMEA analysis including risk matrix, malfunction analysis and Pareto analysis. 

• Create form sheets and control plans. 

• Derive control plans from process FMEA. 

• Perform FMEA-MSR 

• Customizable user interface. 

An easy step-by-step guide will help beginners of SOX to quickly get familiar with the tool. 

Step-by-Step-Guide 

In this chapter you will learn the basics of the module, while creating a simple FMEA, from start to 

finish. 

We recommend going through this guide and performing all the steps necessary to create a simple 

FMEA to get real understanding of the software. This chapter requires knowledge on the basic SOX 

principles and standard views described in section   
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The User Interface. 

Creating a new FMEA file  

Precondition: A SOX project was created and the Repository view is active. 

1. Go to the Repository view and right-click on the ATA folder in the project. 

 

fig. 1 New FMEA file context menu 

2. Choose New > New FMEA File 

 ► The “Create new FMEA” Dialog opens. 

3. Click on Browse… next to “Target folder”. 

4. Choose the desired folder. 

5. Enter a name for the FMEA file. 

6. You need to define a system element that acts as the root of your FMEA. 

a) Define a new root element by entering a name for it. 

b) If you already have an element in your project that you want to use as a root element: Choose 

an existing root element by clicking on Browse... next to "Root Element" and clicking on your 

element of choice in the list. 

7. Define an interface container (optional) 

8. Choose the type of FMEA that you want to create ("PRODUCT"; "PROCESS"; "DESIGN"; 

“AP_PROCESS”; “AP_DESIGN_MSR”). 

Note: To carry out an FMEA in accordance with AIAG & VDA FMEA Guide choose one of the types 

“AP_PROCESS” or “AP_DESIGN_MSR”. 

9. Choose the ratings catalog (you may define your own catalogs in the Catalogs view). 

10. The field “Description” is optional and can be used for detailed descriptions of the FMEA 

document. 

11. Click on Finish. 

► An FMEA file was created and added to the repository. 
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fig. 2 Create new FMEA dialog 

 

Creating System Elements 

Precondition: An FMEA document is selected and a root element was created. 

Note: There are multiple views in which you can create new objects. The result will always be the same, 

regardless of doing it in the FMEA editor or another view. 

 

fig. 3 New system element 

1. Right-click on the root element. 

2. Choose New > New system element. 
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 ► The "Add new system element" dialog opens. 

 

3. In the first line, "Add", make sure "System element" is selected. 

4. Enter a name for the new system element. 

5. The sequence number of the system element can either be determined automatically by SOX 

with a consecutive number or you enter your own sequence number (optional). 

6. Type a description into the "Description" box (optional). 

7. If you are working with variants in your project, you can assign the new system element to a 

variant. Click on Variants and choose one (optional). (See also the chapter Working with 

Variants.) 

8. If you want to add another system element, click on Save & New. 

9. When you are done adding elements, click on OK. 

► The new system elements were added. 

Now add lower level system elements: Just repeat the process, starting with a right-click on the parent 

system element. 

Process FMEA 

For a process FMEA you may choose “Process element” in step 2 of previous section. This is of special 

importance for elements containing product or process characteristics. With process elements defined 

you can derive a control plan from process FMEA. 

Note: System elements can be converted to process elements and vice versa by right-clicking on an 

element and choosing “Convert” from context menu. 

Adding Functions to a System Element 

Precondition: An FMEA document is selected, the editor is active and system elements were created. 
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Note: There are multiple views in which you can select a system element and add functions to it: The 

FMEA editor, the structure content view, and the PSS view. The result will always be the same. 

1.  Right-click on the system element. 

 

 

fig. 4 New function 

2. Choose New > Function. 

 ► The "Add new function" dialog opens. 

 

fig. 5 “Add new function” dialog 



 

EnCo Software GmbH FMEA User Guide 
(Release v3.3.0) 

March 5, 2021 

 

 

3. In the first line, "Add", make sure "Function" is selected. 

4. Enter a name for the new function. 

5. The sequence number of the function can either be determined automatically by SOX with a 

consecutive number or you enter your own sequence number (optional)). 

6. Type a description into the "Description" box (optional). 

7. Choose the function type (function, diagnosis, safety function, product characteristics, process 

characteristics, etc.). The standard type is "function". Choosing "diagnosis" adds another tab 

to the dialog, giving you the option to add more attributes regarding diagnosis. 

8. If you want to add another function, click on Save & New. Otherwise click OK. 

► The functions were added. 

Further explanation of the "Add Function" dialog: 

Under the tab "Functions" you can see if there are other functions already added to this system 

element. Under the tab "Variants" you can assign the function to an existing variant (if you already 

have variants; see also the chapter Working with Variants). Under "Catalog" you can see all functions 

of your project. 
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Adding Malfunctions to a Function 

Precondition: An FMEA document is selected, and system elements were created having at least one 

function. 

Note: There are multiple views in which you can create new objects or edit them. The result will always 

be the same, regardless of doing it in the FMEA editor or another view. 

1.  Right-click on a function. 

 

 

fig. 6 New malfunction 

2. Choose New > Malfunction. 

 ► The "Add new malfunction" dialog opens. 

 

fig. 7 “Add new malfunction” dialog 
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3. Enter a name for the new malfunction. 

4. The sequence number of the malfunction can either be determined automatically by SOX with 

a consecutive number or you enter your own sequence number (optional)). 

5. Type a description into the "Description" box (optional). 

6. If you want to add another malfunction, click on Save & New. Otherwise click OK. 

→ The malfunctions were added. 

Connecting Functions/Malfunctions 

Creating a function net and creating a failure net both work the same. You connect a function to 

another function, or a malfunction to another malfunction respectively, by drag & drop: 

1. With the mouse cursor over a function, press the left mouse button and hold it. 

► The function is highlighted with a yellow background. 

2. Move the cursor over that function that you want to connect it to. 

► Next to the cursor a rectangle and a plus sign appear:  

3. Move the cursor to the left and to the right: You will notice that the function´s background 

becomes yellow either to the left or to the right side. To connect a function with a lower level 

system element, the background has to light up on the right (facing the function it connects 

to). 

 

fig. 8 Connecting functions 

4. Release the mouse button. 

► The icons next to the two functions´ names change: They now also have two smaller dots, 

pointing to the other function:  

► The two functions are now connected. 

Do the same with the malfunctions. 

Now that you have connected the (mal)functions, you can see them (and work with them!) in other 

views: 

• The Function net explorer and Failure net explorer: 

The Function net explorer and Failure net explorer show hierarchical structures (top-down) 

of the system elements and functions / malfunctions. 

• The Function net / Failure net views: 

These two views show how a function or malfunction is connected to others. Just double-
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click on a function / malfunction in the editor and the respective view shows how it is 

connected to the others. 

For more information on these views, read the respective chapters: 

• Function net view 

• Failure net view 

• Function net explorer 

• Failure net explorer 

Editing the FMEA Structure 

Moving Objects 

In the FMEA editor you have the possibility to restructure the objects. For this you can change the 

position of system elements, functions and malfunctions with drag and drop. 

You can also move several objects at once. For this you need to hold the Ctrl key, click on the elements 

you want to select and then drag them to the desired target position.  

Copying Objects 

To copy objects, you have the following possibilities: 

• In the editor you can copy an object with drag and Ctrl + drop. You need to drag the selected 

object to the desired position and then press Ctrl when you want to drop the object. In that 

way a copy will be saved at the target location. 

• Right-click and choose the options Copy or Paste. 

• Select the object you want to copy. Press the key combinations Ctrl + C to copy an object and 

Ctrl + V to paste it again at the desired location. 

► Within the PSS you can make copies in the same way. 

• With Drag and Ctrl + drop you can also copy objects from the PSS to the editor. 

• It is also possible to copy several objects at once. Select the desired objects while holding 

pressed the Ctrl key and then copy them. 

Deleting Objects 

In any view, you have the following options to delete an object: 

• open the context menu with a right-click on the object and then click on Delete. 

• select the object by clicking on it, then press the Del key. 

You can select multiple objects at once by pressing the Ctrl key while selecting further objects. 

When deleting there will always appear the "Refactoring" dialog, which informs you of the changes 

regarding the objects´ connections in the SOX project. Using the check boxes, make sure that only the 

desired objects will be removed, then click on Finish. 

Deleting Connections between Functions/Malfunctions 

After you created a function net or failure net (see Connecting Functions and Malfunctions) you can 

delete connections between (mal)functions in the function net view and the failure net view. 

Here you can delete connections in two ways: 
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• open the context menu with a right-click on the line between two (mal)functions and then click 

on Delete. 

• select the line by clicking on it, then press the Del key. 

 

If the threat evaluated in ATA is used in column “Threat” / “Threat Scenario” of the TARA the attack 

feasibility rating is adopted in TARA. 

Note: It is possible to manually overwrite the propagated feasibility level at each gate. If doing so, the 

feasibility needs to be propagated to the top-level again. 

 

Adding Safety Goals to a Function 

Precondition: The "Project safety goal’s view needs to be open and contains safety goals. If the view is 

not already open, click on Window in the menu bar, then Show view > Project safety goals. Usually, the 

safety goals are defined in the Requirements module, but you can also add new safety goals here by 

right-clicking in the "Project safety goal’s view. 

Use drag & drop to add a safety goal to a function: 

1. In the Project safety goals view, click on your safety goal and hold the mouse button. 

2. Move the cursor to the desired function. 

► Next to the cursor, a rectangle and a plus sign appear. 

 

fig. 9 Adding safety goal 

 

3. Release the mouse button. 

► The safety goal is added to the function. 
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Creating Action Groups 

Note: There are multiple views in which you can create new objects or edit them. The result will always 

be the same, regardless of doing it in the FMEA editor or another view. 

To assign actions to a malfunction you need to add an action group first. Action groups consist of 

construction actions and operation actions. Construction actions are used in design and process FMEA, 

whereas operation actions are used in FMEA-MSR (see chapter FMEA-MSR - Monitoring and System 

Reaction). Construction actions are preventive actions and detection actions rated by occurrence (O) 

and detectability (E), respectively. After adding actions to the action group, you do the rating for 

occurrence and detectability. 

Adding a new action group: 

1. Right-click on a malfunction. 

 

 

fig. 10 Context menu “New” on malfunction 

2. Choose New > New Action Group. 

► The "New action group" dialog opens. 

 

fig. 11 New action group dialog 

3. Enter a name for the new action group. 

4. With the check box, decide if you want to assign the new action group to all malfunctions on 

the same level. 

5. Click OK. 

► A new action group was added and assigned to the malfunction. 
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► A triangle appears next to the malfunction:  

If you did not assign the new action group to all malfunctions of the same structure layer, you still have 

the option to do this afterwards: 

Right-click on an action group, then choose New > Assign to all malfunctions of the same layer. 

 

fig. 12 Context menu “New” on action group 

 

SOX offers the possibility to use revision states multiple times once they have been established. 

In that way, you can assign one action group to several malfunctions. 

Adding an existing action group: 

 

fig. 13 Adding an existing action group 

1. Right-click on a malfunction. 

2. Choose New > Action Groups and then your desired action group. 

► The action group has been added to the malfunction. 

 

Defining Prevention and Detection Actions 

For design and process FMEA you define construction actions, i.e. prevention and detection actions. 

Note: There are multiple views in which you can define actions or edit them. The result will always be 

the same, regardless of doing it in the FMEA editor or another view. 

Adding a new action: 

• In the container “Construction actions” of an action group right-click on “Occurrence” or 

“Detection”. 
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• fig. 14 Context menu “New” on Occurence 

• Choose Prevention action or Detection action from context menu. 

 ► The "Assign task to: …" dialog opens. 

 

fig. 15 “Assign task to: …" dialog 

 

• Enter a name for the new action. 

• Enter a description (optional). 

• Set the status. 

• Set the priority. 

• Set the correct dates. 

• Assign a responsible person. 

c) Choose an existing one by typing the name and selecting from the drop-down menu. 

d) Or click on … to the right to select company, department (optional) and employee. 

e) Or click on … to add a new company, department (optional) and employee. 

• Click Finish. 
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Rating Malfunctions and Action Groups 

The following ratings are possible: 

• Severity rating (S) for malfunctions 

• Occurrence rating (O) for prevention actions  

• Detection rating (D) for actions  

Rating severity (S) of malfunctions 

Note: The ratings that are available depend on the ratings catalog that you chose. 

Editing the significance (or severity) rating of a malfunction: 

1. In the editor or any other view, right-click on a malfunction. 

 

fig. 16 Context menu “Edit significance rating” on malfunctions 

 

2. Select the rating or click on Select… . 

► The dialog "Properties for Malfunction" opens. 
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fig. 17 Dialog “Properties for Malfunction - Significance rating” 

 

3. Choose a rating. 

4. Click on Apply and Close. 

► The malfunction now has a rating. 

Classifying malfunctions and functions 

You can add a classification to a cause of failure. If you do so, the classification is shown the 

corresponding column of the form sheet. 

Note: It depends on the type of form sheet whether the column for classification is shown or not. 

Adding a classification: 

1. Right-click on a function or malfunction. 

 

fig. 18 Context menu “Edit classification” on malfunction 

2. Select the classification or click on Select… . 



 

EnCo Software GmbH FMEA User Guide 
(Release v3.3.0) 

March 5, 2021 

 

► The dialog "Properties for Malfunction" opens. 

 

fig. 19 Dialog “Properties for Malfunction – Classification” 

 

3. Choose from one of the following: 

NC: Not classified 

S: Safety compliant 

CC: Critical characteristic 

PC: Potential critical characteristic 

SC: Significant characteristic 

PSC: Potential significant characteristic 

4. Click OK. 

► A classification has been added. 

 

Rating occurrence (O) and detectability (D) of action groups 

Note: After adding a new action group the rating for occurrence (O) and detectability (D) is set to 10 

by default. 

To rate the actions in your new group: 

1. Click on the triangle next to the malfunction. 

You see the assigned action group(s). 

2. Click on the triangle next to the action group. 

► The list of actions expands. 

► You will see two types of actions: "Construction actions" and "Operation actions". 

Construction actions are used in design and process FMEA, whereas operation actions are used 

in FMEA-MSR (Monitoring and System Reaction). Operation actions are preventive actions and 

detection actions rated by occurrence (O) and detectability (E), respectively.  

3. Choose a rating and make a right-click on it to open the context menu. 
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fig. 20 Context menu “Edit prevention rating” on Occurrence rating 

 

4. Choose Edit prevention rating to open the context menu. 

5. Choose the rating directly or click on Select…. 

► The dialog for the occurrence rating opens. 

 

 

fig. 21 Dialog “Properties for Action group Prevention actions” – Occurrence  rating 

6. Choose a rating. 

7. Click Apply and Close. 

Rating detection actions works similarly starting with a right-click on Detection under Construction 

actions (fig. 20). 
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► Alternatively you can directly switch to the dialog for the detection rating by clicking on Detection 

rating in the „Properties for Action group…” dialog (fig. 21). 

► Make sure you repeated all this for construction actions, operation action and service action. 

► Your actions now have a rating. 

Current state and target state 

Generally different actions assigned to a cause of failure may have different status. Whereas some 

actions are already finished others may be active or in progress. Based on the set of actions and their 

individual status you may want to define a current state and a target state of rating. This can be done 

in two different ways. 

Using a single action group 

When using a single action group, the rating for the current state respective target state is set by 

the rating with respective without parentheses as shown in fig. 21: “Occurrence rating”, 

“(Occurrence rating)”, “Detection rating”, “(Detection rating)”. 

Using different action groups 

When using different action groups to express current and target state, only the rating without 

parentheses should be used. 

Note: The default values for the ratings without parentheses (current state) are 10, whereas the ratings 

in parentheses (target state) are set to 0 (undefined). 

 

Adding Tasks 

You can assign tasks to all objects (system elements, functions, requirements). These are shown in the 

window "project tasks". This is especially important for the construction actions, that are also handled 

as tasks (see section Defining Prevention and Detection Actions on page 14). 

Note: There are multiple views in which you can define tasks or edit them. The result will always be 

the same, regardless of doing it in the FMEA editor or another view. 

Adding a new task: 

1. Right-click on an object. 

2. Choose New > Task from context menu. 

 ► The "Assign task to: …" dialog opens. 
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fig. 22 “Assign task to: …" dialog 

 

3. Enter a name for the new task. 

4. Enter a description (optional). 

5. Set the status. 

6. Set the priority. 

7. Set the correct dates. 

8. Assign a responsible person. 

a) Choose an existing one by typing the name and selecting from the drop-down menu. 

b) Or click on … to the right to select company, department (optional) and employee. 

c) Or click on … to add a new company, department (optional) and employee. 

9. Click Finish. 

► The task has been added. 

The icon of a malfunction changes when a task has been added:  

All tasks are shown in the view "Project tasks". 

 

  



 

EnCo Software GmbH FMEA User Guide 
(Release v3.3.0) 

March 5, 2021 

 

Creating a Form Sheet 

Precondition: An FMEA was created containing focus elements with functions and malfunctions and 

function / failure net completed. 

Note: You can create a form sheet for system and process elements. If you have a process FMEA, read 

about control plans. 

Creating a form sheet: 

1. In the FMEA editor, structure content view or PSS right-click on a system element. You can also 

select multiple process elements by keeping the Ctrl key pressed down while clicking on the 

process elements. 

 

fig. 23 Context menu on system element 

2. Choose Open form sheet. 

► The "Form sheets" dialog opens. 

3. Choose an existing form sheet or create a new one. 

a) Click "Select existing" to choose from existing form sheets. 

b) Click "New" and enter a name for a new form sheet. 

► The form sheet editor opens. 

You can go back to the normal FMEA editor using the tab at the bottom of the editor. You can close 

the form sheet by clicking the X button in the form sheet tab at the bottom of the view. 
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For additional information on the form sheet editor go to section The Form Sheet Editor on page 29. 

FMEA-MSR (Monitoring and System Reaction)  

The risk analysis activities of a design FMEA usually focus on the design phase in order to achieve a 

robust and reliable design that meets the requirements specification. System reaction during 

operation is difficult to model and not covered completely.  

On the other hand, the FMEA-MSR is used to analyze systems with integrated monitoring functions 

and system reactions that become effective during operation. Usually, these systems are related to 

functional safety (ISO 26262) and/or legal requirements. If there are failure effects in DFMEA with 

severity rating of S=9/10 FMEA-MSR should be considered. The aim of FMEA-MSR is to account for 

alternative risk scenarios having reduce severity (S<9!) accomplished by monitoring and system 

reaction during operation. 

FMEA-MSR is an addition to DFMEA and can be done in a separate FMEA document or integrated 

into an existing DFMEA document. 

The hybrid failure net 

In SOX the monitoring and system reaction is modeled by two special tyles of functions, the diagnosis 

function and reaction function. The modeling starts with the failure cause that is to be detected by 

the monitoring function. This is modeled by connecting the diagnosis function to the failure cause 

and reaction function to the diagnosis function. The reaction function is then connected to a failure 

on an upper level to model the alternative failure path leading to a failure effect of lower severity. In 

short, the failure cause is connected to a chain of functions (diagnosis, system reaction) flowing into 

a chain of malfunctions ending at upper-level failure effect. This structure is called a hybrid chain of 

effects or hybrid net. Within this hybrid net the chain of functions represent a signal path, whereas 

the malfunctions belong to the hierarchical structure of the system that is modeled in FMEA as a 

structure tree. 

Creating a hybrid net 

In the example system (fig. 24) the power train of a vehicle consists of the engine, a fuel injector, and 

a control unit, where the control unit provides monitoring of correct function of the fuel injector. If 

too much fuel is injected into the engine (cause of failure), the torque provided to the wheels of the 

vehicle is large (failure mode) resulting in unintended acceleration (failure effect). This effect may 

lead to dangerous situation and thus is rated by a severity of S=10. The monitoring function of the 

control unit should detect the malfunctioning behavior and initiate proper system reaction for risk 

mitigation. 

 

fig. 24 Example system for FMEA-MSR 
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fig. 25 Part of failure net 

In SOX monitoring and system reaction is represented by a diagnosis function and reaction function, 

respectively. 

Note: The procedure of adding functions to system elements is described in detail in section Adding 

Functions to a System Element on page 6. 

Adding a diagnosis function: 

1. Right-click on the system element you want to add a diagnosis function to. 

2. Choose New > Diagnosis Function from context menu. 

► The “Add new function to …” dialog opens. 

3. Enter a name and a code. 

4. Enter a description and values for diagnostic coverage (optional). 

5. Click OK. 

► The diagnosis function is added to the system element. 

Next link the diagnosis function to the cause of failure by drag and drop as described in section 

Connecting Functions/Malfunctions on page 10. The icon next to the diagnosis function name changes 

to indicate the link. Additionally, the link is listed in “Diagnosis targets” located under the diagnosis 

function. Click the small triangle to show the content. 

 

fig. 26 Diagnosis function and connected target 

In a similar manner you model the system reaction by adding a reaction function and connecting it to 

the diagnosis function. 

Adding reaction function: 

1. Right-click on the system element containing the diagnosis function. 
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2. Choose New > Reaction Function from context menu. 

► The “Add new function to …” dialog opens. 

3. Enter a name. 

4. Enter a description (optional). 

5. Click OK. 

Next you need to link the reaction function to the diagnosis function as well as to the failure effects of 

reduced severity. These represent the intended behavior in case a failure is detected. As before the 

connection is done by drag and drop (see section Connecting Functions/Malfunctions on page 10). The 

icon next to the reaction function name changes to indicate the link. Additionally, the links to the 

failure effects are listed in “Safe paths” located under the reaction function. Click the small triangle to 

show the content. 

The resulting hybrid net is shown in fig. 28. The upper branch represents the failure net without 

detection, whereas the lower part shows the intended system reaction if the failure cause is detected. 

 

fig. 27 Example system with diagnosis and reaction function 

 

fig. 28 Hybrid net showing the path with and without failure detection 

You can add an action group to the failure cause as described in section Creating Action Groups on 

page 13. Operation actions are rated by parameters frequency (H) and monitoring (M). The rating is 

done in a similar manner as described in section Rating Malfunctions and Action Groups on page 16.  
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The User Interface 

Setting Preferences 

Preferences for FMEA addressing different aspects can be set in the preferences menu and in FMEA 

document properties. 

Preferences menu 

You can open the preferences menu either from the menu bar (Edit > Preferences), or by making a 

right-click in the editor. 

Then the dialog with all the settings for SOX opens: 

 

fig. 29 Preferences dialog 

When you click on FMEA you can see the General Editor Settings: 

• Figure width: You can choose the width of the boxes representing the elements in the FMEA 

editor. Possible values are 100 to 999. 

• Set a check mark to allow animations. 

• Show comments as a tool tip: If you activate this, every comment will be shown as an overlay 

tool tip when the mouse cursor is above an object in the editor. 

Click on the triangle in front of FMEA, or double-click FMEA, then the list expands: 

• Form sheet / Control Plan: showing / hiding responsibilities and comments and adjusting the 

layout to fit the window width. 

o Form sheet: adjust the layout according to the catalogs, choose how many levels of 

effects are shown and how many levels of the causes are shown. 

• Structure details: Select the information to be shown. 

• For the "PSS" view you can filter what is shown and you can decide how the view expands 

when opening it and when adding parts. 

• You have filtering options for the function net view and the malfunction net view. 

• Action groups: you have options to decide whether the system will open dialogs to ask things 

in certain situations regarding action groups. 
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• Risk matrix: you have options to adjust the size and to hide columns. You can also change the 

style of the risk matrix from the VDA style (red, yellow, green) to the RG style (red and green). 

You can change the detection value split for the RG style. You can decide which squares of the 

risk matrix have which color. You do this by selecting a square, and then clicking on one of the 

buttons labeled with a color name. You can select multiple squares at once by holding Ctrl 

while clicking. 

• Pareto analysis: you can adjust the x- and y-axis and change the labeling of the axis and the 

diagrams title. You can also show grid lines. 

Document properties 

In repository view right-click on the project and choose Document properties to open the “Properties 

for Project …” dialog. On the left click on DFMEA Formsheet. 

On the right you see the mapping between action status and FMEA step 5 or 6. Select an entry and 

move it to the right or left by clicking the right/left arrow button. 

Note: It is recommended to assign status “finished” to step 5 (Risk Analysis) and leave all other in step 

6 (Optimization). If needed status “active” maybe moved to step 5 to indicate actions that are available 

for reducing the risk but are not finished. 

 

 

fig. 30 “Properties for Project …” dialog 

 

The FMEA Perspective 

To open the FMEA perspective go to the menu bar and click Window > Show Perspective > FMEA. 

Below you see all the standard views in the FMEA perspective. You can always open views by going to 

the menu bar and clicking Window > Show View. You can also rearrange the views by drag & drop. 
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fig. 31 Standard views of the FMEA perspective 

[1] FMEA Editor 

[2] Structure content view / Clipboard / Project System Structure (PSS) 

[3] Project safety goals 

[4] Function net / Failure net 

[5] Model Explorer / Catalogs / Object List 

FMEA Editor 

The FMEA editor shows all process and system elements of an FMEA document. You can also see the 

associated functions, malfunctions, product and process characteristics, diagnosis functions, as well as 

requirements and project safety goals assigned to elements and (mal) functions. It is possible to create 

and edit most of these objects right here in the editor. 

Note that you can edit some general settings for the FMEA editor in the preferences menu: 

• Choose the width of the boxes representing the elements. 

• Enable / disable animations. 

• Show comments as a tool tip: If you activate this, every comment will be shown as an overlay 

tool tip when the mouse cursor is above an object in the editor. 

For more information on FMEA editor please read SOX User Guide. 

Structure content view / Clipboard / Project System Structure (PSS) 

Please go to online help and check for user guides (PDF) and video tutorials. Online help will be updated 

continuously.  
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Project safety goals 

Please go to online help and check for user guides (PDF) and video tutorials. Online help will be updated 

continuously.  

Function net / Failure net 

Please go to online help and check for user guides (PDF) and video tutorials. Online help will be updated 

continuously.  

Model Explorer / Catalogs / Object List 

Please go to online help and check for user guides (PDF) and video tutorials. Online help will be updated 

continuously.  

 

The Form Sheet Editor 

The form sheet editor provides an overview of action groups, prevention and detection actions, their 

status, and the rating for the action groups. You can edit objects in the form sheet. You will see these 

changes immediately in the FMEA editor. 

If you have not created a form sheet yet, read chapter Creating a Form Sheet on page 22. 

SOX v3.3 provides three different types of form sheets: 

• VDA RPZ 

• DFMEA 

• PFMEA 

VDA RPZ corresponds to the old standard of VDA 4.2. Choosing DFMEA or PFMEA you get the new 

layout in accordance with new AIAG & VDA FMEA Guide (2019). 

Choose the layout from drop down list Layout at the upper right corner of the FMEA editor. 

 

 

The new form sheets: DFMEA / PFMEA 

With the new standard form sheet FMEA the risk analysis (step 5) and optimization (step 6) are 

arranged side by side. The action group spans over both sections. It depends on the status of an action 

whether it shows up in “Risk Analysis” or “Optimization”. This behavior can be tuned by setting 

preferences (see section Setting Preferences on page 26). It is recommended that action status finished 

is associated with step 5 “Risk Analysis”, all other with step 6 “Optimization”. 

Current state and target state 
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The ratings in step 5 and step 6 correspond to the current state and target state, respectively. How to 

set these ratings is described in section Current state and target state on page 20. The default values 

for the current state is O=E=10 and for target state it is (O)=(E)=0 (undefined). The AP rating is set 

accordingly. If any of the ratings S, O, E is undefined the AP rating is set to undefined shown as “U”. 

Action status “finished” 

Whenever an action in “Optimization” is set to finished, the action will be moved to “Risk analysis” and 

the “Adjust rating” dialog appears. You have three options: 

• Adopt proposed values: The target rating is adopted by current rating. 

• Do not adjust: The ratings are kept the same. 

• Open rating dialog: Adjust the rating manually.  

 

fig. 32 “Adjust rating” dialog 
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Additional Functionality 

Using Control Plans 

A control plan is a detailed document linking manufacturing process steps to key inspection and control 

activities. A control plan lists all product and process inspection points required to minimize errors in 

production and is essential for maintaining process control over the long run. 

A control plan is usually developed based on an existing process flow diagram or system structure. 

Creating a Control Plan 

Precondition: A PFMEA was created containing process elements on two levels with product 

characteristic on the higher level and process characteristic on the lowest level. Process characteristics 

must be connected to product characteristics (function net). 

Note: To generate a control plan, the document type must be PROCESS / AP_PROCESS! 

To change the document type, right-click somewhere in the FMEA editor. Then select Document 

Properties (or in the menu bar: File > Document properties). The properties dialog will appear. Choose 

the document type PROCESS / AP_PROCESS. You can also change the document type by right-clicking 

on the FMEA project name (under the FMEA file of the project while in the SOX Workbench/PSS view) 

and then selecting Properties. 

 

fig. 33 “Properties for FMEA document” dialog 

 

Note: You can create a control plan for process elements only. 

To convert system elements to process elements right-click on a system element and choose Convert 

> Convert to process element from context menu. 

Creating a control plan: 

1. In the FMEA editor, structure content view or PSS right-click on a process element. You can also 

select multiple process elements by keeping the Ctrl key pressed down while clicking on the 

process elements. 
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fig. 34 Context menu on process element 

2. Choose Open Control Plan. 

► The "Control plans" dialog opens. 

3. Choose an existing control plan or create a new one. 

a) Click "Select existing" to choose from existing control plans. 

b) Click "New" and enter a name for a new control plan. 

► The control plan editor opens. 

You can go back to the normal FMEA editor using the tab at the bottom of the editor. You can close 

the control plan by clicking the X button in the control plan tab at the bottom of the view. 

Editing a Control Plan 

Changing the Name of a Control Plan 

You can change the name of the control plan by finding the control plan file in the PSS view and double-

clicking on it. 

The control plan file can be found in the PSS view in your project under the name of the FMEA file and 

then under Control Plans. 

Adding or Editing a Machine 

Note: Machines must be defined in a (public) catalog for assigning machines to the process element. 

To learn how to work with catalogs please read section “Catalogs” in the SOX User Guide. 

To create a catalog or edit the content of a catalog go to folder Public > Machine in the "Catalog" view. 

To edit an existing catalog, double-click on it. A new tab in the editor opens showing the content of the 

catalog. In the field “Catalog” on the left either select the catalog or an item.  In the field “Catalog 

details” on the right you can edit the catalog ID as well as name and description of the catalog and 

items. To add an item, select the catalog and click the “Add new machine” icon to open the “Add new 
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Machin to …” dialog. You can also delete an item by selecting it and clicking the red cross icon. To save 

the changes click somewhere. 

To add a new catalog right-click on folder Machine in "Catalog" view and choose New > Machine 

Catalog. The “Machine Catalog” dialog appears. Choose the target folder for the new catalog, enter 

ID, name, and description, and click Finish. 

Assigning a new machine to a process element: 

1. In the FMEA editor, structure content view, PSS or in the control plan right-click on a process 

element. 

2. Choose New > Machine from context menu. 

► Assign Machine dialog appears. 

 

fig. 35 “Assign Machine” dialog 

3. Choose a catalog. 

4. Choose an item. 

5. Click OK. 

If the machines catalog is empty, click on the green plus icon. The “New Machine” dialog will appear 

where you can enter the name and a description of the machine. 

If there is no catalog available, click on the green plus icon right to the “Catalog” field to open the 

“Machine Catalog”. 

Editing assignment of machines: 

1. In the FMEA editor, structure content view or PSS right-click on a process element. 

2. Choose Edit Machines from context menu. 

► The “Properties for …” dialog appears. 
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fig. 36 “Machine” dialog 

3. Add or delete a machine by clicking New or Delete. 

4. Click Apply and Close. 

You can enter more than one machine for each process. 

Adding/Editing Characteristics 

Adding Characteristics in the Control Plan: 

To add a product / process characteristic right-click on the process element and choose New > Product 

/ Process Characteristic. A dialog will appear where you can enter the name of the characteristic and 

edit it. 

Note: Product and process characteristics should be used on different levels with the process 

characteristics on the lower level, typically the lowest. 

Editing Characteristics in the Control Plan: 

To edit an already existing characteristic right-click on it and then click on Edit Process/Product 

Characteristics. 

If you only want to rename the characteristic, you can double-click on it. 

Adding/Editing Specification and Tolerances 

Please go to online help and check for user guides (PDF) and video tutorials. Online help will be updated 

continuously.  

Editing Classification 

To edit the field "Classification", you can just double-click on it. A drop-down list will appear where you 

can choose the classification of the element. 

Adding/Editing Inspection Equipment 

Note: Inspection equipment must be defined in a (public) catalog for assigning equipment to the 

product or process characteristic. To learn how to work with catalogs please read section “Catalogs” 

in the SOX User Guide. 

To create a catalog or edit the content of a catalog go to folder Public > Inspection Equipment in the 

"Catalog" view. To edit an existing catalog, double-click on it. A new tab in the editor opens showing 

the content of the catalog. In the field “Catalog” on the left either select the catalog or an item.  In the 
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field “Catalog details” on the right you can edit the catalog ID as well as name and description of the 

catalog and items. To add an item select the catalog and click the “Add new inspection equipment” 

icon to open the “Add new Inspection Equipment …” dialog. You can also delete an item by selecting 

it and clicking the red cross icon. To save the changes click somewhere. 

To add a new catalog right-click on folder Inspection Equipment in "Catalog" view and choose New > 

Inspection Equipment Catalog. The “Machine Catalog” dialog appears. Choose the target folder for 

the new catalog, enter ID, name, and description, and click Finish. 

Assigning a new Inspection Equipment to a product or process characteristic: 

1. In the FMEA editor, structure content view, PSS right-click on the characteristic or right-click 

in a cell in column “Inspection equipment” in the control plan. 

2. Choose New > Inspection equipment from context menu. 

► Assign Inspection equipment dialog appears. 

 

fig. 37 “Assign Inspection equipment” dialog 

3. Choose a catalog. 

4. Choose an item. 

5. Click OK. 

Alternatively, you can choose an inspection equipment by double-click in a cell in column “Inspection 

equipment” in the control plan. 

 

Here you have two options: 

• Choose an inspection equipment from the list. You can filter the content of the list by clicking 

“Select choice lists …” and select one or more catalogs. 

• Create a new item by clicking “+Add list entry … “. In the dialog choose a catalog and enter a 

name, then click OK. 
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Setting Sample Size and Frequency 

Note: To set sample size and frequency an inspection equipment needs to be assigned to the 

characteristic. 

There are two possibilities to set sample size and frequency: 

• Control plan editor: 

In the control plan editor double-click in the corresponding cell and type in the values. 

• Properties for inspection equipment: 

Right-click on a product or process characteristic and choose Properties from context menu. 

In the properties for inspection equipment all assigned equipment is shown in the table on 

the right. Here you can add or delete equipment and set values for sample size and 

frequency. 

 

Creating and editing Control Method and Reaction Plan 

Control methods and reaction plans are allocated to product and process characteristics and are 

handled as actions or tasks. The corresponding containers can be seen by clicking on the triangle to 

the left of a characteristic to expand all its children: 

 

 

Creating a control method / reaction plan: 

1.  In the FMEA editor, structure content view or PSS right-click on a product or process 

characteristic. 

 

fig. 38 Context menu on product or process characteristic 

2. Choose New > Control action / Reaction action. 
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► The "Assign task to: …" dialog opens. 

 

3. Enter a name for the new task. 

4. Enter a description (optional). 

5. Set the status. 

6. Set the priority. 

7. Set the correct dates. 

8. Assign a responsible person. 

a) Choose an existing one by typing the name and selecting from the drop-down menu. 

b) Or click on … to the right to select company, department (optional) and employee. 

c) Or click on … to add a new company, department (optional) and employee. 

9. Click Finish. 

► The control method / reaction plan has been added. 

The icon changes when a task has been added:  

 

To edit an existing control method or reaction plan right-click on the task and choose Edit from 

context menu. This can be done in the FMEA editor, structure content view, PSS or in the control 

plan editor. 


